colemak is broken

Bug #188308 reported by ethana2 on 2008-02-02
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-do (Kiwi Linux)
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Nominated for Dapper by ethаnа2

Bug Description

The colemak layout includes a mapping for key 66, which is the Wrong Way to add the backspace caps lock key behavior. This mapping should be removed from the colemak layout and a backspace caps behavior should be added to gnome, KDE, and xfce. While it would be nice if the colemak layout would default to this caps lock behavior, it's not crucial, as it's easy enough to just change it. It is possible that backspace would be the first caps lock behavior to require repeat.

ethana2 (ethana2) wrote :

Either that or have colemak just be for the keys and make a backspace option for caps lock that is set to true for colemak. That may be much more elegant a solution.

ethana2 (ethana2) wrote :

As of Tuesday, March 25, 2008, colemak on Ubuntu Hardy still does not function as documented.

I am now going to spread awareness of this bug amongst other ubuntu/colemak users in hopes that this gets fixed properly before the final release of Ubuntu 8.04.

uberstuber (james-stubers) wrote :

This occurs for me as well.

ethana2 (ethana2) wrote :

..I don't know exactly which package is responsible for this breakage though, could somebody clarify that for me?

I would like to see this fixed, it looks like /usr/share/X11/xkb/symbols/us is correct but the caps lock gets detected on another (lower) level. :(

I've decided that even people with non-colemak layouts may want to try
using caps as backspace. That behavior for the caps lock key needs to
be built in lower, and the actual layout should just leave the key
alone.

I have fixed the issue, I have added a "CapsLock acts as backspace" to the keyboard options and removed the remapping of the caps lock from the colemak configuration.
One thing that still bothers me is that the keyboard-capslock-inducator-light still switches when hitting caps lock. But that is not specific for this problem.
I will attach the patch if I find out how to make it correctly.

Hmm, I was wrong it is still not totally fixed. When using 1 layout it works but when having multiple layouts it does not :S

ethana2 (ethana2) wrote :

My family all uses qwerty, so I have to switch back and forth often.
Thomas, you rock.

Max Battcher (worldmaker) wrote :

I'm interested in a quick resolution of this bug as well. Colemak's preference of the Backspace over Caps Lock is something that is very useful and certainly unwieldy under current conditions in Ubuntu/Gnome.

fudderduds (fudderduds) wrote :

I would greatly appreciate a solution to this bug. I love Colemak and would like it to work properly.

ethana2 (ethana2) wrote :

Thanks, Drew.

16 days for this to get fixed before hardy goes out with a borked
colemak. We'll take every confirmation we can get, folks!

snailian (snailian) wrote :

I'm having the same issue. If we could get Thomas' fix in before the deadline, that would be most helpful.

Michael Dudalev (dudalev) wrote :

there is a discussion at forum.colemak.com about what's really broken in gnome-keyboard handling of capslock...

Feike (feikesteenbergen) wrote :

I also experience this issue on a freshly installed Hardy.
It only appears if you have multiple layouts installed.

With 1 layout installed the Caps-Lock acts as a backspace, and the Caps-Lock LED toggles.
With > 1 layout installed the Caps-Lock acts as a backspace AND Caps-Lock toggle. The Caps-Lock LED also toggles.

ethana2 (ethana2) wrote :

Alright, you can turn caps off with one line of text, but I forgot
what it was. My backspace is working great, and probably will
continue until i restart this machine.

It seems a basic fix should be quite trivial. Please, just add an
'off' in backspace behavior or something.
It may not be the most elegant, but whatever.

Chloe (bunnyfly) wrote :

The Colemak capslock is still broken. Has anybody figured it out? Thanks.

ethana2 (ethana2) wrote :

You can remove the lock and turn on the repeat fairly easily, but I
screwed up my X, so I have to do it every time I boot up, which is
ridiculous.

When Intrepid alpha one comes out, I'll be on it, and I'll be relaying
the status of its colemak implementation to this bug.

I think it's safe to say this is confirmed, so I'll change the status
of the bug now..

ethana2 (ethana2) wrote :

Wait nevermind, it already is confirmed...

Ah yes, the topic gmail gave the conversation didn't change to reflect that...

ethana2 (ethana2) wrote :

Ubuntu 8.10 alpha 4.
Colemak is not in the keymaps list at the livecd main menu (hit F4).
Colemak can be selected from the layouts under language -> english.
To make backspace repeat properly, type:
xset r 66

If you switch to qwerty, it turns the caps toggle back on and breaks
the layout for that session.
Logging out and back in does nothing but turns backspace repeat off again.

Again, the only proper solution to this problem is to remove the
awesome backspace from the colemak layout file and implement it
properly as a caps lock key behavior. That sounds like a feature, but
would primarily be a bugfix.

At any time, if the layout is colemak, it will be in working condition
with the following two commands:
xmodmap -e "remove lock = Caps_Lock"
xset r 66

It is recommended that until this bug is fixed, those commands be
added to a startup script of some sort as a workaround.

ethana2 (ethana2) wrote :

Quick note: before disabling Caps_Lock and setting key 66 repeat, be
sure that the current capslock state is /off/.

ethana2 (ethana2) on 2008-08-22
description: updated
description: updated
ethana2 (ethana2) wrote :

proper backspace caps lock behavior: still missing
layout: still contains backspace key
third level choosers: still not there

Colemak in Ubuntu 8.10 alpha 6: still borked.

On the plus side, I type at 85 words per minute now! That's gotta be like three times what my qwerty hunt-and-peck garbage was.

ethana2 (ethana2) wrote :

Props to the people who implemented the 'apply system wide' feature in
the keyboard layout manager though. That's bound to make my life
easier..

ethana2 (ethana2) wrote :

Ubuntu Jaunty alpha 3:

Still no colemak keymap option in the pre-load menu on the LiveCD.
To get colemak working in Jaunty, select country USA, variant Colemak, make it the only layout in the list, and hit 'apply system wide'. I gave up on proper repeating backspace, I don't think gnome loves us.

If you still use key repeat at all (I do not, mostly because of gnome's colemak problems),

xset r 66
will make it repeat.

Colin Watson (cjwatson) on 2009-06-02
affects: ubuntu → xkeyboard-config (Ubuntu)
ethana2 (ethana2) wrote :

Thanks, Colin; I was having a hard time placing this, as I'm unfamiliar with Ubuntu's keyboard-related infrastructure.

I'll update this bug if and when I test the next ubuntu alpha release.

description: updated
ethana2 (ethana2) wrote :

Do not edit my bug descriptions, troll.

description: updated
ethana2 (ethana2) on 2009-06-09
Changed in gnome-do (Kiwi Linux):
status: New → Invalid
Jean-Pierre Rupp (xenog) wrote :

I don't think is OK to mark this bug as invalid, I still have this problem with the latest and greatest Ubuntu 9.10.

Justyn Butler (justyn) wrote :

This is only marked as invalid in gnome-do.

It seems to be a confirmed bug in xkeyboard-config.

Justyn Butler (justyn) wrote :

Is this really a bug in xkeyboard-config, the keyboard configuration files?

I don't think so. The layout works fine if used as the default and only layout in gnome-keyboard-properties (except for the issue that the key doesn't repeat).

The problem occurs if trying to switch between layouts in gnome-keyboard-properties...the caps lock behaviour is not properly set in this situation.

I find that if I start off with colemak as the default and switch to a standard layout using the applet then the colemak caps lock behaviour (as backspace) persists. If however I start off with a standard layout and switch to colemak I get the strange bug where the caps lock key is both caps lock and backspace at the same time.

Perhaps this is a bug in gnome-keyboard-properties.

ethana2 (ethana2) wrote :

My main problem now is that colemak isn't in the keyboard options on the LiveCD keyboard menu, so I can't change layout until I boot it up, which takes longer.

Edward Liaw (chrono2200) wrote :

This was bugging me, so I just commented out the capslock remap in /usr/share/X11/xkb/symbols/us :

https://gist.github.com/4401095#file-colemak_no_caps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers