The Hebrew lyx layout lack 1-8 numbers

Bug #1089804 reported by Ariel Galil on 2012-12-13
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Won't Fix
Critical
xkeyboard-config (Ubuntu)
Undecided
Unassigned

Bug Description

The Hebrew lyx keyboard layout lack 1-8 numbers in the symbols configuration file:
/usr/share/X11/xkb/symbols/il

Created attachment 71433
The orginal file

Somehow, The Hebrew lyx layout lack 1-8 numbers in the symbols configuration file.

the file is:
/usr/share/X11/xkb/symbols/il

Ariel Galil (arielgalula) wrote :
Changed in xkeyboard-config:
importance: Unknown → Critical
status: Unknown → Confirmed

Could you please do proper patch against git?

(In reply to comment #2)
> Could you please do proper patch against git?

O.K. I comapred my file with someone that don't have this bug, and those files are identical, it's not related to this file.

Please do "xkbcomp :0 -xkb out.xkb" on your system - and on the system without that bug. Please attach the results here.

(In reply to comment #4)
> Please do "xkbcomp :0 -xkb out.xkb" on your system - and on the system
> without that bug. Please attach the results here.

I uploading the files.

Created attachment 71446
xkbcomp output on system with the bug

Created attachment 71447
the same output without the bug

There is a serious difference.

In one case (where you see the bug) you have Hebrew as 1st layout, US as 2nd. But if you put US layout first, the bug disappears.

Please confirm?

i Confirm when i move the hebrew to be the second layout the bug dissapear.

Does this affect other Hebrew variants? I suspect it should do...

(In reply to comment #10)
> Does this affect other Hebrew variants? I suspect it should do...

No, only this specific layout.

Even il(phonetic)??

Could you please try the version from git?

http://cgit.freedesktop.org/xkeyboard-config/commit/symbols/il?id=2e9ab8be72b1d0306e5e6e8c33cde51c0c927450

Has the fix you need. But perhaps il(phonetic) should be fixed as well.

I don't have time to check it now, thank you for your kindly help :-)

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Yotam Benshalom (benshalom) wrote :

This bug is not fixed!

Now, in ubuntu 13.10, the faulty behaviour which "leaked" symbols from the English layout into the Hebrew (lyx) layout when English was listed first is no more. So now, Hebrew (lyx) has no numbers or symbols like !@#, and it is unusable.

I do not know if the fix suggested upstream was incorporated into ubuntu or not, but the bug is here.

See attached screenshot of the faulty keyboard layout.

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed

This bug is not fixed in ubuntu 13.10, using xkb-data 2.5.1-3ubuntu2. The file is still using the old version. This is the downstream bug report: https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/1089804

I just wanted to makesure that this version is indeed one prior to the release of the upstream fix. If not, then something is wrong.

I also tried to replace the /usr/share/X11/xkb/symbols/il with the version from git linked here and reboot. Now, when I use the gnome tool for displaying keyboard layouts I see the numbers in place, but they do not work. Pressing the number keys in lyx layout still does not work.

Is there a way to solve this?

Changed in xkeyboard-config:
status: Fix Released → Confirmed

Could you please attach the output of xkbcomp :0 -xkb out.xkb ? What version of GNOME are you using?

Created attachment 84917
keyboard layout before applying the file from git

Created attachment 84918
keyboard layout after applying the file from git and restarting

The version of the "gnome" meta package is ubuntu 13.10 is currently 1:3.8+1ubuntu3. In practice I think that some of the gnome packages there are still using version 3.6. Is there a specific package of interest?

I am sorry but the files you provided are exactly same!

And they look correct:

    key <AE01> {
        type[group2]= "THREE_LEVEL",
        symbols[Group1]= [ 1, exclam ],
        symbols[Group2]= [ 1, exclam, U05B1 ]
    };
    key <AE02> {
        type[group2]= "THREE_LEVEL",
        symbols[Group1]= [ 2, at ],
        symbols[Group2]= [ 2, at, U05B2 ]
    };
etc

So, keys 1 and 2 have proper mapping for both groups.

Try starting KDE or some other simple window manager, configure the keyboard and check. I guess GNOME does not use XKB for Hebrew.

‏You are correct - on lxde, the repaired file works just right. But not on gnome. On gnome, even when I remove the lyx layout, reboot, and then re-add it, the 1-8 number keys are not recognised,
Do you have any clue about how to even approach this problem?

(In reply to comment #22)
> ‏You are correct - on lxde, the repaired file works just right. But not on
> gnome. On gnome, even when I remove the lyx layout, reboot, and then re-add
> it, the 1-8 number keys are not recognised,
> Do you have any clue about how to even approach this problem?

Please complain to gnome bugzilla, against gnome-settings-daemon. I used to be one of them till they fscked up XKB support

The problem is that this is not really a gnome bug. I can't just go to gnome bugzilla and say that there is a problem in gnome because it does not auto-update its cached data after I manually edit the X keyboard layouts - this is not something a regular user would do.

I would like to find out how to rectify my current situation - a handicapped GNOME experience, not being able to type numbers using my keyboard layout - but I do not know whom I should ask. Do you have any idea?

Changed in xkeyboard-config:
status: Confirmed → Won't Fix

I am not sure gnome is using XKB for Hebrew in your case. It may be some Input Method

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.