Ubuntu

Totem-xine subtitle lag

Reported by Bugsy on 2007-10-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xine-lib (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem-xine

When the subtitle size is set to Very Large or Huge the movie lags a little when the subtitle is displayed. With smaller subtitles the stopping cannot be seen.

Also this is happening only with Nvidia binary driver and Ubuntu Gutsy using Unscaled OSD support in Xine. Everything functioned properly in Edgy.

Basilio Kublik (sourcercito) wrote :

Hi there
Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the development version of Ubuntu, Hardy Heron?

Thanks in advance.

Changed in totem:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Basilio Kublik (sourcercito) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thanks again!

Changed in totem:
assignee: sourcercito → nobody
status: Incomplete → Invalid
Mahendra Tallur (mahen) wrote :

I can confirm this behaviour still occurs in Hardy Heron.

That is to say : subtitles in xine make the video hang for a fraction of a second when they are set to a big enough size, with nvidia binary drivers and compiz enabled. when the xine subtitles option "Use unscaled OSD" is unchecked. (so it happens by default)

Work around : either disable compiz, or check the aforementioned option (which doesn't look as good).

Thanks for reading this :)

This is a bug in xine, and it's still in Intrepid. It also occurs in Kaffeine and xine-ui. It has nothing to do with Compiz / KWin desktop effects (i checked), but is related to the size of the playback window. It might also be linked to the proprietary Nvidia drivers but I doubt that. I rather suspect this is caused by a very ineffective method of rendering the subtitles, as the processor usage of the X server jumps every time a subtitle is displayed)

I've reported this to the xine bug tracker: http://bugs.xine-project.org/show_bug.cgi?id=206

If anybody experiencing this bug does not use the proprietary nvidia driver, please report so at http://bugs.xine-project.org/show_bug.cgi?id=206.

Changed in totem:
status: Invalid → Confirmed

The bug only occurs with the proprietary nvidia drivers (at least for me, I've also tested the nv driver).

Probably should be closed again as invalid, but as this only seems to occur with subtitles I think it might be a good idea if somebody familiar with xine had a look at this first.

Closed again as this is definitely an issue with the proprietary nvidia drivers.

I've reported this issue on the nvnews forum:
http://www.nvnews.net/vbulletin/showthread.php?p=1929108

Changed in xine-lib:
status: Confirmed → Invalid
Migel Klimin (yhorror) wrote :

I have the same issue: laggy video with subtitles in any xine-based player on my Dell 500 notebook.

SYSTEM INFORMATION
 Running Ubuntu Linux, the Ubuntu 8.04 (hardy) release.
 GNOME: 2.22.3 (Ubuntu 2008-07-09)
 Kernel version: 2.6.24-23-generic (#1 SMP Wed Apr 1 21:47:28 UTC 2009)
 GCC: 4.2.4 (i486-linux-gnu)
 Xorg: unknown (13 June 2008 01:08:21AM) (13 June 2008 01:08:21AM)

GRAPHIC CARD
 VGA controller
  Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
  Subsystem: Dell Unknown device 023a

Changed in xine-lib (Ubuntu):
status: Invalid → New
Marcus Sundman (sundman) wrote :

I also suffer from this same bug using the "intel" xorg driver (package "xserver-xorg-video-intel-2.4" version "2:2.4.1-1ubuntu11~ppa1", because the default intel driver in jaunty is fubar) on the "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)" on my laptop.

sit0yen (sit0yen) wrote :

I also have this bug using xserver-xorg-video-radeon 1:6.12.99 on my ATI Technologies Inc RS690 [Radeon X1200 Series].
The problem disappears if using the sdl output driver instead of x11 or xv.

Thank you for taking the time to report this bug and helping to make Ubuntu better. The package your reporting is updated and the issue should be reproducible with the live environment of the Desktop CD development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Thomas Hotz (thotz) wrote :

Can you please tell us if this still happens under a supported Ubuntu version? Thank you!

Changed in xine-lib (Ubuntu):
status: New → Incomplete
Thomas Hotz (thotz) wrote :

I have read the bug report on the xine bug database and this is still not fixed. That's why I mark this bug as confirmed.

Changed in xine-lib (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.