xiccd consumes 100% CPU

Bug #1845800 reported by Jhair Tocancipa Triana on 2019-09-28
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
xiccd (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from disco to Ubuntu Eoan Ermine (development branch) xiccd consumes 100% CPU (see attached screenshot).

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: xiccd 0.2.4-1
Uname: Linux 5.3.0-050300-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:xfce
Date: Sat Sep 28 19:46:46 2019
InstallationDate: Installed on 2014-12-01 (1762 days ago)
InstallationMedia: Xubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140723)
SourcePackage: xiccd
UpgradeStatus: Upgraded to eoan on 2019-09-28 (0 days ago)

I am observing a similar phenotype when I plug my Dell laptop into its docking station, which is connected to an external monitor. 100% CPU, fan spinning.

`killall xiccd` "fixes" the problem.

I should also add that I observe the problem at home, but not at work. Same laptop; same model docking station. Different KVM's and monitors.

To fix this on my machine I removed the xiccd package. It seems is not really used in my environment since nothing broke without it.

Some additional info: I thought that the problem was specific to my home docking station + external monitor, but it is not. In fact, I am able to reproduce the problem without either the docking station or the external monitor.

Here are my steps to reproduce the problem:

1. Reboot. Login via, in my case, `lightdm`.

2. Open a terminal and check that `xiccd` is running.

3. Logout via the panel menu applet

At this point, `xiccd` will run at 100% CPU even though no user is logged in. I can check this by switching to a virtual terminal, logging in and running, say, `htop`.

If I switch back to the GUI "terminal" and login via `lightdm` again, then I can see that _two_ `xiccd` processes are running.

Perhaps `xiccd` should be killed on logout?

I am using the XFCE DE also.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xiccd (Ubuntu):
status: New → Confirmed
Henrik Holst (hholst80) wrote :

I see the same problem on a freshly installed Xubuntu 19.10. I have seen it occur twice now over the course of two days.

tomtom (tbjornli) wrote :

I can confirm that I have seen the same issue a couple of times since a fresh install of Xubuntu 19.10.

If you have any logs or information you want me to collect the next time it happens, please let me know.

Simon Steinbeiß (ochosi) wrote :

This issue is more than likely fixed with xiccd 0.3.x. What we need (imo) is simply the latest stable release of xiccd in Ubuntu.

A PPA of 0.3.x would help people with testing I guess...

Felix Gertz (g-ubuntu-8) wrote :

Just confirming the issue after a fresh install of Xubuntu 19.10.

Johannes Brakensiek (letterus) wrote :

Confirming this. Even seems to happen after deactivating the lock screen. Is there an update coming?

Tom Reynolds (tomreyn) wrote :

Just a side note: An unsupported, experimental build of xiccd 0.3.0-1 is currently available at
  https://launchpad.net/~xubuntu-dev/+archive/ubuntu/experimental

If you are considering to use this PPA, please make sure to read its description first. Consider using APT pinning to only allow this one package to be installed from this PPA, similarly to what is documented at https://help.ubuntu.com/community/PinningHowto#Examples

pauljohn32 (pauljohn) wrote :

I confirm that installing the new package fixed the problem. I had to manually kill xiccd one time because the old instance kept running. But after logging out and in again, problem solved. Instead of using APT, I downloaded the deb package and installed manually: xiccd_0.3.0-1~19.10_amd64.deb

Upon logging in again, the only app gobbling up CPU is dropbox. But I'm used to that one :)

Simon Steinbeiß (ochosi) wrote :

I also tested 0.3.0 in the PPA and it fixes the problem.

So from focal onward this bug should be gone.

Changed in xiccd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.