Cannot start desktop session with compositor enabled

Bug #1835622 reported by intherye on 2019-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xfwm4
Invalid
Medium
mesa (Ubuntu)
Undecided
Unassigned
xfwm4 (Ubuntu)
Undecided
Unassigned

Bug Description

I cannot login to the Xfce desktop session anymore. in ~/.xsession-errors there's the message:

xfwm4: ../src/mesa/drivers/dri/i965/intel_mipmap_tree.c:1285: intel_miptree_match_image: Assertion `image->TexObject->Target == mt->target' failed.

Earlier today Mesa was upgraded via bionic-updates from 18.2 to 19.0.

I'm running Xubuntu 18.04 and I'm also using the Xubuntu Staging PPA with xfwm4 4.13.3

intherye (intherye) wrote :

~/.xsession-errors attached.

If needed, I can provide any other information.

description: updated
Download full text (3.9 KiB)

Created attachment 8729
xsession-errors

This is a copy of the Ubuntu bug I created: https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/1835622

"I cannot login to the Xfce desktop session anymore. in ~/.xsession-errors there's the message:

xfwm4: ../src/mesa/drivers/dri/i965/intel_mipmap_tree.c:1285: intel_miptree_match_image: Assertion `image->TexObject->Target == mt->target' failed.

Earlier today Mesa was upgraded via bionic-updates from 18.2 to 19.0.

I'm running Xubuntu 18.04 and I'm also using the Xubuntu Staging PPA with xfwm4 4.13.3"

Some additional notes:
- I had occasional crashed of xfwm or the panel, but those did not affect functionality
- Before the upgrade today I had no problems logging in to the Xfce Desktop
- Disabling the compositor in xfwm resolved the issue
- Else than the Xubuntu Staging PPA I also have:
  * deb http://www.ui.com/downloads/unifi/debian stable ubiquiti
  * deb http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 multiverse (I just saw the xenial here. Seems to be wrong. But probably not related to that bug here)

Those were the upgrades from today:

Start-Date: 2019-07-06 10:23:49
Commandline: /usr/sbin/synaptic
Requested-By: marting (1000)
Install: libllvm8:amd64 (1:8-3~ubuntu18.04.1, automatic), libllvm8:i386 (1:8-3~ubuntu18.04.1, automatic)
Upgrade: libthunarx-3-0:amd64 (1.8.7-0ubuntu1~18.04, 1.8.7-0ubuntu2~18.04), thunar-data:amd64 (1.8.7-0ubuntu1~18.04, 1.8.7-0ubuntu2~18.04), libegl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libegl-mesa0:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libsystemd0:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), libsystemd0:i386 (237-3ubuntu10.23, 237-3ubuntu10.24), libglapi-mesa:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libglapi-mesa:i386 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), mesa-common-dev:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libxatracker2:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), udev:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), libegl1-mesa:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libreoffice-l10n-de:amd64 (1:6.0.7-0ubuntu0.18.04.4, 1:6.0.7-0ubuntu0.18.04.7), libudev1:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), libudev1:i386 (237-3ubuntu10.23, 237-3ubuntu10.24), libgbm1:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libreoffice-help-de:amd64 (1:6.0.7-0ubuntu0.18.04.4, 1:6.0.7-0ubuntu0.18.04.7), systemd-sysv:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), libwayland-egl1-mesa:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libgles2-mesa-dev:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libpam-systemd:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), systemd:amd64 (237-3ubuntu10.23, 237-3ubuntu10.24), thunar:amd64 (1.8.7-0ubuntu1~18.04, 1.8.7-0ubuntu2~18.04), libgl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libgl1-mesa-dri:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libgl1-mesa-dri:i386 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libosmesa6:amd64 (18.2.8-0ubuntu0~18.04.2, 19.0.2-1ubuntu1.1~18.04.1), libosmesa6:i386 (18.2.8-0ubuntu0~18.04.2, 19.0....

Read more...

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed

Installed package versions are:
- xfwm4 4.13.3-0ubuntu1~18.04
- libgl1-mesa-dri 19.0.2-1ubuntu1.1~18.04.1

This is an issue in Mesa DRI driver for Intel, that shows when Mesa is built with asserts() enabled (typically debug).

See:

https://bugs.freedesktop.org/show_bug.cgi?id=107117
https://patchwork.freedesktop.org/patch/237490/

Changed in xfwm4:
status: Confirmed → Invalid
Timo Aaltonen (tjaalton) wrote :

please test ppa:ubuntu-x-swat/updates

seems to be a duplicate of bug 1836721

Timo Aaltonen (tjaalton) wrote :

well, perhaps not a dupe but would be nice to know if the new upstream bugfix version helps

Timo Aaltonen (tjaalton) on 2019-07-18
Changed in xfwm4 (Ubuntu):
status: New → Invalid

*** Bug 15741 has been marked as a duplicate of this bug. ***

*** Bug 15765 has been marked as a duplicate of this bug. ***

intherye (intherye) wrote :

@Timo: I could not test this earlier because I was on holidays. So finally here are the results:

1. (If I understand correctly the fix from bug 1836721 is already in bionic-updates) I upgraded all packages, but the bug still persists (error message "xfwm4: ../src/mesa/drivers/dri/i965/intel_mipmap_tree.c:1285: intel_miptree_match_image: Assertion `image->TexObject->Target == mt->target' failed.")

2. So I enabled ppa:ubuntu-x-swat/updates and upgraded all packages, but the error still persists.

From my point of view it seems this bug is not fixed by bug 1836721.

k3dar7 (k3dar7) wrote :

same problem with Xubuntu 18.04.3 64bit 5.0.0-25-generic + ppa:xubuntu-dev/staging (on machines with Intel GPU)

- not help update Mesa to 19.0.8-0ubuntu0~18.04.1 from ppa:ubuntu-x-swat/updates
- only help disabling Compositor in xfwm4-tweaks-settings as workaround

k3dar7 (k3dar7) wrote :

additional test - not help Mesa:
- today bionic-update/main 19.0.8-0ubuntu0~18.04.1
- Padoka Stable (ppa:paulo-miguel-dias/pkppa) 19.1.2-0~b~padoka0

BUT with this Mesa work Compositing enabled without crash:
- Padoka Unstable (ppa:paulo-miguel-dias/mesa) 19.2~git190724122600.e7e31b1~b~padoka0

all test with today 18.04 Xfce 4.14 packages fro ppa:xubuntu-dev/staging and Intel GPU...

intherye (intherye) wrote :

Set to confirmed because affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
intherye (intherye) wrote :

The newest Mesa version 19.2.1-1ubuntu1~18.04.1~ppa2 in ppa:ubuntu-x-swat/updates has fixed that problem for me. Thanks!

k3dar7 (k3dar7) wrote :

with newest Mesa version 19.0.8-0ubuntu0~18.04.3 from oficial (non-ppa) bionic-updates repository is problem gone

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.