xfwm4 (4.10, xubuntu 12.10 b2) handle fullscreen incorrectly

Bug #1066535 reported by mrDoctorWho on 2012-10-14
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Fix Released
Undecided
Mario Limonciello
Xfwm4
Fix Released
Low
xfwm4 (Ubuntu)
Undecided
Unassigned

Bug Description

When opening VLC (sometimes), youtube in firefox, libreoffice, minecraft - all in full screen XFWM4 handle in incorrectly: show panels.

If I switch to workspace with Chromium in fullscreen mode I see xfce-panel overlapping Chromium. To hide panel I need too turn fullscreen mode off and then turn it on again.

P.S.
I think this bug is reproducable for all non-decorated windows because if I set Chromium to use system frames and title bar all works great.

Works for me in 4.10

Happens with 4.10 as well (on Arch Linux), but only if the Chromium window is maximized before going to fullscreen.

This bug might also be related: https://bugs.archlinux.org/task/28450.

Also reproducible on Xubuntu 12.04, if that helps further investigating the issue.

mrDoctorWho (mrdoctorwho) wrote :
Ingo Ruhnke (grumbel) wrote :

To add to this: Fullscreen doesn't interact properly with multiple monitors either, whenever I move the mouse from one monitor to the other, the window that was in fullscreen mode will fall into the background and be covered by all other windows and the panels, meaning it's impossible to properly watch a video on a second monitor. Prior to Ubuntu 12.10 everything worked perfectly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfwm4 (Ubuntu):
status: New → Confirmed

Created attachment 4777
Testcase

Issue is still present in 4.10. Attached testcase (from Arch bug report) still reproduces the issue for me (xfwm 4.10, Qt 4.8).

Run xfwm_qt.py, ensure window is maximized (M), switch to fullscreen (F), toggle menu bar visibily (H) -> xfce-panel is drawn on top of the supposed-to-be-fullscreen window.

Created attachment 4960
Fix

I hope this patch fixes an issue. (Makes Fullscreen flag override Maximized)

This bug is still present in 4.10.1 although the patch has been available for weeks. It doesn't seem to affect newer versions of Chromium, but Qt apps (e.g. VLC) are still affected.
I have been using the patch for some weeks without any issues. (Thank you, Viktor Semykin.) It would be great if it was included in future versions.

Confirming and requesting inclusion of patch.

Details of my confirmation here: http://forum.xfce.org/viewtopic.php?id=7682

I also confirm this bug affecting VLC(2.0.8) and Xfce(4.10) on Arch Linux. Please apply the patch.

Mario Limonciello (superm1) wrote :

MythTV is affected by this as well. It seems there is a bug report upstream along with a patch that should fix the problem. https://bugzilla.xfce.org/attachment.cgi?id=4960

Changed in mythbuntu:
assignee: nobody → Mario Limonciello (superm1)

I can confirm that patch fixes this behavior with a Qt based application (MythTV) in Ubuntu 14.04 development.

Changed in mythbuntu:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfwm4 - 4.10.1-2ubuntu2

---------------
xfwm4 (4.10.1-2ubuntu2) trusty; urgency=low

  * Add patch from XFCE bugzilla to fix fullscreen behavior with Qt
    based apps (LP: #1066535)
 -- Mario Limonciello <email address hidden> Tue, 03 Dec 2013 15:24:16 -0600

Changed in xfwm4 (Ubuntu):
status: Confirmed → Fix Released

*** Bug 10622 has been marked as a duplicate of this bug. ***

Changed in xfwm4:
importance: Unknown → Low
status: Unknown → Confirmed

So, what's the state of this patch? It has been merged or it's still in the "to merge/to review" list?

Committed the patch to master and consequently marking this fixed: http://git.xfce.org/xfce/xfwm4/commit/?id=cf82188eb5a841e8be34fa7ce67933ca15eba7fa

Changed in xfwm4:
status: Confirmed → Fix Released
Thomas Mashos (tgm4883) wrote :

Marking as Fix Released since we provide newer builds in our PPA and this has been marked fix committed for awhile now.

Changed in mythbuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.