Removal of gdmflexiserver breaks user switching

Bug #1320560 reported by Micouin Claude on 2014-05-17
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Xfce4 Panel
Confirmed
Medium
xfce4-panel (Ubuntu)
Undecided
Unassigned
xfce4-whiskermenu-plugin (Ubuntu)
Undecided
Unassigned
xfswitch-plugin (Ubuntu)
Undecided
Unassigned
xscreensaver (Ubuntu)
Undecided
Unassigned

Bug Description

Hello and pardon for my bad english.
On xfce4, the button to log with a new user without logout never wants to works.
It accepts to open a confirmation windows "To you really want to change user?" That's OK.
Then I press Yes and I've got an error message who says in french : "Impossible to create a new display"
and in english : "GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.DisplayManager was not provided by any .service files"

lsb_release-rd :
Description: Ubuntu 14.04 LTS
Release: 14.04

apt-cache policy xfswitch-plugin
xfswitch-plugin:
  Installé : 0.0.1-4ubuntu1
  Candidat : 0.0.1-4ubuntu1
 Table de version :
 *** 0.0.1-4ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Thanks for your help.

Claude Micouin

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xfswitch-plugin 0.0.1-4ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 18 00:20:57 2014
InstallationDate: Installed on 2014-05-07 (10 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: xfswitch-plugin
UpgradeStatus: No upgrade log present (probably fresh install)

Micouin Claude (mlnglst) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfswitch-plugin (Ubuntu):
status: New → Confirmed

This bug is caused by the removal of gdmflexiserver in Ubuntu 14.04. The source of xfswitch-plugin needs to be edited accordingly. It should either call "dm-tool switch-to-greeter" (lightdm) or a wrapper script which detects the running display manager and initiates the user switch.

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/xfswitch-plugin/trusty/view/head:/panel-plugin/main.c#L118

Anton Asche (aasche) wrote :

A simple workaround is creating the file /usr/local/bin/gdmflexiserver:

#!/bin/sh
#
# replacement for missing gdmflexiserver in Ubuntu 14.04
#
dm-tool switch-to-greeter

and make it executable (chmod 755).

Micouin Claude (mlnglst) wrote :

Thank you Anton Asche.
I've just tried your workaround and I can switch users now.

Simon Steinbeiß (ochosi) wrote :

I'm not sure that this issue can really be sorted upstream, first one would have to assess whether gdmflexiserver is still used in some distros.

In this case I'd personally advocate patching the xfswitch-plugin in Ubuntu to use dm-tool over gdmflexiserver (seems like an easy-enough thing to do), since Xfce users in Ubuntuland are at least very likely to use LightDM.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
summary: - xfswitch-plugin refuses to switch user
+ Removal of gdmflexiserver breaks user switching
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xscreensaver (Ubuntu):
status: New → Confirmed
Changed in xfce4-whiskermenu-plugin (Ubuntu):
status: New → Confirmed

The following PPA contains patched versions of the affected packages:

https://launchpad.net/~smd-seandavis/+archive/ubuntu/lp1320560

Tormod Volden (tormodvolden) wrote :

IMO, the session manager which launches xscreensaver should also tell xscreensaver (or other screensavers) how to do user switching. It does not make sense that xscreensaver should try to keep up with various combinations of desktop environments and display managers and guess the right commands.

I think this would be something for a freedesktop standard. Until then, xscreensaver reads the X resource XScreenSaver.newLoginCommand run-time so the session managers can simply set this.

I made this wrapper once: http://anonscm.debian.org/cgit/collab-maint/xscreensaver.git/commit/?id=f2136d9374bd072a0e6978c3a19c1a8cc2396726 but seriously this is not a good solution either.

PPA link has been changed. Please install and test the updated packages.

https://launchpad.net/~bluesabre/+archive/ubuntu/lp1320560

Sean Davis (bluesabre) wrote :

Patches have been updated on the PPA. Please test before I upload to the archive.

Sean Davis (bluesabre) wrote :

Attaching debdiff for xfswitch-plugin on Utopic, request package sponsorship.

Iain Lane (laney) wrote :

++ /* check for gdmflexiserver if no dm-tool */
++ g_free (path);

This g_free is redundant since you know path is NULL there. Fortunately g_free checks this itself so it's not an error.

Would you forward the patch upstream please?

Sean Davis (bluesabre) wrote :

Attaching debdiff for xscreensaver on Utopic. Request package sponsorship.

Sean Davis (bluesabre) wrote :

@laney -- Yes, will forward packages upstream.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-panel - 4.11.1-0ubuntu2

---------------
xfce4-panel (4.11.1-0ubuntu2) utopic; urgency=medium

  * debian/patches/02_support-dmtool.patch
    - Add support for dm-tool for user-switching (LP: #1320560)
 -- Sean Davis <email address hidden> Tue, 14 Oct 2014 06:15:01 -0400

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-whiskermenu-plugin - 1.4.0-1ubuntu1

---------------
xfce4-whiskermenu-plugin (1.4.0-1ubuntu1) utopic; urgency=medium

  * debian/patches/01_replace-gdmflexiserver.patch
    - Use dm-tool instead of gdmflexiserver for user-switching,
      the latter is no longer provided by lightdm (LP: #1320560)
 -- Sean Davis <email address hidden> Tue, 14 Oct 2014 06:39:57 -0400

Changed in xfce4-whiskermenu-plugin (Ubuntu):
status: Confirmed → Fix Released

The attachment "xfswitch-plugin utopic debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in xfswitch-plugin (Ubuntu):
status: Confirmed → Fix Committed
Changed in xscreensaver (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfswitch-plugin - 0.0.1-5ubuntu3

---------------
xfswitch-plugin (0.0.1-5ubuntu3) utopic; urgency=medium

  * debian/patches/02_support-dmtool.patch
    - Add support for dm-tool for user-switching (LP: #1320560)
 -- Sean Davis <email address hidden> Tue, 14 Oct 2014 06:53:47 -0400

Changed in xfswitch-plugin (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xscreensaver - 5.26-1ubuntu3

---------------
xscreensaver (5.26-1ubuntu3) utopic; urgency=medium

  * debian/patches/91_replace-gdmflexiserver.patch:
    - Use dm-tool instead of gdmflexiserver for user-switching,
      the latter is no longer provided by lightdm (LP: #1320560)
 -- Sean Davis <email address hidden> Tue, 14 Oct 2014 07:07:45 -0400

Changed in xscreensaver (Ubuntu):
status: Fix Committed → Fix Released

Created attachment 6158
switch-user xflock4

"Switch User" via 'xflock4' i.e. 'light-locker-command --lock'.

From the light-locker and LightDM's greeter perspective,
"Lock Screen" and "Switch User" are the same action type.

Of course, this functionality implies working 'light-locker'.

See "light-locker as additional preferred screen locker"
https://bugzilla.xfce.org/show_bug.cgi?id=11785

(In reply to Thaddaeus Tintenfisch from comment #1)
> Better use "dm-tool switch-to-greeter" as replacement for "gdmflexiserver".
>
> http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/vivid/xfce4-panel/vivid/
> view/head:/debian/patches/02_support-dmtool.patch

'dm-tool' is not intended to be used directly.
If 'light-locker' doesn't run, 'dm-tool switch-to-greeter' will leave the session unlocked.
It is the very reason why there is a tool like 'light-locker' with its controller 'light-locker-command', which will lock the session and then switch to the LightDM's greeter.

I hope you understand this. ;)

For what it's worth, this also affects Ubuntu 14.04 with the classic metacity desktop. Anton Asche's workaround (comment 4) solved the problem for me.

V字龍(Vdragon) (vdragon) wrote :

Hi, can someone port the fix back to Ubuntu 14.04?

Hi, I've linked the (related) downstrem Ubuntu bug here:
[Bug #1320560 “Removal of gdmflexiserver breaks user switching” : Bugs : xfswitch-plugin package : Ubuntu](https://bugs.launchpad.net/ubuntu/+source/xfswitch-plugin/+bug/1320560)

Changed in xfce4-panel:
importance: Unknown → Medium
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.