xfdesktop crashed with SIGSEGV in xfce_desktop_refresh()

Bug #1282509 reported by David Pires on 2014-02-20
848
This bug affects 162 people
Affects Status Importance Assigned to Milestone
xfdesktop
Fix Released
High
xfdesktop4 (Ubuntu)
Medium
Jackson Doak

Bug Description

The crash occurred just after the login and when entering the desktop.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: xfdesktop4 4.11.3-1ubuntu1
Uname: Linux 3.14.0-031400rc2-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CurrentDesktop: XFCE
Date: Thu Feb 20 10:37:51 2014
ExecutablePath: /usr/bin/xfdesktop
InstallationDate: Installed on 2013-03-22 (334 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130311.1)
ProcCmdline: xfdesktop --display :0.0 --sm-client-id 24680e5d5-a5bd-446f-b873-eefd78c1a0b7
SegvAnalysis:
 Segfault happened at: 0xb7703a98 <xfce_desktop_refresh+168>: mov (%eax,%ebp,1),%eax
 PC (0xb7703a98) ok
 source "(%eax,%ebp,1)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfdesktop4
StacktraceTop:
 xfce_desktop_refresh ()
 ?? ()
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: xfdesktop crashed with SIGSEGV in xfce_desktop_refresh()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

David Pires (slickymaster) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed

StacktraceTop:
 xfce_desktop_refresh (desktop=desktop@entry=0xb7cdd078) at xfce-desktop.c:1767
 style_refresh_cb (w=0xb7cdd078) at xfce-desktop.c:1357
 ?? ()
 ?? ()

plucky (pwlmail) wrote :

Same symptoms and also after todays updates.

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Dick Smallberries (johnsjt) wrote :

Same Same here. VMWare Workstation 10.0.1 build-1379776, Windows 7 Host, Xubuntu 14.04 guest.

Confirmed, 64bit xubuntu 14.04 installed in virtualbox (xubuntu 13.10 64bit host)

David Pires (slickymaster) wrote :

Uploading the backtrace of the crash (as an attachment) to the bug report.

Since the uploaded crash contained a CoreDump, which will potentially have sensible information, I have created a new version with the dump removed.

Jackson Doak (noskcaj) on 2014-02-20
Changed in xfdesktop4 (Ubuntu):
status: Confirmed → Triaged
Piotr (majsza-one) wrote :

Uploading the backtrace of the crash (as an attachment) to the bug report.

David Pires (slickymaster) wrote :

Since Piotr's uploaded crash contained a CoreDump, which will potentially have sensible information, I have created a new version with the dump removed.

The crash occurs on session start. Trace logs can be found here:

https://bugs.launchpad.net/ubuntu/+source/xfdesktop4/+bug/1282509

xfdesktop 4.11.3

Created attachment 5366
Fix segfault on session start

This makes the refresh into a no-op if workspaces is null. The icon refresh (which is the reason this is now getting called) doesn't rely on workspaces, so this may not be an appropriate fix. I would like to know *why* workspaces apparently haven't been set up when this is getting called.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1282509

tags: added: iso-testing

On session startup gtk does send a style set before libwnck has
initialized and sent its workspace created messages.
Pushed to master in: http://git.xfce.org/xfce/xfdesktop/commit/?id=6583a1a632779e72ba6ecfa32a10f30980081876

Thanks for the patch!

John Law (anoctoil) wrote :

I had restored a backup by deja dup, which was actually from a 13.10 32bit Xubuntu install on a different partition. I now have all my home directory from that installation. All seems well. The current bug report was initiated by apport immediately after reboot.
This machine is an i7 desktop.

John Law (anoctoil) wrote :

(Cont) Trusty Tahr beta. 64 bit version. Updated earlier today then shutdown. Logon set to automatic without password.

Jean-Peer Lorenz (peer.loz) wrote :

Happens for me with a fresh install of Xubuntu daily build as of 2014/02/22 in VM (virtualbox i386).

Jack Kern (schproodle) wrote :

Happens for me with a fresh install of Xubuntu i386 daily build as of 2014/02/25 in VM (virtualbox i386).

Jack Kern (schproodle) wrote :

fresh install of Xubuntu amd64 daily build as of 2014/02/25 in vm virtualbox 64 bit

Kenneth Wrede (kennethwrede) wrote :

During first login after upgrading Xubuntu from Saucy to Thrusty. 64-bit.

Jackson Doak (noskcaj) wrote :

This is fixed in debian's packaging svn. If a release is not out soon, i will upload a patched version straight to ubuntu.

Changed in xfdesktop4 (Ubuntu):
milestone: none → ubuntu-14.04-beta-2
status: Triaged → Fix Committed
assignee: nobody → Jackson Doak (noskcaj)
ajgreeny (ajg-charlbury) wrote :

Running Xubuntu 14.04 64bit daily iso, dated 25 Feb 2014, fully updated, in Virtualbox-4.3.8.

Cristina (fcloud400) wrote :

Affects me during login, Running Xubuntu 14.04 fully updated, on Amd FX 6100 64-bit. (In real pc, no Virtualbox)

First use of XFCE session in Ubuntu 14.04 x64 kernel 12.x I chose the empty panel for first run.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.11.3-2ubuntu1

---------------
xfdesktop4 (4.11.3-2ubuntu1) trusty; urgency=medium

  * Merge from debian. Remaining changes:
    - debian/patches/xubuntu_improve-nautilus-interactions.patch: added,
      should prevent nautilus from taking over the desktop if xfdesktop is
      running (and vice-versa).
    - debian/patches/xubuntu_set-accountsservice-user-bg.patch: update the
      user background property of Accountsservice on backdrop change.
 -- Jackson Doak <email address hidden> Sat, 01 Mar 2014 16:02:38 +1100

Changed in xfdesktop4 (Ubuntu):
status: Fix Committed → Fix Released

Marking resolved

Changed in xfdesktop:
importance: Unknown → High
status: Unknown → Fix Released
Ian (superian) wrote :

I can see that this is marked as fixed in the beta-2 release of Xubuntu 14.04, but I am seeing something very similar with that:

Write the beta-2 ISO to a USB stick.
Boot up with it.
Select 'try Xubuntu'
Gets to the desktop, then crashes after a couple of seconds (monitor says no input, PC reboots after about 30 seconds)

This happens on two PCs, with both the i386 and x64 versions. One has an AMD A8-5500 CPU, the other a AMD A4-5300. Both have 16G RAM.

But exactly the same USB stick works, with the i386 version, on two laptops: one an Asus Eee900, the other an HP NC4200 (after using the forcepae argument when booting).

Interestingly, on at least one of the machines it fails on, the items on the boot menu are all duplicated - 123456123456-style - but the verify works and exactly the same USB stick looks normal on the two laptops.

Ian (superian) wrote :

Having tried again with the x64 version on both AMD PCs, selecting either 'Try Xubuntu' item in the menu boots to desktop, then crashes to reboot after a count of 'one-and-two-and.. ..and seven'

$ md5sum *.iso
fdb202007513d5a267ac8484b28f283d xubuntu-14.04-beta2-desktop-amd64.iso
12125f4bbdc886d9497d6cb820574031 xubuntu-14.04-beta2-desktop-i386.iso

Menu items are:

Default
Help
Try Xubuntu
Install Xubuntu
Check disc for defects
Test memory
Boot from first hard disc
Try Xubuntu
Install Xubuntu
(OEM version of install)
Check disc for defects

Ian (superian) wrote :

Ah, it's not xfdesktop - the same crash occurs if I try the beta2 lubuntu ISOs. Boot to desktop, then crash to, eventually, reboot (it just crashes after one second rather than several with them!)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.