xfce4 doesnt shut down properly

Bug #46571 reported by John Vivirito on 2006-05-25
26
Affects Status Importance Assigned to Milestone
xfce4 (Ubuntu)
Medium
Xubuntu Team

Bug Description

Binary package hint: xfce4

i am running dapper with xubuntu installed and when you go to reboot or shutdown it drops you to a tty login and doesnt let you do anything than after a while you will get the last 4 lines or so of the usplash. someone running xfce4 on breezy is having same issues. this has been happening ever since xfce4.4 was put in dapper for me.

Jani Monoses (jani) wrote :

if it's the same thing I am thinking about it is a known issue. The shutdown messages are scrolling on vt7 (or 8 I forgot) but X drops you to vt1 so you
don;t see that shutdown is actually in progress.
It is a bit confusing indeed.

John Vivirito (gnomefreak) wrote :

that would be the same one im glad its not just me and another person that noticed this. is this a fix to look foward to for dapper?

Daniele Favara (nomed) wrote :

fix has been commited since time. it was mainly an hal/xfce issue

Changed in xfce4:
assignee: nobody → xubuntu-team
status: Unconfirmed → Fix Released
Jani Monoses (jani) wrote :

no, this is a different issue. It shuts down, just without indication because the text scrolls on vc7 while the user is dropped to vc1

Changed in xfce4:
status: Fix Released → Confirmed

On 5/28/06, Jani Monoses <email address hidden> wrote:
> no, this is a different issue. It shuts down, just without indication
> because the text scrolls on vc7 while the user is dropped to vc1

i don't see this issue ... is it still present ?
How can i reproduce the bug ? ... and if i understand well (this
time).. isn't this an usplash bug|issue ?

Jani Monoses (jani) wrote :

shut down or restart from the logout dialog. The system messages about
going down and killing processes and stopping init.d scripts are not visible
unless you switch to vt7 (or 8?)

Pascal Vincent (pvincent00) wrote :

I had the same problem in dapper. I describe it again to clarify and be sure i am in the subject.
With my xfce session is open, i select reboot or shutdown.
Then, I observe a switch to VT, where i can see shutdown messages, and then switch to usplash for the last steps.
Note that this never happen if i select reboot or shutdown from GDM.

After an update to Edgy last week, the behavior is not exactly the same :
if i select reboot or shutdown, my X is totally freeze during the fist part of shutdown, and then again switch to usplash for the last steps.
Again, usplash is correctly start immediatly after reboot or shutdown asked from GDM.

I too can confirm that this occurs in Edgy (though it doesn't drop to vt1 anymore). I also don't think that X/xfce4/etc. is shutting down correctly at all because music from my X app is still playing until the very end (it would have stopped playing if it had been killed). This also leads to other problems like application settings that only get saved during a proper exit of the program being lost. I dunno if this is a separate bug but it all seems to be related.

This also occurs in Fesity.

Testing on fiesty beta.
Most of the times I shutdown, logout or hibernate on my test Pentium III 800 (asus mb) I got 5-7 lines of text from boot messages and system hangs up. Probably this is the same issue.
This happens on fresh beta install after 2-3 successful reboots, shutdowns and hibernates.

It seems I have the same problem than Cody on xubuntu feisty RC:
When shutting down from gdm it works: I see the nice upslash with progress bar.
When shutting down from xfce (thus, after login), the system switch to VT8 and the usplash is only shown the very last second, with no progress bar.

I notice no hang or so however.

Yes, my recent test installs of daily iso behave this way.
No hangups but usplash screen only shown within last 1-2 seconds...

I'll try to be more accurate :

 It seems I have the same problem than Cody on xubuntu feisty RC:
 When shutting down from gdm it works: I see the nice upslash with progress bar.
 When shutting down from xfce (thus, after login), the system switch to VT8 and the usplash is only shown the very last second, with no progress bar. On VT8, the text displayed comes from the startup and is therefore irrelevant . The good one is on VT7.

I notice no hang or so however.

Pancho (jfdarv) wrote :

Same problem occurs in Feisty Final with a fresh install. When shutting down from GDM, usplash appears correctly. When shutting down from xfce, usplash appears only 1 second before the PC powers off. No hangs, nothing, just not as pretty as it should be. Hope somebody has an idea, this bug is pending for a year now!

The issue seems to be resolved in Gutsy. If anyone else still has this problem is Gutsy, please reopen this bug report.

Changed in xfce4:
status: Confirmed → Fix Released

This may be new in Hardy:

I have a weird issue with Xubuntu Hardy. It will not shut down. When I restart the xserver and attempt to select xfce login and try to shutdown, it brings me back to the GDM login screen and when I try to login in I get a blue screen that doesnt ever show my desktop.
I reinstalled everything to do with XFCE and I cant even see my desktop, it hangs with the blue screen, but gnome hardy works

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers