SRU xfce4-weather-plugin, currently showing 'No Data'

Bug #1244629 reported by Jim Bauer on 2013-10-25
146
This bug affects 24 people
Affects Status Importance Assigned to Milestone
xfce4-weather-plugin (Debian)
Fix Released
Unknown
xfce4-weather-plugin (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Impact]
This package no longer functions due to an URI change to weather.com. Debian patched this issue in 0.7.4-4, which is currently in stable.

[Test Case]
This only applies to precise
Open xfce4-weather-plugin and this issue should appear.

[Regression potential]
Low. The patch was based on an upstream fix and has been in debian experimental for a few months already. The package is completely broken and has no reverse-depends, so nothing else will be affected. In the case of a regression, that patch would need more changes, but a regression cannot damage more than already is.

[Patch]
Please just sync from from debian stable, the changelog reads:
xfce4-weather-plugin (0.7.4-5) wheezy; urgency=low
 .
   * debian/patches:
     - 02_NULL-hi added, fix cases where <hi> element is empty. closes: #735478

xfce4-weather-plugin (0.7.4-4) wheezy; urgency=low

  * debian/patches:
    - 01_uri_change added, update weather.com API URI. closes: #727628

 -- Yves-Alexis Perez <email address hidden> Thu, 24 Oct 2013 22:17:51 +0200

[Original bug]
xfce4-weather-plugin, in Ubuntu 12.04.3, seem to be having a problem as of about 2013-10-25 (date problem first noticed) parsing the queries it is getting. When selecting 'refresh', I see the following output being logged.

Entity: line 1: parser error : Space required after the Public Identifier
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
                                                 ^
Entity: line 1: parser error : SystemLiteral " or ' expected
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
                                                 ^
Entity: line 1: parser error : SYSTEM or PUBLIC, the URI is missing
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
                                                 ^
Entity: line 6: parser error : Opening and ending tag mismatch: p line 6 and a
mp;link=xoap&amp;prod=xoap&amp;par=1003666583&amp;key=4128909340a9b2fc">here</a>
                                                                               ^
Entity: line 6: parser error : Opening and ending tag mismatch: body line 4 and p
ink=xoap&amp;prod=xoap&amp;par=1003666583&amp;key=4128909340a9b2fc">here</a>.</p
                                                                               ^
Entity: line 9: parser error : Opening and ending tag mismatch: hr line 7 and body
</body></html>
       ^

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xfce4-weather-plugin 0.7.4-3
ProcVersionSignature: Ubuntu 3.2.0-55.85-generic 3.2.51
Uname: Linux 3.2.0-55-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.5
Architecture: amd64
Date: Fri Oct 25 07:45:02 2013
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-weather-plugin
UpgradeStatus: Upgraded to precise on 2012-05-30 (512 days ago)

Jim Bauer (jfbauer-d) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-weather-plugin (Ubuntu):
status: New → Confirmed
tags: added: i386
David Cancalon (david-cancalon) wrote :

Problem confirmed in ubuntu 12.04 but seems to be OK in ubuntu 13.04 with this version of the plugin :

apt-cache policy xfce4-weather-plugin
xfce4-weather-plugin:
  Installé : 0.8.3-0ubuntu1
  Candidat : 0.8.3-0ubuntu1
 Table de version :
 *** 0.8.3-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ raring/universe <http://fr.archive.ubuntu.com/ubuntu/%20raring/universe> i386 Packages
        100 /var/lib/dpkg/status

This problem only affects the xfce weather plugin in Precise, but I don't have the ability to split the bug into separate releases.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727628

Changed in xfce4-weather-plugin (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged

I put a patched version in my PPA: https://launchpad.net/~dtl131/+archive/mediahacks
It fixes the issue in my Precise VM, but it would be nice to get more testing/feedback before attempting SRU.

tags: added: patch

The attachment "01_uri_change.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

smilingralph (smilingralph) wrote :

Adding PPA fixed issue for me. Thanks

smilingralph (smilingralph) wrote :

Oops. It's gotten a bit windy :)

Bill

^I'm guessing that's garbage data from weather.com service and not a problem with the patch.

ergatif (georges-comptoirip) wrote :

Thanks for the PPA it worked for me :
sudo add-apt-repository ppa:dtl131/mediahacks
sudo apt-get update
sudo apt-get install xfce4-weather-plugin
sudo add-apt-repository --remove ppa:dtl131/mediahacks

Thanks ! It's works perfectly for me on my VM (xubuntu 12.04)

Humm... It's works, except for the extra informations on Weather.com (displaying four "99") ?
Perhaps another URL to fix ?

It's nice to see it's patched for the immediate problem and will probably eventually make it into the Precise updates. What I did to see what was happening was to use Wireshark. It was getting a 301 response (or was that 302?). Wouldn't it be nicer if the plugin properly followed redirects such as this? I was looking in weather-http.c, but I wasn't too sure about the BEST place to parse the response code and the Location: header. I also wasn't too sure of how to handle a 301, such as changing the appearance somehow, because it could go from working, to 301, to 404, and developers wouldn't otherwise see it until it totally breaks at the 404 stage (or in this case, at some other time if xoap is removed from DNS).

Changed in xfce4-weather-plugin (Debian):
status: Unknown → Fix Committed
Changed in xfce4-weather-plugin (Debian):
status: Fix Committed → Fix Released

So guys... What are we waiting for ?...
The fix seems to be OK. What is the next step now ?

Roman (thezub) wrote :

Has the fix been sent as a regular update? Because I'm not seeing it, and weather is still broken. I'm not exactly keen on updating out of an LTS release...

Roman, You're absolutely right, I went down that path. It's not worth the headache and crashes caused by the newer releases no matter how "nice" things are on them. Waiting for an official fix (upgrade to 8.3 version) for the standard repositories/bug fix in Xubuntu. Until then, I've just reverted to 12.04 as it's more stable/works better for me than 12.10, 13.04 OR 13.10 which I tried all.. they didn't suit me for various reasons.
I could try to put the 8.3 version out of saucy (13.10) into Precise (12.04) but, it's just not worth screwing something up. Just using a browser based application now or manually checking.
My local weather station is online with updates and forecasts, for instance.
Until a patch/update is shown in the standard Xubuntu/Ubuntu 12.04 repositories, this is NOT FIXED.

It's fixed and backported in Debian, apparently:
http://archive.getdeb.net/ubuntu precise-getdeb apps
I believe I added
ppa http://archive.getdeb.net/ubuntu precise main
in synaptic, refreshed, and a bunch of stuff popped up, lots of xfce 4.10 updates in the dev branch, I guess.
They certainly weren't intended for Xubuntu 12.04, but new releases for 13.04 and beyond (12.04 uses xfce 4.8.)
The next stable LTS of Xubuntu, 14.04 will use yet another version of xfce, 4.11 or 4.12 depending on how quickly it's updated.
This stuff's pretty confusing to me.
Shows as a Xubuntu developer port?
Guess if you have a record of the changes, you can revert if it doesn't work. I don't recall how.

Jackson Doak (noskcaj) on 2014-01-14
summary: - xfce4-weather-plugin showing 'No Data'
+ SRU xfce4-weather-plugin, currently showing 'No Data'
Jackson Doak (noskcaj) on 2014-01-14
description: updated
description: updated
Martin Pitt (pitti) wrote :

Closing trusty task as apparently this was fixed in 13.04 and later.

Changed in xfce4-weather-plugin (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Uploaded precise SRU, thanks Daniel! The SRU team now needs to review this. Unsubscribing sponsors.

Changed in xfce4-weather-plugin (Ubuntu Precise):
status: New → In Progress

Something strange occured yesterday with the patched version supplied by Daniel... Plugin systematically crash at startup (on two different PC). Today it works fine with no change...

Crashed again today with the lines below in apport.log file.
Hope it will not the same with the "official" Precise fixed version... :(

ERROR: apport (pid 2620) Thu Jan 16 17:03:41 2014: called for pid 2619, signal 6
ERROR: apport (pid 2620) Thu Jan 16 17:03:41 2014: executable: /usr/lib/i386-linux-gnu/xfce4/panel-plugins/xfce4-weather-plugin (command line "/usr/lib/i386-linux-gnu/xfce4/panel-plugins/xfce4-weather-plugin 15 31503613 weather Mise-à-jour\ météo Afficher\ les\ conditions\ météo\ actuelles")
ERROR: apport (pid 2620) Thu Jan 16 17:03:41 2014: gdbus call error: Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

ERROR: apport (pid 2620) Thu Jan 16 17:03:41 2014: debug: session gdbus call:
ERROR: apport (pid 2620) Thu Jan 16 17:03:44 2014: wrote report /var/crash/_usr_lib_i386-linux-gnu_xfce4_panel-plugins_xfce4-weather-plugin.1000.crash

Jackson Doak (noskcaj) wrote :

Debian should fix that issue in -5, we can just sync to precise from there.

Jackson Doak (noskcaj) on 2014-01-21
description: updated
Jackson Doak (noskcaj) wrote :

-5 is in debian s-p-u, it needs uploading to ubuntu asap

Micah Gersten (micahg) wrote :

Uploaded backport from s-p-u to -proposed

Changed in xfce4-weather-plugin (Ubuntu Precise):
importance: Undecided → High
status: In Progress → Fix Committed
Bucky Ball (buckyball) wrote :

I can confirm that:

xfce4-weather-plugin:
  Installed: 0.7.4-4~mediahacks1
  Candidate: 0.7.4-4~mediahacks1
  Version table:
 *** 0.7.4-4~mediahacks1 0
        100 /var/lib/dpkg/status
     0.7.4-3 0
        500 http://mirror.aarnet.edu.au/pub/ubuntu/archive/ precise/universe amd64 Packages

... is broken on one machine running 12.04 LTS Xubuntu and two with minimal install and xfce4 as the desktop environment. They all crashed at pretty much the same time (a couple of weeks ago?). I've only just decided to do something about it and found this report.

PPA packages/versions are unsupported. Please enable precise-proposed in repositories, if necessary, to test the backported version recently uploaded.

Bucky Ball (buckyball) wrote :

Added proposed following the guide here:

https://wiki.ubuntu.com/Testing/EnableProposed

I tried to install just the xfce4-weather-plugin using this command:

sudo apt-get install xfce4-weather-plugin/precise-proposed

... and got this:

E: Release 'precise-proposed' for 'xfce4-weather-plugin' was not found

I tried:

sudo aptitude install xfce4-weather-plugin/precise-proposed

... it installed the same version I had, 0.7.4-3. Tested and no different. Can't get the location in, just searches and stops. This was why I was trying to fix in first place. ;)

I'm aware my issue is due to this:

'Attention: Please update to 0.8.3. Versions older than 0.8.0 no longer work (bug #8105), and all earlier 0.8.x versions have problems with the search dialog (bug #9636) and are no longer supported.'

... from here:

http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin

Bucky Ball (buckyball) wrote :

I realise now I probably got this:

E: Release 'precise-proposed' for 'xfce4-weather-plugin' was not found

... because there was no upgrade or anything different about the version in proposed. Perhaps the fixed version hasn't made it to my mirror yet?

Hello Jim, or anyone else affected,

Accepted xfce4-weather-plugin into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfce4-weather-plugin/0.7.4-5~ubuntu12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

Enabled -proposed and updated to version 0.7.4-5~ubuntu12.04.1. All features work now.

tags: added: verification-done
removed: verification-needed
Jim Bauer (jfbauer-d) wrote :

Installed version '0.7.4-5~ubuntu12.04.1' (Ubuntu:12.04/precise-proposed [amd64])

It is working a lot better, but there seems to be an issue remaining.

When I bring up the forecast window everything looks reasonable except for the High
temps for each day. They show up as "NA".

Jim, try the version in my PPA: https://launchpad.net/~dtl131/+archive/mediahacks/+packages
I used the alternate patch which is still not perfect, but may be better for some: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=735478

Packagers, see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=735478#90
Given that information, backporting a newer version of the weather plugin may actually be more feasible than maintaining the old one, especially if it has major breakage again.

Jim Bauer (jfbauer-d) wrote :

Just tried https://launchpad.net/~dtl131/+archive/mediahacks/+files/xfce4-weather-plugin_0.7.4-5%7Emediahacks1_amd64.deb

Little bit better. The "NA"s are gone but today's high is listed as 99F. And no, it is not that hot here (more like 30s).

As far as I am concerned either this one of the one in proposed are worth moving to. They are at least useful.

Jim, the high will be listed as '99' after the hottest part of the day, but it should still work properly if you check it in the morning, no?

Jim Bauer (jfbauer-d) wrote :

The 99 for the high was in the evening. Looking now (~9am) the high for today looks good.

Bucky Ball (buckyball) wrote :

Try the .deb for amd64 from here:

https://launchpad.net/ubuntu/+source/xfce4-weather-plugin/0.7.4-5~ubuntu12.04.1/+build/5563383

The forecasts are way out but the current temperature and details, oddly, are pretty much bang on. When I go for the long range forecast and click on 'Details' I get the 99s at the bottom of the page:

More on weather.com
 99
 99
 99
 99

No big issue. The relevant info is there, even if it is out by around five degrees. I look forward to the final fix reaching the official repos. I'm testing 14.04 at the moment and the xfce4 weather plugin there rocks!

Bucky Ball (buckyball) wrote :

Typo. I didn't mean 'Try the .deb for amd64 from here', but by all means do, I meant I am TRYING that .deb and here are my results ... ;) For clarity.

The verification of the Stable Release Update for xfce4-weather-plugin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-weather-plugin - 0.7.4-5~ubuntu12.04.1

---------------
xfce4-weather-plugin (0.7.4-5~ubuntu12.04.1) precise; urgency=low

  * No-change backport to precise (LP: #1244629)

xfce4-weather-plugin (0.7.4-5) wheezy; urgency=low

  * debian/patches:
    - 02_NULL-hi added, fix cases where <hi> element is empty. closes: #735478

xfce4-weather-plugin (0.7.4-4) wheezy; urgency=low

  * debian/patches:
    - 01_uri_change added, update weather.com API URI. closes: #727628
 -- Micah Gersten <email address hidden> Thu, 23 Jan 2014 17:31:44 -0600

Changed in xfce4-weather-plugin (Ubuntu Precise):
status: Fix Committed → Fix Released
luca (l-savio) wrote :

Still this issue in Trusty ver. 0.8.3-1 ... maybe the problem is with the weather service's api.

Martin Spacek (mspacek) wrote :

@luca, not still, this is a new issue, started showing "No data" around last weekend, maybe October 11, 2014 . This is on Xubuntu 14.04 amd64.

This bug report refers to an old old version of this issue. xfce4-weather-plugin has been using met.no for its data for a while now. I suppose something's changed with the met.no API? I even tried compiling and installing the latest xfce4-weather-plugin from git:

http://git.xfce.org/panel-plugins/xfce4-weather-plugin/

...but that doesn't help. I have this problem on 3 different machines running Xubuntu 14.04. Not sure where to alert the devs, though if they use it on a regular basis, they've probably noticed the problem as well.

Martin Spacek (mspacek) wrote :

Actually, from the timestamps of the cache files in $HOME/.cache/xfce4/weather, it looks like the last successful data retrieval was Oct 12.

Martin Spacek (mspacek) wrote :

Never mind. The latest version in git does indeed work. met.no changed their API from 1.1 to 1.2:

http://api.yr.no/weatherapi/locationforecastlts/1.2/documentation

1.2 was implemented in git in xfce4-weather-plugin this summer, and met.no deprecated 1.1 about a week ago. My problem was that I wasn't installing the git version properly. The panel in xubuntu uses /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins/ as the plugin path, but autogen.sh only allows you to set the first part of the prefix:

autogen.sh --prefix=/usr

But that installs to /usr/lib/xfce4/panel/plugins/, which is missing the x86_64-linux-gnu part of the path. So, I manually copied the libweather.so and libweather.la files to /usr/lib/x86_64-linux-gnu/xfce4/panel/plugins, restarted the panel with xfce4-panel -r, and that did it.

luca (l-savio) wrote :

Good work, @Martin :) I'll wait for a fix committed in regular updates, hoping devs will read your report. Thanks.

Also looking forward to a properly functioning release for Ubuntu 14.04.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.