Tooltips unresponsive

Bug #1740578 reported by Kev Bowring on 2017-12-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4
Fix Released
Medium
xfce4-taskmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Hovering over a process shows a key to colours used to show when the state of process is changing.

The tooltip hangs around often and can be unresponsive.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xfce4-taskmanager 1.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.14.0-13.15-generic 4.14.7
Uname: Linux 4.14.0-13-generic x86_64
ApportVersion: 2.20.8-0ubuntu5
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Dec 30 08:47:43 2017
InstallationDate: Installed on 2017-09-02 (119 days ago)
InstallationMedia: Xubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170902)
SourcePackage: xfce4-taskmanager
UpgradeStatus: No upgrade log present (probably fresh install)

Kev Bowring (flocculant) wrote :

Hovering over a process shows a key to colours used to show when the state of process is changing.

The tooltip hangs around often and can be unresponsive.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-taskmanager (Ubuntu):
status: New → Confirmed
Changed in xfce4:
importance: Unknown → Medium
status: Unknown → Confirmed
Sean Davis (bluesabre) wrote :

I can still reproduce this with 19.04.

tags: added: cosmic disco

Created attachment 8437
proposed patch

Alternatively, the tooltip could be bound to each individual row, so that it will be more responsive.

In , Gitbot (gitbot) wrote :

Simon Steinbeiss referenced this bugreport in commit a18b8bd3c357af82fd68e1e11a046d7727b02c51

Move legend from tooltip to hide-able statusbar (Bug #14131)

https://git.xfce.org/apps/xfce4-taskmanager/commit?id=a18b8bd3c357af82fd68e1e11a046d7727b02c51

The tooltip is no more, the information is now shown in a statusbar that can be shown or hidden (shown by default).

Changed in xfce4:
status: Confirmed → Fix Released
Sean Davis (bluesabre) on 2019-10-16
tags: added: eoan
Sean Davis (bluesabre) wrote :

@ochosi, Can you release a new xfce4-taskmanager version? We can pull it into 20.04 and cleanup one of these papercut bugs :)

Sean Davis (bluesabre) on 2020-04-12
tags: added: focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-taskmanager - 1.2.3-0ubuntu1

---------------
xfce4-taskmanager (1.2.3-0ubuntu1) focal; urgency=medium

  * New upstream bugfix release.
    - Fixes unresponsive tooltips (LP: #1740578)
  * d/control:
    - Bump Standards-Version to 4.5.0
    - Set Rules-Requires-Root to no
  * d/compat, d/control:
    - Bump to debhelper-compat 12
  * d/copyright:
    - Use https for debian copyright format

 -- Sean Davis <email address hidden> Sun, 12 Apr 2020 06:03:55 -0400

Changed in xfce4-taskmanager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.