xfce4-settings-manager crashed with SIGSEGV in gtk_drag_finish()

Bug #1785143 reported by Mariusz Kubański on 2018-08-02
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfwm4
Fix Released
Medium
xfce4-settings (Ubuntu)
Medium
Unassigned

Bug Description

I was changing some options in the Window Manager settings (xfwm4 4.13.1). It started behaving strangely - when I clicked somewhere in the Window Manager settings window it brought me back to the main settings window, I clicked on Window Manager icon, WM settings window showed up and the crash report opened.

ProblemType: Crash
DistroRelease: Ubuntu 18.10
Package: xfce4-settings 4.13.3-0ubuntu1
ProcVersionSignature: Ubuntu 4.17.0-6.7-generic 4.17.9
Uname: Linux 4.17.0-6-generic x86_64
ApportVersion: 2.20.10-0ubuntu7
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Aug 3 00:59:43 2018
ExecutablePath: /usr/bin/xfce4-settings-manager
InstallationDate: Installed on 2018-08-01 (1 days ago)
InstallationMedia: Xubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180801)
ProcCmdline: xfce4-settings-manager
SegvAnalysis:
 Segfault happened at: 0x7f088d2db1ed <gtk_drag_finish+29>: mov (%rbx),%rdx
 PC (0x7f088d2db1ed) ok
 source "(%rbx)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfce4-settings
StacktraceTop:
 gtk_drag_finish () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: xfce4-settings-manager crashed with SIGSEGV in gtk_drag_finish()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Mariusz Kubański (spass) wrote :
information type: Private → Public

StacktraceTop:
 gtk_drag_finish (context=0x8, success=0, del=0, time=6) at ../../../../gtk/gtkdnd.c:961
 gtk_drag_drop_finished (info=0x560a3ecfbd60, result=result@entry=GTK_DRAG_RESULT_TIMEOUT_EXPIRED, time=<optimized out>) at ../../../../gtk/gtkdnd.c:2593
 gtk_drag_abort_timeout (data=<optimized out>) at ../../../../gtk/gtkdnd.c:3265
 gdk_threads_dispatch (data=0x560a3ea53f20, data@entry=<error reading variable: value has been optimized out>) at ../../../../gdk/gdk.c:755
 g_timeout_dispatch (source=source@entry=0x560a3ecdeac0, callback=<optimized out>, user_data=<optimized out>) at ../../../../glib/gmain.c:4650

Changed in xfce4-settings (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Created attachment 7885
terminal output

Hello, I'm testing Xubuntu 18.10 with xfwm4 4.13.1 installed in VirtualBox VM. I have an issue with xfwm4-settings (opened separately and within the xfce4-settings-manager) window crashing when I change the button layout, just by dragging it's elements.

There are some issues with "gtk_widget_size_allocate" and most important:
xfwm4-settings: ../../../../src/cairo-surface.c:1734: cairo_surface_mark_dirty_rectangle: Assertion `! _cairo_surface_has_mime_data (surface)' failed.
(full terminal output attached)

Besides the window closing/crashing, when I open Window Manager settings from Settings Manager (and only then) and when I change the button layout, the buttons are disappearing from that section (see here - https://ibb.co/mXtPBU ). Probably related to "gtk_widget_size_allocate".

Also, this is my Launchpad bug report related to this issue, maybe it will be useful:
https://bugs.launchpad.net/ubuntu/+source/xfce4-settings/+bug/1785143

Changed in xfwm4:
importance: Unknown → Medium
status: Unknown → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1785143

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-settings (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

Ubuntu-Studio 19.04 QA-Test (live)

I didn't note any strange behavior (I'd left the room briefly and came back to this)

I was just using xfce4-settings-manager just prior to leaving the room, and had just changed my window dressing (button layout change then style to another choice [moheli]).

Mariusz Kubański (spass) wrote :

I have the same issue on Xubuntu 19.04 Disco Dingo with some development PPAs.

xfce4-settings:
  Installed: 4.13.4-1ubuntu2

tags: added: disco

I'm on Xubuntu 19.04 Disco Dingo now and I still have this issue with Window Manager settings window. It doesn't always crash, but the issue with disappearing buttons when changing the layout is all the time, easy to reproduce.

xfwm4 4.13.1-3~19.04, VirtualBox VM

Bug reports from Launchpad related to this issue:
https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/1821638
https://bugs.launchpad.net/ubuntu/+source/xfwm4/+bug/1821517

Chris Guiver (guiverc) wrote :

I tested today using Xubuntu 19.04 daily (20190325) and could NOT re-create this issue.
dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

--
comment #10 was I believe build 20190322, and on box
dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
taken from http://iso.qa.ubuntu.com/qatracker/milestones/398/builds/190037/testcases/1303/results

In , Gitbot (gitbot) wrote :

Olivier Fourdan referenced this bugreport in commit 60a8e49c8a63db47b8eb31618e0b6aa5be729a80

settings: Crash in button layout

https://git.xfce.org/xfce/xfwm4/commit?id=60a8e49c8a63db47b8eb31618e0b6aa5be729a80

Changed in xfwm4:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.