Horizontal scrolling sensitivity differs from vertical

Bug #1409478 reported by Ben James on 2015-01-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-settings
Confirmed
Medium
xfce4-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Summary:

When horizontal scrolling is enabled (xfce4-mouse-settings: Menu | Settings | Mouse and Touchpad) it does not honour the sensitivity/acceleration settings.

Related issues:

"Enable horizontal scrolling" doesn't work with "Reverse scroll direction" - https://bugs.launchpad.net/ubuntu/+source/xfce4-settings/+bug/1409347

Aside:

In addition (and this may warrant a separate ticket), the options in the UI are somewhat confusing:

1) The "Sensitivity" option has a tooltip which reads as if the option should actually be named "Threshold" as it defines when the acceleration option comes into effect. To exacerbate the issue, lowering the slider (further left) decreases the threshold and actually increases the "sensitivity".

2) There is no actual sensitivity option - i.e. there is no way to change the underlying mapping between distance moved on the touchpad and distance moved on the screen; this makes it very awkward to use a laptop with a small touchpad without having an "edgy" feel to the mouse (i.e. relying on acceleration to when sensitivity isn't appropriate).

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xfce4-settings 4.11.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-29.39-generic 3.16.7-ckt2
Uname: Linux 3.16.0-29-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Jan 11 16:09:29 2015
ExecutablePath: /usr/bin/xfce4-mouse-settings
InstallationDate: Installed on 2015-01-10 (1 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: xfce4-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Ben James (ben-c-james) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/Xfce. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Summary:

When horizontal scrolling is enabled (xfce4-mouse-settings: Menu | Settings | Mouse and Touchpad) it does not honour the sensitivity/acceleration settings.

Related issues:

"Enable horizontal scrolling" doesn't work with "Reverse scroll direction" - https://bugs.launchpad.net/ubuntu/+source/xfce4-settings/+bug/1409347

Aside:

In addition (and this may warrant a separate ticket), the options in the UI are somewhat confusing:

1) The "Sensitivity" option has a tooltip which reads as if the option should actually be named "Threshold" as it defines when the acceleration option comes into effect. To exacerbate the issue, lowering the slider (further left) decreases the threshold and actually increases the "sensitivity".

2) There is no actual sensitivity option - i.e. there is no way to change the underlying mapping between distance moved on the touchpad and distance moved on the screen; this makes it very awkward to use a laptop with a small touchpad without having an "edgy" feel to the mouse (i.e. relying on acceleration to when sensitivity isn't appropriate).

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: xfce4-settings 4.11.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-29.39-generic 3.16.7-ckt2
Uname: Linux 3.16.0-29-generic x86_64
ApportVersion: 2.14.7-0ubuntu8.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Jan 11 16:09:29 2015
ExecutablePath: /usr/bin/xfce4-mouse-settings
InstallationDate: Installed on 2015-01-10 (1 days ago)
InstallationMedia: Xubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: xfce4-settings
UpgradeStatus: No upgrade log present (probably fresh install)

See downstream bug here: https://bugs.launchpad.net/ubuntu/+source/xfce4-settings/+bug/1409478

Ben James (ben-c-james) wrote :

Upstream bug created here: https://bugzilla.xfce.org/show_bug.cgi?id=11457

There's a link on the upstream bug back to this one also.

Changed in xfce4-settings:
importance: Unknown → Medium
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.