xfdesktop4 crashes on exit with xorg-server 1.10

Bug #711571 reported by Ronald McCollam on 2011-02-01
154
This bug affects 25 people
Affects Status Importance Assigned to Milestone
xfdesktop
Fix Released
Critical
xfce4-session (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned
xfdesktop4 (Ubuntu)
Low
Lionel Le Folgoc
Natty
Low
Unassigned

Bug Description

Binary package hint: xfce4-session

In xubuntu desktop amd64, "reboot" and "shut down" do not work from the live session. Instead they simply return to the login screen. Rebooting from the login screen works correctly.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xfce4-session 4.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Tue Feb 1 18:21:00 2011
LiveMediaBuild: Xubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201)
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: xfce4-session

WORKAROUND:
restart and shutdown log out to the GDM screen. At the GDM screen, click the actions icon in the bottom, click either restart or shutdown.

Related branches

Ronald McCollam (fader) wrote :
summary: - "Reboot" and "Shut down" do not work from live session desktop
+ Xfce Shutdown/Restart doesn't work (logout instead)

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I am able to reproduce this issue in VirtualBox.

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-session (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
tags: added: iso-testing
Changed in xfce4-session (Ubuntu Natty):
milestone: none → natty-alpha-3
Randy Klein (randyklein99) wrote :

Having same problem with Gnome. Happens on both a fresh 32 bit 10.10 install on laptopn and an upgrade 64 bit 10.10 on a desktop.

Charlie Kravetz (charlie-tca) wrote :

Randy Kein - I would suggest filing a new bug report for that. This is restricted to the Natty Xubuntu 64bit images only, probably related to Xfce 4.8. Thanks in advance.

Charlie Kravetz (charlie-tca) wrote :

This bug is only present using the "session menu" to reboot and shutdown. If the panel is right-clicked, high-light Panel, then click "Log Out", the system will give you a window with 5 actions. Choose "restart" and the machine restarts as expected. Either method when clicking on "shutdown" will simply logout and leave the user at the GDM screen.

Lionel Le Folgoc (mrpouit) wrote :

I had the same bug with the logout dialog also... Could someone provide a .xsession-errors from a session that didn't restart/shutdown correctly (if you relogged in after, it will be in .xsession-errors.old instead)? If you can see some errors such as "error 104 (connection reset)", I think Xorg is crashing on shutdown (this bug only appeared with the recent X upload).

Changed in xfce4-session (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Charlie Kravetz (charlie-tca) wrote :

Fresh Natty pre-alpha3 installation, instead of running update-manager, went to shutdown. The VBox 64 install went to gdm instead. Checking screens, Alt+F7 is blank, gdm is on Alt+F8. Am attaching the Xsession-errors.txt log file copied while at the gdm screen, before going further.

Xfdesktop is crashing on exiting session (logout, shutdown) when using xorg-server 1.10.

Bugtrace from log:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x46b688]
1: /usr/bin/X (0x400000+0x5f8b9) [0x45f8b9]
2: /lib/libpthread.so.0 (0x7ffb86e97000+0xf150) [0x7ffb86ea6150]
3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7ffb84224000+0x2564d) [0x7ffb8424964d]
4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7ffb84224000+0x25aa8) [0x7ffb84249aa8]
5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7ffb84224000+0x25b31) [0x7ffb84249b31]
6: /usr/bin/X (0x400000+0x99ef0) [0x499ef0]
7: /usr/bin/X (ChangeWindowAttributes+0x2c3) [0x443933]
8: /usr/bin/X (0x400000+0x4ce38) [0x44ce38]
9: /usr/bin/X (0x400000+0x52b01) [0x452b01]
10: /usr/bin/X (0x400000+0x2132e) [0x42132e]
11: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7ffb85e17dcd]
12: /usr/bin/X (0x400000+0x20ed9) [0x420ed9]
Segmentation fault at address 0x10

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Changed in xfce4-session (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
In , anm1 (anm1) wrote :

    Backtrace:
    0: /usr/bin/X (xorg_backtrace+0x37) [0x80a38e7]
    1: /usr/bin/X (0x8048000+0x5faea) [0x80a7aea]
    2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb785040c]
    3: /usr/bin/X (ChangeGC+0x182) [0x8083cd2]
    4: /usr/bin/X (miPaintWindow+0x107) [0x809e5e7]
    5: /usr/bin/X (miWindowExposures+0xc0) [0x809e870]
    6: /usr/bin/X (miHandleValidateExposures+0x84) [0x81b49b4]
    7: /usr/bin/X (MapWindow+0x23d) [0x8099c2d]
    8: /usr/bin/X (ReparentWindow+0x25b) [0x809b31b]
    9: /usr/bin/X (0x8048000+0x23067) [0x806b067]
    10: /usr/bin/X (0x8048000+0x29217) [0x8071217]
    11: /usr/bin/X (0x8048000+0x1c17c) [0x806417c]
    12: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb7583db6]
    13: /usr/bin/X (0x8048000+0x1c491) [0x8064491]
    Segmentation fault at address 0x2

    Fatal server error:
    Caught signal 11 (Segmentation fault). Server aborting

In , Aaron (akb825) wrote :

I have the same problem on one of my computers, which has a Radeon 4650 running the open source radeon drivers. It is intermittent, though, and sometimes doesn't crash. I have yet to see this crash on my other computer, which has a NVidia 460 GTX with the proprietary drivers. (though since I've heard that NVidia replaces part of XOrg with their drivers, I suppose that isn't too surprising that the behavior is different...)

In , Lisaev (lisaev) wrote :

This issue is not x86_64 specific, happens on an i686 too.

In , Aaron (akb825) wrote :

I have now experienced this crash on my computer with the NVidia card, it's just much less common than my computer with the ATI card. Here's the backtrace for the crash that just happened with the NVidia card.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x26) [0x45d396]
1: /usr/bin/X (0x400000+0x617b9) [0x4617b9]
2: /lib/libpthread.so.0 (0x7f171683a000+0xf150) [0x7f1716849150]
3: /usr/bin/X (ChangeGC+0x194) [0x4400c4]
4: /usr/bin/X (miPaintWindow+0xf6) [0x458416]
5: /usr/bin/X (miWindowExposures+0xc2) [0x458682]
6: /usr/bin/X (0x400000+0x12bc0d) [0x52bc0d]
7: /usr/bin/X (miHandleValidateExposures+0x68) [0x55c398]
8: /usr/bin/X (UnmapWindow+0x200) [0x4544a0]
9: /usr/bin/X (0x400000+0x1621f4) [0x5621f4]
10: /usr/bin/X (0x400000+0xa11e9) [0x4a11e9]
11: /usr/bin/X (FreeResource+0x124) [0x44b684]
12: /usr/bin/X (0x400000+0x1616d8) [0x5616d8]
13: /usr/bin/X (0x400000+0x161a8e) [0x561a8e]
14: /usr/bin/X (0x400000+0xa11d9) [0x4a11d9]
15: /usr/bin/X (FreeClientResources+0xdc) [0x44bd5c]
16: /usr/bin/X (CloseDownClient+0x5a) [0x42deaa]
17: /usr/bin/X (0x400000+0x2e9ee) [0x42e9ee]
18: /usr/bin/X (0x400000+0x22b7e) [0x422b7e]
19: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f17157badcd]
20: /usr/bin/X (0x400000+0x22e6d) [0x422e6d]
Segmentation fault at address 0x2

Changed in xfce4-session (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Charlie Kravetz (charlie-tca) wrote :

This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=7442

Changed in xfce4-session (Ubuntu Natty):
milestone: ubuntu-11.04 → none
Changed in xfdesktop4 (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Low
Changed in xfce4-session (Ubuntu Natty):
importance: Medium → Low
In , 8-nick (8-nick) wrote :

I've disabled the code that causes the crash in bf07cc0, but I think it might be a problem in X itself.
X might still try to use/unref the pixmap set by xfdesktop, but when xfdesktop is closed, this is obviously not available, causing the crash. Not very important to keep the background when xfdesktop is not running any more, but not a proper fix as well.

Martin Erik Werner (arand) wrote :

Upstream did a workaround fix.
Probably something we might want in before relese.
debdiff attached
my "main" PPA should soon have patched packages for testing:
https://edge.launchpad.net/~arand/+archive/ppa

In , 8-nick (8-nick) wrote :

The root window pixmap is used for pseudo-transparent windows, like terminal without compositing enabled.

tags: added: patch

(In reply to comment #7)
> The root window pixmap is used for pseudo-transparent windows, like terminal
> without compositing enabled.

Yep, noticed that. My terminal windows are not transparent anymore, so i'll wait for a better fix before updating xfdesktop..

Lionel Le Folgoc (mrpouit) wrote :

The upstream workaround is introducing regressions with pseudo transparent windows (e.g. transparent terminal windows without compositing don't work anymore).

Changed in xfce4-session (Ubuntu Natty):
status: Triaged → Invalid
summary: - Xfce Shutdown/Restart doesn't work (logout instead)
+ xfdesktop4 crashes on exit with xorg-server 1.10
tags: added: patch-needswork
removed: patch
In , Lisaev (lisaev) wrote :

These two are probably related (should be in the Blocks section?):
https://bugzilla.xfce.org/show_bug.cgi?id=7534
https://bugzilla.xfce.org/show_bug.cgi?id=7535

Changed in xfdesktop4 (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfdesktop4 (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.8.2-1ubuntu1

---------------
xfdesktop4 (4.8.2-1ubuntu1) oneiric; urgency=low

  * Merge with Debian unstable, remaining Ubuntu changes:
    - debian/patches:
      + xubuntu_hide-ugly-resize-grip.patch: disable resize grips for xfdesktop's
        root windows. lp: #709279
      + series: added.

  * Bugs closed by this new upstream release:
    - crash with SIGSEGV in g_closure_invoke() lp: #724816
    - crash with SIGSEGV in g_type_check_instance_is_a() lp: #733822
    - explicit gamin dependency dropped lp: #776503
    - crash on exit with xorg-server 1.10 lp: #711571
    - Cannot create an empty file on the desktop lp: #754595
 -- Lionel Le Folgoc <email address hidden> Sat, 11 Jun 2011 22:39:00 +0200

Changed in xfdesktop4 (Ubuntu):
status: Fix Committed → Fix Released
In , 8-nick (8-nick) wrote :

*** Bug 7534 has been marked as a duplicate of this bug. ***

In , 8-nick (8-nick) wrote :

Maybe this will be fixed in xorg-server-1.10.3

Christian (kurisu666) wrote :

I have the feeling that the Menu doesn't have the rights to do it always, I wonder if a

sudo chmod a+s /sbin/shutdown

would help ?

(In reply to comment #11)
> Maybe this will be fixed in xorg-server-1.10.3

partially ... Terminal has back transparency but XChat 2.8.8 has not.

Closing Terminal leaves a zombie process behind, which consumes all CPU time.

Peyre (lordpeyre) wrote :

"This bug was fixed in the package xfdesktop4 - 4.8.2-1ubuntu1"

It was?? I'm running a freshly-installed copy of Xubuntu 11.04 (with the latest updates, of course), and it's still doing this to me. When I click the Shut Down option, it logs me off instead. I tell my machine to shut down and I go to bed, then come downstairs in the morning to find my computer's been on all night doing nothing, sitting at the login screen.

Charlie Kravetz (charlie-tca) wrote :

Xubuntu 11.04 is not running xfdesktop4 4.8.2-1ubutnu1, it is running an older version. Oneiric Ocelot is running the current version and does not have the logoff instead of reboot/shutdown issue. In the status line at the top of the report, the task for natty is still in triaged status, showing this has not been fixed in the release you are using.

xfdesktop4 | 4.8.1-1ubuntu2 | natty/universe | source, amd64, i386
xfdesktop4 | 4.8.2-1ubuntu1 | oneiric/universe | source, amd64, i386

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

This is also present in the 32 bit version, on 3 of my pc's.

Leon Baradat (raceintospace) wrote :

I should echo dennygoot. My machine which is experiencing the issue is 32-bit, not 64.

Thanks Charlie. That makes sense now.

Kangarooo Jānis (kangarooo) wrote :

I have this problem on Xubuntu 11.04 installed 6d ago && latest updates
Nvidia video card using Noveau default driver.
When Composing enabled all is fine. when disabled then not working but instead restart and shutdown just logs out.

What's the status of this issue?

With
  xorg-server-1.11.3
  xfdesktop-4.8.3
  terminal-0.4.8

there are still no (software rendered) transparent backgrounds in terminal (or rxvt-unicode) on my machine.

(There's no segfault, though.)

dino99 (9d9) on 2013-05-18
Changed in xfdesktop4 (Ubuntu Natty):
status: Triaged → Invalid
Changed in xfdesktop:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.