preferences and calendar popup on login

Bug #208014 reported by Günter
14
Affects Status Importance Assigned to Milestone
xfce4-session (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: orage

(very similar to #186050)

on newest xubuntu hardy:

when I activate orage via "Settings Manager", everytime I login xfce, orage pop-ups up including the preferences dialog.

-> Session saving is deactivated
-> yes, I tried all "Calendar starts" options (hide/minimized) - and even then, I don't think the Preferences dialog should ever pop-up?

Revision history for this message
Juha Kautto (kautto-juha) wrote :

I can reproduce this by starting orage with preferences option:
orage -p
and then saving this session.

I bet if you do
ps -ef | grep orage
you will see that you have orage started like this?
and the parent process is
xfce4-session

If that is the case, you can fix it by ending that Orage session
and starting new without any parameters and saving that session.

Revision history for this message
Günter (guenter-grodotzki) wrote :

yep you are right. I figured out this is actually an issue of the session manager rather than of orage itself.

Check out: http://forum.xfce.org/index.php?topic=3733.0 seems to happen with other apps, too.

Revision history for this message
Vincent (vinnl) wrote :

Marked as invalid, please re-report it with xfce4-session if that's where the problem is. https://bugs.launchpad.net/ubuntu/+source/xfce4-session/+filebug

Changed in orage:
status: New → Invalid
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

As stated above, the issue seems to be in xfce4-session, so no need to file a new bug.

Changed in orage:
status: Invalid → New
Revision history for this message
Vincent (vinnl) wrote :

(...) I'm stupid, I could've just changed the package... >.<
Ah well, I'll remember it for next time ;-)

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Uh no, nevermind (sorry vincent). That's indeed invalid: the session is saved, so that's normal if orage is restarted with the same options...

Changed in xfce4-session:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers