Power Manager does not suspend computer on LID close if external monitor is plugged-in

Bug #1855078 reported by G.M. on 2019-12-04
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-power-manager (Ubuntu)

Bug Description


I think this is a regression... I had the exact same problem (system not going to suspend when LID is closed and external monitor plugged-in) with XUbuntu 19.04.
Under Xubuntu 19.04, I was using light-locker and was advised to switch to power manager. This solved the problem.

However, I recently upgraded to XUbuntu 19.10 and now, I get the exact same problem: if my external monitor is plugged-in, then closing the LID the computer does not suspend, it only switches the monitor external monitor to black screen (sleep?) for half a second, then switches it on again.

See demonstration at:

light-lock says power manager is responsible for the PM config:

Xfce Power Manager is version 1.6.5

I've tried the solution provided in the following answer:
With this the external monitor does blank/go to sleep, then wakes up, then goes to blank again, but the system does not go to suspend on lid close. It *does* go to suspend... *but when the lid is reopened!!!!*

I tried to remove power manager and switch back to light-locker. It does not work either.

I tried to look at the scripts, but there are tens of redirections between the various daemons in charge of PM/screen locking (logind, systemd, lightlocker, ...). This ping-pong game is simply intrackable by hand.
My 2 cents: It would be great if the power management/screen locking layer could be simplified, for instance by replacing totally one system by another (following the user's choice), instead of piling up and tight coupling many incompatible solutions... This would simplify both maintenance and simple functioning...

G.M. (sexxxenator) on 2019-12-04
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers