xfce4-panel crashed with SIGSEGV in _IceTransWrite()

Bug #480094 reported by strodti on 2009-11-10
60
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Xfce panel
In Progress
Unknown
xfce4-panel (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-panel

Firefox 3.5.3 in xubuntu 9.10 (live-CD) is abortet/crashed, and now xfce4-panel is also crashed

ProblemType: Crash
Architecture: i386
Date: Tue Nov 10 16:05:14 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/xfce4-panel
LiveMediaBuild: Xubuntu 9.10 "Karmic Koala" - Release i386 (20091028.3)
Package: xfce4-panel 4.6.1-3ubuntu2
ProcCmdline: xfce4-panel
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SegvAnalysis:
 Segfault happened at: 0xb2397c <_IceTransWrite+12>: mov (%eax),%edx
 PC (0x00b2397c) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfce4-panel
StacktraceTop:
 _IceTransWrite () from /usr/lib/libICE.so.6
 _IceWrite () from /usr/lib/libICE.so.6
 IceFlush () from /usr/lib/libICE.so.6
 SmcRequestSaveYourself () from /usr/lib/libSM.so.6
 logout_session () from /usr/lib/libxfcegui4.so.4
Title: xfce4-panel crashed with SIGSEGV in _IceTransWrite()
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

strodti (js-strodti) wrote :

StacktraceTop:_IceTransWrite (ciptr=0x0, buf=0x0, size=49)
_IceWrite (iceConn=0x8bc5e00, nbytes=49, ptr=0x0)
IceFlush (iceConn=0x8bc5e00) at ../../src/misc.c:80
SmcRequestSaveYourself (smcConn=0x8bc6db8, saveType=2,
logout_session (session_client=0x8bc5cf0)

Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=6213

Changed in xfce4-panel (Ubuntu):
status: Confirmed → Triaged
Charlie Kravetz (charlie-tca) wrote :

The upstream developers believe this is fixed in libxfcegui4 4.6.3, which is in Lucid Lynx.

The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Lucid Lynx. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . It can be downloaded from http://cdimages.ubuntu.com/xubuntu/daily-live/current/ . Thanks again and we appreciate your help.

Charlie Kravetz (charlie-tca) wrote :

Crash occurred during ISO image testing of the Release Candidate for Xubuntu Lucid. Reported to developers at Xfce.

tags: added: iso-testing
A. Denton (aquina) wrote :

It also happened when testing [L1]. I marked the bug as serious in iso.qa.ubuntu.com since this happened the third time to me now and I think it is a severe drawback for Xubuntu users.

[L1] http://cdimage.ubuntu.com/xubuntu/daily-live/20100429/lucid-desktop-i386.iso

Changed in xfce4-panel:
status: Unknown → In Progress
Lionel Le Folgoc (mrpouit) wrote :

Should be fixed in natty (Xfce 4.8~pre1).

Changed in xfce4-panel (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.