Unity indicators not displaying correctly

Bug #1004870 reported by Mezgrman on 2012-05-26
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Xfce4 Indicator Plugin
Confirmed
Low
xfce4-indicator-plugin (Ubuntu)
Low
Unassigned

Bug Description

I updated my system just yesterday (just the standard apt-get update && apt-get upgrade) and now the "Unity" indicators don't display correctly in the panel. (Hardware sensors indicator and System load indicator). See this screenshot: http://www.mezgrman.de/scr/Btfi5R.png
The "blank" area should display the system load indicator. From the few visible pixels I think that the indicator is displayed, but just incredibly zoomed-out. The hardware sensors indicator only shows the icon, not the temperatures.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xfce4-panel 4.8.6-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-13.53-generic 2.6.38.8
Uname: Linux 2.6.38-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Sat May 26 14:16:26 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: xfce4-panel
UpgradeStatus: Upgraded to precise on 2012-04-28 (27 days ago)

Mezgrman (mezgrman-o) wrote :
affects: xfce4-panel (Ubuntu) → xfce4-indicator-plugin (Ubuntu)

My system is Xfce 4.10 (installed from https://launchpad.net/~xubuntu-dev/+archive/xfce-4.10) running on Ubuntu 12.04. Both Xfce 4.10 and the OS are fully updated.

I have described the problem here (http://forum.xfce.org/viewtopic.php?id=7233) and here (http://ubuntuforums.org/showthread.php?t=2003403).

I hope that is adequate.

I marked the component as Notification Area because that is where the System Load Indicator is displayed.

I am also affected by this bug and have already reported it here: https://bugs.launchpad.net/ubuntu/+source/xfce4-indicator-plugin/+bug/1004870

Here is a screenshot of the problem. Note that the hardware sensors indicator is also not being displayed correctly; I have to click the icon to view temperatures instead of having them displayed directly in the panel. http://www.mezgrman.de/scr/MTsvBz.png

Mezgrman (mezgrman-o) wrote :

This bug is also reported here: https://bugzilla.xfce.org/show_bug.cgi?id=9040
It is still not solved.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-indicator-plugin (Ubuntu):
status: New → Confirmed
In , alekos (alekos) wrote :

in case it matters, the same problem exists under Xfce 4.08 (with ubuntu 12.04.)

Changed in xfce4-indicator-plugin (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
David Holmer (odinguru) wrote :

I am also having this issue.

I'm running Xubuntu 12.10 (fully updated as of 2012-11-30) with xfce4-indicator-plugin 0.5.0-1ubuntu2.

The primary affected indicator is indicator-multiload (I'm running 0.3-0+66~34~17~quantal1). This is a variable width indicator that shows graphs of CPU usage, network traffic, load, etc. The width of these graphs in pixels is controlled by user preference, as well as which graphs to show. This can result in a very wide indicator if many graphs are turned on.

The issue appears to be that xfce4-indicator-plugin is taking the image output by indicator-multiload and explicitly scalling it down so that it fits in a space that is about as wide as a single "standard" menu indicator. This ends up being useless because lots of graphs end up being much wider than tall, so the scalled down version is just looks like a horizontal line of pixels.

I can confirm the problem in Xubuntu 12.10 / Xfce 4.10.

multiload indicator devs pointed the problem as an indicator-plugin's fault from the bugs filed on their tracker, see https://bugs.launchpad.net/indicator-multiload/+bug/1014494

Moving to correct component.

Thank you for the report (and sorry for the delay, I only found it today).

It is indeed a bug in the indicator plugin. Version 0.4 simply assumes that all icons are square. I will try to add support for non-square icons back. Unfortunately, this is not as simple as it looks - it seems to conflict with icon scaling that was added recently.

Note, that rectangular icons will not be fully supported because in narrow vertical panels icons like the ones used in multiload-plugin will simply not fit.

A new branch in the repo has this error partially "fixed". The icon is still small but at least there is no empty space added next to it.

Should be now fixed in andrzejr/tmp3 git branch. Testing appreciated.

Hi Andrzej,

I think the fix should be to scale icons that are too high (on horizontal panels) or too wide (on vertical panels) to fit onto the panel, but then without taking the other dimension (width on horizontal, height on vertical panels) into account.

Thanks for working on this!
  Michael

Uriel Tunn (u2n) wrote :

Just did a fresh install of 12.04.2 x86_64 (3.5.0-37-generic) and find the same problem. Digging around, find no easy fix.

In , flg (flg) wrote :

(In reply to Andrzej from comment #7)
> Should be now fixed in andrzejr/tmp3 git branch. Testing appreciated.

Sorry to ask but what is the address of the git server so that I can test. The bug still exists.

(In reply to flg from comment #9)
> (In reply to Andrzej from comment #7)
> > Should be now fixed in andrzejr/tmp3 git branch. Testing appreciated.
>
> Sorry to ask but what is the address of the git server so that I can test.
> The bug still exists.

Code is on git.xfce.org
But there have benn several releases since. I suggest just checking the latest release.

In , flg (flg) wrote :

Sorry I wasn't clear. The version embedded in latest Xubuntu version sill shows up the issue. I was trying to fetch Andrzej's code to check if it works for me.

git clone git://git.xfce.org/andrzejr/tmp3 does not work. But it is likely to be a network access issue on my side. Can you just please confirme this is the right command/address to fetch this code ?

flg, can you tell me what is your:
- xubuntu version,
- xfce4-indicator-plugin version,
and describe the issue you are seeing?

For your information, andrzejr/tmp3 branch was merged in xfce4-indicator-plugin-1.0.0 (gtk2 version). The mechanism of handling the icon sizing has then been changed again in xfce4-indicator-plugin-2.x.y (gtk3 version).

In , flg (flg) wrote :

Xubuntu version: 13.10 64 bits
Plugin version: 0.5.0-2ubuntu2
"System Load Indicator" (aka indicator-multiload) version: 0.3

The problem is that the "system load indicator" widgt has a fixed width in the indicator plugin (in the Xfce panel). Thus, increasing the number of resources or increasing the "System monitor width" config parameter leads to reducing the height of the graphs (instead of extending the width).

Seems like Xubuntu guys have not upgraded the plugin to version 1.0 in 13.10.

In 14.04 they are going straight to version 2.x, which should fix this issue as well (albeit differently).

Changed in xfce4-indicator-plugin:
importance: Unknown → Low
status: Unknown → Confirmed
flg (flg) wrote :

For the record, upgrading to 14.04 with embeds version 2.3.2-0ubuntu2 of xfce4-indictor-plugin did fox the problem. Thank you.

eolien (mrnfake) wrote :

I'm on a 14.04 64 bits port from a 12.04, with version 2.3.2-0ubuntu2, and i have the same bug :

here a screenshot :
http://img4.hostingpics.net/pics/363623Capturedcran30042014133452.png

don't know what to do

Have a nice day

eolien (mrnfake) wrote :

am i right to say that this is the same bug ?
how to fix that, this is really handicapping

Tested with indicator-multiload and did not encounter the bug.

Xubuntu 18.04

Changed in xfce4-indicator-plugin (Ubuntu):
status: Triaged → Fix Released

Correction: indicator-multiload is displayed by the "Status Notifier Plugin" instead now.

The "Indicator Plugin" is still not able to render the indicator properly.

Simon Quigley (tsimonq2) on 2018-08-19
Changed in xfce4-indicator-plugin (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.