X crashes after a few minutes or seconds (Jaunty)

Bug #368135 reported by floyd0815 on 2009-04-27
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xf86-input-evtouch (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Nicholas Christian Langkjær Ipsen
Declined for Lucid by Bryce Harrington

Bug Description

My X server crashes (without reports in the log) after few time when I use my touchscreen.
When I use my touchpad it doesn't. (first I thought it was a xorg-intel problem)
Then I have to restart X via <alt>+<print>+<K>.

In Hardy, my touchscreen worked perfect (eGalax-driver), and in Jaunty it does too, except the freezes.
And the eGalax driver doesn't find a usb-controller, so I cann't use it either.

Description: Ubuntu 9.04
Release: 9.04

xserver-xorg-input-evtouch:
  Installiert: 0.8.8-0ubuntu3
  Kandidat: 0.8.8-0ubuntu3
  Versions-Tabelle:
 *** 0.8.8-0ubuntu3 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Hardware:
Acer Aspire One ZG5 modded with eGalax Touchscreen (Hoda - eBay)
1.5 GB Ram
(happens with normal and Sickboy's kernel)

Thanks in advance!
Floyd

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-input-evtouch 0.8.8-0ubuntu3
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.29.1.20090414.sickboy (root@Desktop) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP PREEMPT Tue Apr 14 22:08:40 EST 2009
SourcePackage: xf86-input-evtouch
Tags: ubuntu-unr
Uname: Linux 2.6.29.1.20090414.sickboy i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
     Subsystem: Acer Incorporated [ALI] Device [1025:015b]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
     Subsystem: Acer Incorporated [ALI] Device [1025:015b]

floyd0815 (floriankre) wrote :
Bryce Harrington (bryce) on 2009-04-28
tags: added: crash
Changed in xf86-input-evtouch (Ubuntu):
status: New → Confirmed
floyd0815 (floriankre) wrote :

EDIT:
When I use my touchpad, then the touchscreen for 2-3 clicks, then touchpad, then touchscreenfor 2-3..., and so on --> all is good.

But when I use only my touchscreen --> X crashes after a few hits.

I recognized, that when I use the touchpad and after the touchscreen --> X crashes later as when I use first (and only) the touchscreen.

Maybe this helps.

Sorry for the duplicated bug, but firefox hasn't reacted at the first button press so I pressed it a second time.

Also sorry for my poor English.

Floyd

Uwe L. Korn (uwelk) wrote :

As this problem occurs with the eGalax driver too, I think this is maybe related to another point of the system, could there be a problem with the usbhid kernel module?

Uwe L. Korn (uwelk) wrote :

Just saw that that even when I am forcing X to use the eGalax driver, evtouch is preferred and now everything works fine.
Info: I'm using a beta driver I received by an EETI employee, just mail them and they will sent it to you.

floyd0815 (floriankre) wrote :

It seems to be solved!
I used my touchscreen for a while and there are no freezes anymore.
(normally there would be 10 freezes in that time))

Don't know which package did it, but I installed:

xserver-xorg-core-dbg (2:1.6.0-0ubuntu14)
xserver-xorg-input-tslib (0.0.5-1ubuntu2)

and the freezes are gone.

I also activated the ath5k again, and I haven't recognized disconnections so far.
(also not in the WPA-supplicant log)

2 flies with one hit!

Hopefully it is really solved!

Floyd

floyd0815 (floriankre) wrote :

F***!

The freezes are still there!
The first one came really late, but now they come quickly like before.

@ Uwe L. Korn
Can you post the eGalax beta-driver?
I don't get an answer from EETI!

Thanks.

Floyd

Bryce Harrington (bryce) on 2009-05-06
description: updated
Ramaddan (ramaddan) wrote :

Have the same problem here, and many others reported a similar problem and a lot of them seem to use eGalax touchscreens that use the xserver-xorg-input-evtouch driver.

This problem came up for me in Jaunty and still ongoing in Karmic.

I have also experienced freezes in Jaunty using evtouch - system locks up completely and I have to do a hard poweroff. This is with the same exact xorg.conf that worked in Hardy without any problems. Still got freezes after removing xorg.conf and creating fdi for touch screen.

Now running with sendCoreEvents off, and so far so good. Will post back with experiences.

No crashes today. I still have sendcoreevents set to false, and additionally I changed CPU frequency scaling threshold from 95 to 40, so CPU speed is increased more aggressively. In a day or two, if no crashes, will try setting core events back on and see if freezing occurs again. Now I also have SSH server installed so I can check whether the rest of the system remains functional.

chefpro (chefpro) wrote :

How have you switched off core events ?
Is it still hang ?
I have the same Problem.

I have turned core events back on, and no crashes. I'm not sure which change is the key unfortunately.

Is your touch screen configured by xorg.conf or a HAL fdi file? I have also taken an fdi file into use, which could affect this issue.

chefpro (chefpro) wrote :

I only use the ubuntu way, whitch means I have modified the file /etc/evtouch/config.

chefpro (chefpro) wrote :

So, how did you ?
Maybe, you can send me your xorg.conf and fdi file please ?

my xorg.conf is practically empty:

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 SubSection "Display"
  Virtual 1024 1368
 EndSubSection
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

--end of xorg.conf

but to get touch screen to work I had to manually create this file:
/etc/hal/fdi/policy/gunzetouch.fdi:

<?xml version="1.0" encoding="ISO-8859-1" ?>
<deviceinfo version="0.2">
<device>
  <match key="info.product" contains="GUNZE USB Touch Panel">
 <merge key="input.x11_driver" type="string">evtouch</merge>
 <merge key="input.x11_options.ReportingMode" type="string">Raw</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">false</merge>
 <merge key="input.x11_options.Emulate3Timeout" type="string">1</merge>
 <merge key="input.x11_options.SendCoreEvents" type="string">On</merge>
 <merge key="input.x11_options.MinX" type="string">35</merge>
 <merge key="input.x11_options.MinY" type="string">37</merge>
 <merge key="input.x11_options.MaxX" type="string">990</merge>
 <merge key="input.x11_options.MaxY" type="string">986</merge>
  </match>
</device>
</deviceinfo>

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Bryce Harrington (bryce) wrote :

Thanks. The SendCoreEvents crash bug sounds like one we now have a patch for in the xserver, so forcing SendCoreEvents on should not be necessary.

I've also added your fdi into the package (except the now unnecessary SendCoreEvents).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xf86-input-evtouch - 0.8.8-0ubuntu5

---------------
xf86-input-evtouch (0.8.8-0ubuntu5) karmic; urgency=low

  * control: Add dependencies for ttf-freefont and x-ttcidfont-conf.
    These dependencies are required by one of the earlier patches.
    (LP: #299178)
  * Add debian/fdi/50-elo-2700.fdi to support EloTouch 2700 IntelliTouch
    Touchmonitor Interface.
    (LP: #362308)
  * Add debian/fdi/50-gunze.fdi to support GUNZE USB Touch Panel
    (LP: #368135)

 -- Bryce Harrington <email address hidden> Wed, 14 Oct 2009 02:10:14 -0700

Changed in xf86-input-evtouch (Ubuntu):
status: Confirmed → Fix Released
Eli Spizzichino (scrivi-gmail) wrote :

using 0.8.8-0ubuntu6.1 with the eGalax touchscreen another fdi is needed:

<?xml version="1.0" encoding="ISO-8859-1" ?>
<deviceinfo version="0.2">
<device>
<match key="info.product" contains="eGalax Inc. USB TouchController">
 <merge key="input.x11_driver" type="string">evtouch</merge>
 <merge key="input.x11_options.ReportingMode" type="string">Raw</merge>
 <merge key="input.x11_options.Emulate3Buttons" type="string">false</merge>
 <merge key="input.x11_options.Emulate3Timeout" type="string">1</merge>
 <merge key="input.x11_options.SendCoreEvents" type="string">On</merge>
 <merge key="input.x11_options.MinX" type="string">0</merge>
 <merge key="input.x11_options.MinY" type="string">2</merge>
 <merge key="input.x11_options.MaxX" type="string">4096</merge>
 <merge key="input.x11_options.MaxY" type="string">4096</merge>
</match>
</device>
</deviceinfo>

using this fdi actually solves the stability issue but it's still slow in reacting to input and the calibration goes away when rotating.
I found the solution here http://swiss.ubuntuforums.org/showthread.php?t=1275975

Changed in xf86-input-evtouch (Ubuntu):
status: Fix Released → In Progress

Also affects Karmic, Lucid(Alpha2).

Kevin Brewster (kbrewster) wrote :

There's an extra </deviceinfo> at the bottom of /usr/share/hal/fdi/policy/20thirdparty/50-elo-2700.fdi

This causes a parsing error and hal won't read the fdi..
just remove to fix..

xn242424 (xn242424) wrote :

Eli's last fdi fixed it for me. However the calibration points are quite different on mine. They shouldn't be in this file, as this overrides the calibration generated by the GUI tool. I commented mine out and have not had problems since.

Florian (engineer-sauter) wrote :

I have a very similar problem with a 3M Microtouch EX-II touchpanel. It works with the evtouch-driver (Ubuntu 9.10), but after a short period of time (especially if many clicks are produced) the system freezes. I am using the following (custom) fdi-file in /usr/share/hal/fdi/policy/20thirdparty/ :
---
<?xml version="1.0" encoding="ISO-8859-1" ?>
<deviceinfo version="0.2">
  <device>
    <match key="info.product" contains="3M 3M USB Touchscreen - EX II">
      <merge key="input.x11_driver" type="string">evtouch</merge>
      <merge key="input.x11_options.ReportingMode" type="string">Raw</merge>
      <merge key="input.x11_options.Emulate3Buttons" type="string">false</merge>
      <merge key="input.x11_options.Emulate3Timeout" type="string">1</merge>
      <merge key="input.x11_options.MinX" type="string">2500</merge>
      <merge key="input.x11_options.MinY" type="string">2500</merge>
      <merge key="input.x11_options.MaxX" type="string">13500</merge>
      <merge key="input.x11_options.MaxY" type="string">13500</merge>
      <merge key="inpux.x11_options.SendCoreEvents" type="string">On</merge>
      <merge key="input.x11_options.SwapX" type="string">1</merge>
    </match>
  </device>
</deviceinfo>
---

Unfortunately the touchpanel does not work when SendCoreEvents is turned off.

Bryce Harrington (bryce) wrote :

With Lucid we no longer use fdi files, so if the bug still exists there it must be due to something different. Also, with lucid we are starting to look more to -evdev than -evtouch for touchpad support, so the issue is not one we have much interest in. If you still want to have it explored with the evtouch driver I would recommend going directly upstream with this issue.

Changed in xf86-input-evtouch (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers