evtouch frequently crashes the system when using the touchscreen

Bug #432980 reported by Nicholas Christian Langkjær Ipsen on 2009-09-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
Undecided
Unassigned
xf86-input-evtouch (Ubuntu)
Undecided
Unassigned

Bug Description

After installing evtouch to get the touchscreen working on my Gigabyte T1028, the system has started to crash when I'm using the touchscreen, forcing me to do a hard-shutdown. SysRq + REISUB doesn't work. Often, this also results in evtouch losing my touchscreen calibration settings, making this a quite annoying bug.

This happens on Ubuntu Netbook Remix 9.10, as well as 10.04 testing with the latest updates installed.

evTouch version: 0.8.8-0ubuntu6

seph@seph-netbook:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu lucid (development branch)"

description: updated
Paul Larson (pwlars) wrote :

netbook-remix is not a valid target for bugs, so I'm moving this to Ubuntu distribution

Changed in netbook-remix:
status: New → Invalid
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) wrote :

Not enough information has been provided to troubleshoot this bug. It is generally required to provide a full backtrace for crash bugs.

Offhand, this sounds a lot like bug #368135. You could try turning on SendCoreEvents as described in that bug report to confirm this. If so, this should be fixed with the new xserver we'll be shipping in Karmic. If not, feel free to reopen but please provide a full backtrace. Your Xorg.0.log would be helpful too.

Changed in xf86-input-evtouch (Ubuntu):
status: New → Invalid

Still happening with a fresh install of Karmic. How do I do a backtrace on this bug?

Changed in netbook-remix:
status: Invalid → Confirmed
Changed in xf86-input-evtouch (Ubuntu):
status: Invalid → Confirmed
Changed in netbook-remix:
status: Confirmed → Invalid
tags: added: lucid
description: updated
description: updated
Eli Spizzichino (scrivi-gmail) wrote :

as described here
http://swiss.ubuntuforums.org/showthread.php?t=1275975
using that fdi actually solves the stability issue but it's still slow in reacting to input and the calibration goes away when rotating.
I was unable to produce a stacktrace because it's not a crash but it freeze and I can't find and valuable log... let me know if I can help further

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers