update-alternatives: error: alternative path /usr/bin/xemacs21 doesn't exist.

Bug #467446 reported by bostongeek24 on 2009-10-31
320
This bug affects 74 people
Affects Status Importance Assigned to Milestone
xemacs21 (Debian)
Fix Released
Unknown
xemacs21 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xemacs21

will not install for me.

ProblemType: Package
Architecture: i386
Date: Sat Oct 31 17:02:53 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
Package: xemacs21 21.4.22-2ubuntu1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: xemacs21
Tags: ubuntu-unr
Title: package xemacs21 21.4.22-2ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
Uname: Linux 2.6.31-14-generic i686

Related branches

bostongeek24 (markdymek) wrote :
era (era) wrote :

Confirming from duplicates. The error message is from DpkgTerminalLog.txt

summary: - package xemacs21 21.4.22-2ubuntu1 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 2
+ update-alternatives: error: alternative path /usr/bin/xemacs21 doesn't
+ exist.
Changed in xemacs21 (Ubuntu):
status: New → Confirmed
Changed in xemacs21 (Debian):
status: Unknown → New
Changed in xemacs21 (Debian):
status: New → Fix Committed
Changed in xemacs21 (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xemacs21 - 21.4.22-3ubuntu1

---------------
xemacs21 (21.4.22-3ubuntu1) maverick; urgency=low

  * Merge from debian unstable. Remaining changes: (LP: #467446) (LP: #583224)
    - debian/patches/21_fix_maximation_bug.dpatch:
      + Fix maximation issue, where xemacs21 meant to stay in an infinite loop
 -- Stephan Hermann <email address hidden> Thu, 27 May 2010 11:09:38 +0000

Changed in xemacs21 (Ubuntu):
status: Confirmed → Fix Released
Adam Seering (aseering) wrote :

xemacs21 from Maverick (21.4.22-3ubuntu1) does not fix this bug for me; I assume that's because this ticket is listed as a "Remaining Change" above? Should the status of this bug actually be "Fix Released"?

era (era) wrote :

If the release doesn't fix this then no, the status should be New or Confirmed. If someone else can confirm that this is still an issue in Maverick, please feel free to update the status. I'm setting it to New based on comment #4.

@Adam Seering: The "remaining changes" refers to what changes Ubuntu has made to the package compared to Debian, and they are "remaining" because often an update means a patch which was previously specific to Ubuntu has been accepted upstream and can be removed from Ubuntu. There is a drive to minimize the Ubuntu-specific patches; ideally, if there are none, the Debian package can simply be synced to Ubuntu whenever Debian releases a new version.

Changed in xemacs21 (Ubuntu):
status: Fix Released → New
era (era) wrote :

I was unable to reproduce this on a Maverick Live CD as of 2010-08-24; I installed xemacs21 (which pulled in emacsen-common libcompfaceg1 xemacs21-basesupport xemacs21-bin xemacs21-mule xemacs21-mulesupport xemacs21-support) version 21.4.22-3.1ubuntu1 just fine.

@Adam Seering: are you still seeing this? Were you upgrading from an earlier version or something?

I am setting the Status of this bug report to Incomplete to signal that work is pending on your input. Please feel free to change the bug report's status back to New once you have supplied the requested information. Thank you.

Changed in xemacs21 (Ubuntu):
status: New → Incomplete
era (era) wrote :

In fact I am unable to figure out how to reproduce this. I have tried to reproduce on Karmic, Jaunty, Hardy, and when upgrading each of these to Lucid. The fact is that people are still reporting this problem on Lucid systems, so the fix appears not to work, but it would definitely help if somebody could provide repro steps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.