Ubuntu

Apport should not present the user with non-actionable information

Reported by Tomas Lycken on 2012-05-28
186
This bug affects 44 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
xdiagnose
Undecided
Unassigned
xdiagnose (Ubuntu)
Undecided
Unassigned

Bug Description

What is expected to happen?
When the dialog is shown, the user is taken through the steps to report a bug in Launchpad. If the error is too minor for the dev team to want to see a bug report every time it occurrs, no dialog is shown.

What actually happens?
Apport frequently states that an internal error has occurred, but presents the user with no path of action (except asking a question at askubuntu.com).

Please also see this thread at askubuntu.com for further input: http://askubuntu.com/questions/141671/keep-getting-messages-about-internal-system-errors

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: apport 2.0.1-0ubuntu7
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CrashReports:
 640:1000:114:37346020:2012-05-28 16:41:15.035427000 +0200:2012-05-28 16:41:17.051427847 +0200:/var/crash/_usr_share_spotify_spotify.1000.crash
 600:0:114:2822675:2012-05-28 00:34:13.847883112 +0200:2012-05-28 00:34:13.731883110 +0200:/var/crash/xserver-xorg-video-intel.2012-05-28_00:34:13.734115.crash
 600:0:114:2822675:2012-05-28 00:34:14.883883142 +0200:2012-05-28 00:34:14.767883137 +0200:/var/crash/xserver-xorg-video-intel.2012-05-28_00:34:14.770546.crash
 600:105:114:0:2012-05-28 17:20:11.889550579 +0200:2012-05-28 16:41:18.343427820 +0200:/var/crash/_usr_share_spotify_spotify.1000.uploaded
 664:1000:114:0:2012-05-28 16:41:16.787427853 +0200:2012-05-28 16:41:16.787427853 +0200:/var/crash/_usr_share_spotify_spotify.1000.upload
Date: Mon May 28 17:23:26 2012
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tomas Lycken (tlycken) wrote :
Tomas Lycken (tlycken) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Sep Thijssen (thijssensep) wrote :

I am affected by this as well. When clicking the "Show Details" button in the error message, I get to see:

ExecutablePath
/usr/share/apport/apport-gpu-error-intel.py

If this is the same for you, than this bug is perhaps a duplicate of
https://bugs.launchpad.net/ubuntu/+source/xdiagnose/+bug/997470

Menno (mlabakker) wrote :

I don't know if this is related and should be reported here, but on my system apport tels me:

"You are not allowed to access this problem report."
on a dialogbox with title "Invalid problem report - Apport KDE"

This is running as user, Kubuntu 12.04 64 bit with all updates installed as of 2012-09-11.
(This includes an update to apport todat that I had hoped would fix this)

TheOldFellow (theoldfellow) wrote :

The duplicate status is wrong.
bug #997470 is about a bug in apport-gpu-error-intel.py
this bug is about a reporting strategy which is inappropriate for any fault in a stable LTS release.

Shauna Gordon (shauna) wrote :

@Sep Thijssen - This is not regarding a particular crash, but the fact that Apport will prompt a user to report *any* fault, and then the reporting process will fail because the reporting service has been turned off.

I've seen this personally with anything from bundled applications to OS-level scripts (including Compiz, and Unity itself).

Bryce Harrington (bryce) on 2013-01-20
affects: apport (Ubuntu) → xdiagnose (Ubuntu)
bugbot (bugbot) on 2013-01-24
tags: added: kubuntu
Incze GASPAR (inczegaspar) wrote :

This is very annoying to end users! Just like Windows crash reports, totally useless.
Let's make all this transparent and automatic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 3.4.3

---------------
xdiagnose (3.4.3) raring; urgency=low

  [ Bryce Harrington ]
  * apport/source_xorg.py:
    + Fix assertion in apport when assigning a None value for the
      xserver.configfile parameter. This may not be defined if there is no
      xorg.conf (a common situation).
    + Fix HookError when specifying a gpu hang is 'infrequent'
    + Drop the post-release dialog recommending technical support
      (LP: #1080233, #1005573)
    + Add capturing of gsettings options for unredirected fullscreen windows
  * debian/xdiagnose.links:
    + Add lts-quantal X.org packages

  [ Michael Terry ]
  * Switch from gksu to pkexec
    (LP: #421660)
 -- Bryce Harrington <email address hidden> Wed, 13 Feb 2013 18:38:28 -0800

Changed in xdiagnose (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2013-09-23
Changed in xdiagnose:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers