[SRU] Light Locker blanks the screen when playing video

Bug #1309744 reported by Juan Montoya on 2014-04-18
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xdg-utils (Ubuntu)
Undecided
Unassigned
Trusty
Medium
Unit 193

Bug Description

Problem description
---

Expected behaviour:
When playing back videos in fullscreen mode in Xubuntu's, the X11 screensaver should be inhibited. (Xubuntu previously used XScreensaver.)

Behaviour:
The screensaver blanks the screen (after the timeout that the user defined in light-locker-settings, by default 10mins) despite the video playing in fullscreen.

[Test Case]
Play back a video file in Parole with screenblanking enabled (can be checked with "xset q | grep timeout").

[Regression potential]
None apparent, tested in Trusty.

[Other Info]
A little background: this problem became apparent only in Trusty with the switch from XScreensaver to light-locker. As light-locker doesn't handle screenblanking itself but instead relies on X11's builtin screensaver (aka MIT screensaver extension), it needs xdg-utils/screensaver's support for inhibiting the blanking. For some reason, xdg-screensaver doesn't support controlling X11's screensaver extension in Xfce, probably for historical reasons (e.g. most distros with Xfce use XScreensaver).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: vlc 2.1.2-2build2
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 18 15:41:48 2014
InstallationDate: Installed on 2014-03-31 (18 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
SourcePackage: vlc
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Juan Montoya (th3pr0ph3t) wrote :
affects: vlc (Ubuntu) → ubuntu
affects: ubuntu → light-locker (Ubuntu)
Peter de Ridder (cavalier) wrote :

If "lock after screensaver" is enabled for light-locker the screen is locked after build-in X screensaver is activated.
The getting blanked is screensaver kicking in. That probably means that the build-in X screensaver isn't inhibitted.

This would mean that the same blanking happend even is light-locker is not used.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-locker (Ubuntu):
status: New → Confirmed
Changed in light-locker (Ubuntu):
status: Confirmed → Invalid
hadrons123 (piruthiviraj) wrote :

@ simon
Why is it Invalid?

Simon Steinbeiß (ochosi) wrote :

@hadrons123: It is invalid against light-locker (as explained by Peter in #2) and valid against Parole.

hadrons123 (piruthiviraj) wrote :

Thanks for the answer. But I am not able to remove the built in x screensaver. I tried removing the xscreensaver but it was not installed in the first place. How to get rid of the built in x screensaver?

Simon Steinbeiß (ochosi) wrote :

This isn't really a support-thread, so please don't keep asking questions here.
In any case, you can use light-locker-settings to disable the timeout so there'll be no screen-blanking.

costales (costales) wrote :

@Simon: Awesome solution! ¬¬ FYI: The max time for disable the screensaver is 120', a movie can get that time.
Please, disable/Enable the screensaver isn't an option!

I think this could be a duplicate of #1193716

I can reproduce this with Totem & VLC.

Best regards.

Simon Steinbeiß (ochosi) wrote :

@costales: If you pull the respective slider in light-locker-settings to the very left, it disables the screensaver (the label says "Never").

claw (cl-111) wrote :

I upgraded Xubuntu from 12.04 LTS to 14.04 LTS and I removed xscreensaver based on the post-upgrade recommendation.

However, what I found was that the screen blanked while parole was playing a video. Here is what is happening:

Parole executes xdg-screensaver to inhibit the screen saver while video is being played and resume normal screen saver operations when the video has either stopped or is paused.

xdg-screensaver is a shell script which detects which screen saver is installed and then proceeds to perform the requested operation on the screen saver detected - note here, that light-locker is not supported, but xscreensaver is supported.

When no known screen saver is detected, xdg-screensaver defaults to manipulating xset. Light locker is not inhibited and its own timer will expire, thereby blanking the screen.

A cursor look at light-locker-command indicates that it supports immediately locking the screen only. i.e.: There is no way for xdg-screensaver to inhibit the light locker timer using light-locker-command.

So this issue is still VERY much valid for the light-locker package and its status ought to be changed from invalid. The developers for light-locker will need to work closely with the developers of xdg-utils to get this issue resolved.

For those of you interested in a work-around: Re-install xscreensaver and let light-locker pick up the dbus messages sent from the screen saver. Alternatively, uninstall light-locker and go back to xscreensaver.

IMHO, light-locker is immature and should not have been introduced into a LTS release, but its heading into a promising direction.

Simon Steinbeiß (ochosi) wrote :

@claw: light-locker doesn't have any timer of its own, it listens to X11's screensaver extension, so in a way what is happening is happening as planned. We have a working patch for Parole for that, so this issue will hopefully be resolved soon.

hawkerb (hawk) wrote :

@ochosi
Great to hear you got a patch ready. But I am also experiencing same issue with VLC 2.1.2 on pretty much clean install of xubuntu 14.04, so maybe the problem is not only in Parole?

Rodion (dulicek) wrote :

Got the same problem (VLC, Parole) on clean install of Xubuntu 14.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
affects: xfce4-power-manager → xdg-utils (Ubuntu)

Could anyone affected by this please run the terminal command "xset -q" while a movie is playing and attach the output to this report?

Thanks.

Simon Steinbeiß (ochosi) wrote :

Just to give you guys an update, I suspect that the xdg-screensaver script is actually the source of the problem. This is a common way for media players to interact with screensavers, as there is on default/standard that all screensavers stick to.
For that I haven't found a cure yet.

Fixing this issue solely in Parole isn't enough and actually not a desirable solution.

Simon Steinbeiß (ochosi) wrote :

Ok, so I think I've figured this one out.

The problem is that the /usr/bin/xdg-screensaver script does detect the desktop-environment (in our case: "xfce"), but when checking for it in "perform_action" there's actually no case that matches xfce, so it never does anything if it detects xfce.
This was previously not noted because we used xscreensaver, which has a special case built in.

There is one easy workaround: replace the '' in line 435 with 'xfce' and it should work.

The desired patch is probably adding a special case for light-locker just as there's one for xscreensaver and gnome-screensaver, cause it could also be used in other DEs.

However, there is one big caveat: the script in its current form always sets the screensaver timeout to the system default value of "600" (i.e. 10minutes). So the feature of remembering the timeout and re-setting it correctly on "resume" would have to be added in a second step.

no longer affects: parole
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1309744

tags: added: package-qa-testing
description: updated
summary: - Light Locker blanks the screen when playing video
+ [SRU] Light Locker blanks the screen when playing video
Jackson Doak (noskcaj) on 2014-07-16
Changed in xdg-utils (Ubuntu):
status: Confirmed → Triaged
Unit 193 (unit193) wrote :
Unit 193 (unit193) wrote :

Attaching a debdiff for Trusty

Jackson Doak (noskcaj) on 2014-07-16
no longer affects: light-locker (Ubuntu)
Brian Murray (brian-murray) wrote :

The Launchpad bug number was not referenced in the changelog entry for the utopic upload fixing this, so I am manually setting it to Fix Released.

xdg-utils (1.1.0~rc1-2ubuntu8) utopic; urgency=medium

  * Add patch xfce-blanking.diff to prevent screenblanking in Xfce when
    XScreensaver isn't installed/used
 -- Simon Steinbeiss <email address hidden> Wed, 16 Jul 2014 11:19:43 +0200

Changed in xdg-utils (Ubuntu):
status: Triaged → Fix Released
Changed in xdg-utils (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Iain Lane (laney) wrote :

Uploaded to t-proposed

Changed in xdg-utils (Ubuntu Trusty):
status: Triaged → In Progress
assignee: nobody → Unit 193 (unit193)

Hello Th3Pr0ph3t, or anyone else affected,

Accepted xdg-utils into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xdg-utils/1.1.0~rc1-2ubuntu7.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xdg-utils (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Jack Fromm (jjfrv8) wrote :

Verified fix.
- Did a fresh install of Trusty on hardware and confirmed I could reproduce the bug.
- Enabled -proposed, updated, verified I got xdg-utils 1.1.0~rc1_2ubuntu7.1 and re-ran testcase.
- Did not get the screen blanking during fullscreen video playback in Parole.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-utils - 1.1.0~rc1-2ubuntu7.1

---------------
xdg-utils (1.1.0~rc1-2ubuntu7.1) trusty; urgency=medium

  * Add patch xfce-blanking.diff to prevent screenblanking in Xfce when
    XScreensaver isn't installed/used. (LP: #1309744)
 -- Unit 193 <email address hidden> Wed, 16 Jul 2014 17:49:42 -0400

Changed in xdg-utils (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xdg-utils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Sergio Benjamim (sergio-br2) wrote :

The fix worked here, tested with retroarch.

John Hupp (john.hupp) wrote :

With a fully patched Lubuntu Trusty, streaming Flash video through Firefox results in the screen blanking and locking after 10 minutes.

I have the recommended/most-recent version of xdg-utils.

Does this mean that media players in general use xdg-screensaver to inhibit the screensaver while playing video, but that Firefox does not?

If so, is there a workaround?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers