X-chat disconnects when connecting to ZNC bouncer

Bug #530771 reported by kungfutse on 2010-03-02
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xchat (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xchat

When attempting to connect to a ZNC bouncer with X-chat the connection is closed almost immediately with an error "Remote host closed socket". Only the MOTD is shown and channels are autojoined.

I've tried tweaking the ZNC buffer size and disabling it altogether, but that doesn't seem to have any effect.

Same bouncer works without problems if using f.ex pidgin with it's IRC plugin and it worked in karmic koala (9.04) with x-chat. Also Silverex windows build of X-chat works with the bouncer.

Connecting to IRC server normally works as expected.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 2 17:53:50 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/xchat
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: xchat 2.8.6-4ubuntu4
ProcEnviron:
 LANGUAGE=en_US.utf8
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: xchat
Uname: Linux 2.6.32-14-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:6146): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-power-manager:6144): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
 (gnome-terminal:6227): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (firefox-bin:8164): Gdk-WARNING **: XID collision, trouble ahead

kungfutse (kungfutse) wrote :
kungfutse (kungfutse) on 2010-03-02
tags: added: xchat znc
description: updated
description: updated
Lorenzo De Liso (blackz) wrote :

Hello,
thanks for making ubuntu better.
You can check if you use some options doesn't supported by your znc server, e.g: SSL;
are you sure that aren't you using these?

Regards,

Lorenzo D. (alias BlackZ).

kungfutse (kungfutse) wrote :

Hi,

The xchat config first used was the one used succesfully in karmic, as I updated . SSL was disabled as it should be. I tried removing the entire~/.xchat2 directory and setup the server connection from scratch but it didn't make any difference.

Xchat connects to the bouncer fine, receives the MOTD and auto joins channels and outputs the line buffers and then immediately disconnects.

Lorenzo De Liso (blackz) wrote :

Can you run xchat via terminal then paste the eventually output here?

Thanks,

Regards,

Lorenzo D. (alias BlackZ).

kungfutse (kungfutse) wrote :

Unfortunately running xchat in terminal doesn't produce any errors (or any output at all). I tried running it through gdb but as it doesn't crash, just disconnects, that wasn't really helpful.

It produces one with ssl option enabled. "SSL_read/read: Connection reset by peer"

I've been using znc+xchat combination for years now, with many ubuntu versions and windows etc...
Upgrading to 10.04 made it impossible and I'm totally suffering with xchat-gnome what works :(..

I've been on impression the bug is related to ssl but seems like it isn't if kungfutse doesn't use ssl.
I've actually got thru couple times, but at least 99/100 times it doesn't work.

With same configs, everything works flawlessly with 9.10 32 & 64bit but not with 10.04 64bit (haven't tried 32bit).

This is sad since xchat is one of my most important tools of job.

Solved for me. The bug is probably with the xchat version. Install new version and enjoy the life. Here's instructions for the newest 2.8.8: http://theubuntunews.blogspot.com/2010/06/install-or-update-xchat-288-on-ubuntu.html

kungfutse (kungfutse) wrote :

The 2.8.8 update above fixed the issue for Lucid Lynx.

I yesterday upgraded to Maverick beta, and the xchat got replaced with the version that ships with it, and the problem is back.

tags: added: maverick
Guido Nickels (gsn) wrote :

Hi!

The problem is the 51_freenode_ircd-seven.patch included in the ubuntu package of xchat. Remove the patch, rebuild xchat, and everything works fine again.

Hopefully someone with more c knowledge than me can provide a fix for this.

Regards,

Guido

Any news on this? Has anyone made recompiled deb? I need to either fall back to old ubuntu or get recompiled xchat.

kungfutse (kungfutse) wrote :

Still the same bug in 11.04 beta

kungfutse (kungfutse) on 2011-04-27
tags: added: narwhal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers