Please Upgrade x264 and libx264

Bug #243451 reported by nullack on 2008-06-27
22
Affects Status Importance Assigned to Milestone
x264 (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: x264

Im currently on the Intrepid repo, but I do believe that along with Intrepid, Hardy also has an old revision of x264 and libx264.

As of 27/06/08, the current version of x264 is r890 whereas Intrepid has somewhere around r815 i.e. about 75 versions ago. x264 has not had a release per se, but the development versions are largely stable and I have been personally using my own compile of r890 for some days now. There is many problems that have been fixed since the 75 versions have past.

I recommend these should be backported wherever possible as I see no risk to doing so.

Related branches

Dean Loros (autocrosser) wrote :

Confirmed

No reason why these should be at the versions they are---Please update or backport.

Debian multimedia, where the current packages are merged from has 1:0.svn20080712-0.1

Dean Loros (autocrosser) on 2008-09-26
Changed in x264:
status: New → Confirmed
nullack (nullack) on 2008-10-09
Changed in x264:
importance: Undecided → Wishlist
John Dong (jdong) wrote :

Too late for this release cycle; libx264 has VLC and ffmpeg reverse dependencies that I don't feel like risking at any point other than the beginning of the release cycle. I made an upload to VLC at the beginning of Intrepid for that particular reason.

John Dong (jdong) wrote :

Will do this over the weekend for Jaunty. This time, I definitely plan on doing this again right before Feature Freeze too so we don't run into the same situation. Sorry about that.

Changed in x264:
assignee: nobody → jdong
importance: Wishlist → Low
Lionel Le Folgoc (mrpouit) wrote :

John: are you still working on it?

I started to merge it from Debian multimedia...
 x264 (1:0.svn20081210-0.0ubuntu1) jaunty; urgency=low
 .
   * Merge from Debian multimedia (LP: #243451), remaining Ubuntu changes:
     - b-d on yasm on lpia.

... and then launched some rebuilds (in my PPA) for reverse-build-deps:
* ffmpeg: OK
* avidemux: FTBFS
* gst-plugins-bad-multiverse0.10: FTBFS
* mpeg4ip: FTBFS
* mplayer: FTBFS
* mythtv: FTBFS
* ogmrip: OK
* vlc: N/A (waiting for a newer libass).

Build failures are mostly caused by a change in x264_param_t (b_bframe_adaptive removed and i_bframe_adaptive added).

Paul Gevers (paul-climbing) wrote :

Bug 303537 is waiting for this bug to be resolved. Any progress?

Reinhard Tartler (siretart) wrote :

well, of course the other packages need to be adapted to the changes in x264. I'm attaching a diff to the changes in the only header in libx264-dev.

I'd suggest to upload the new version from debian-multimeida ASAP and fix the resulting breakage before FeatureFreeze!

Changed in x264:
assignee: jdong → mrpouit
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x264 - 1:0.svn20081230-0.0ubuntu1

---------------
x264 (1:0.svn20081230-0.0ubuntu1) jaunty; urgency=low

  * Merge from Debian multimedia (LP: #243451), remaining Ubuntu changes:
    - b-d on yasm on lpia.

x264 (1:0.svn20081230-0.0) unstable; urgency=low

  * New git release.

x264 (1:0.svn20081210-0.0) unstable; urgency=low

  * Net git release.
  * Now yasm is the default assembler.
  * The GTK frontend is gone.

x264 (1:0.svn20080712-0.1) unstable; urgency=high

  * Seems to be a problem with the previous release (Segfault) that I'm
    unable to reproduce, so back to this version for Lenny.

x264 (0.svn20080828-0.0) unstable; urgency=low

  * New git release.

x264 (0.svn20080712-0.0) unstable; urgency=low

  * New git release.

x264 (0.svn20080616-0.0) unstable; urgency=low

  * New git release.

 -- Lionel Le Folgoc <email address hidden> Thu, 15 Jan 2009 23:15:42 +0100

Changed in x264:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments