Ubuntu

[MASTER] Karmic alpha: Checkbox cannot switch display modes in display test

Reported by Alexandros on 2009-09-11
304
This bug affects 110 people
Affects Status Importance Assigned to Milestone
Checkbox (Legacy)
Undecided
Marc Tardif
checkbox (Ubuntu)
High
Marc Tardif
x11-xserver-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x11-xserver-utils

Steps to reproduce:
1)Perform the display test of checkbox

What happens:
1)Switch display modes test does not pass

Tested using Toshiba A200 laptop.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 11 15:15:10 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090902.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: TOSHIBA Satellite A200
Package: x11-xserver-utils 7.4+2ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=el console-setup/layoutcode?=gr
ProcEnviron:
 PATH=(custom, no user)
 LANG=el_GR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
SourcePackage: x11-xserver-utils
Uname: Linux 2.6.31-9-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 04/26/2007
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V1.40
dmi.board.name: ISKAE
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV1.40:bd04/26/2007:svnTOSHIBA:pnSatelliteA200:pvrPSAE0E-04E029GE:rvnTOSHIBA:rnISKAE:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite A200
dmi.product.version: PSAE0E-04E029GE
dmi.sys.vendor: TOSHIBA
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-9-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
     Subsystem: Toshiba America Info Systems Device [1179:ff03]

Related branches

Alexandros (alexandros-t) wrote :
Bryce Harrington (bryce) on 2009-09-12
Changed in x11-xserver-utils (Ubuntu):
status: New → Confirmed
summary: - Checkbox cannot switch display modes
+ [MASTER] Karmic alpha: Checkbox cannot switch display modes in display
+ test
Louis Simard (louis-simard) wrote :

Merged 4 duplicates into this one for ease of tracking. Please provide any additional information you may have about this bug here.

Summary of occurrences of this bug, see duplicates for details:

On an ASUS EEE PC 900, i386
On a Dell Inspiron 1420, amd64
On a Acer Aspire 5536 with Radeon HD 3200, amd64
On a Dell Studio 1537, amd64

David R. Hedges (p14nd4) wrote :

Using vesa (since radeon hangs my system in karmic) on T41 (mobility radeon 7500; r100), the hardware test for switching detected modes does nothing, as far as I can tell.

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-10
description: updated
Nizar Kerkeni (nizarus) wrote :

My Bug #433347 is declared as a duplicate of this one :
Dell Dimension E521 with ATI X1300Pro, amd 64

Matej Kenda (matejken) wrote :

From Bug #437151:
Compaq Evo N1015v with ATI Radeon Mobility U1 (IGP 320M), i386

Mihai Glont (mihai-glont) wrote :

I encountered the bug on my 64 bit dell vostro 1520.

Louis Simard (louis-simard) wrote :

Merged 3 duplicates (bugs 442646, 441924, 439852) into this one for ease of tracking. Please provide any additional information you may have about this bug here.

Summary of new occurrences of this bug, see duplicates for details:

On a Micro-Star Inc. MS-6566E, i386
On an ASUS A8He, i386
On a Dell Dimension 4550, i386

Antonio Roberts (hellocatfood) wrote :

I'm getting this bug on ASUS X50SL-AP124C - Intel Core 2 Duo T5550 3072MB 320GB 15.4IN DVD Super-Multi DL WIFI webcam ATI Mobility Radeon HD 3470 with 256MB dedicated graphics

Changed in checkbox (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Michał Gołębiowski (mgol) wrote :

I got this on Dell Latitude E6500 with Intel GMA 4500MHD.

TG (jp-tomi) wrote :

Same problem with Intel 82815 graphics with Acer FP751 Monitor.
Modes are detected but monitor does not switch during testings.

Kenyon Karl (kenyon-karl) wrote :

I reported this bug as #447624, when testing Ubuntu 9.10 Beta in Live! mode on an Asus A2H (A2500H) laptop. It is still present after installing Ubuntu 9.10 RC using Wubi.exe on Windows XP partition. As otherwise reported, System testing shows a variety of Modes detected in the previous step, but can not test them out. My suspicion is that the Systems Test module is defective.

Bryce Harrington (bryce) wrote :

It appears that 'checkbox' has some sort of video test which is buggy. Whatever the problem is, it's causing a lot of stray dupe bugs to get filed against xorg.

Changed in x11-xserver-utils (Ubuntu):
status: Confirmed → Invalid
Louis Simard (louis-simard) wrote :

Merged 3 duplicates (bug #450888, bug #456998, bug #457086) into this one for ease of tracking.

This bug doesn't seem so hardware-specific (or even hardware-related in any way) now.

And letting this bug slip through into the release version of Karmic will create even *more* stray duplicate bugs. :(

Marc Tardif (cr3) wrote :

It seems this problem is partially related to bug #459606. However, Bryce has raised a valid concern that this bug report should contain additional information already known by Checkbox such as the test description. So, I will add this information in the hope future bug reports will be more relevant.

Marc Tardif (cr3) on 2009-10-26
Changed in checkbox:
status: New → Fix Committed
assignee: nobody → Marc Tardif (cr3)
Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
status: Confirmed → Fix Committed
Download full text (3.4 KiB)

Concur -- thank you kindly!

Regards,
rcs

On Mon, Oct 26, 2009 at 10:12 AM, Louis Simard <<email address hidden>
> wrote:

> Merged 3 duplicates (bug #450888, bug #456998, bug #457086) into this
> one for ease of tracking.
>
> This bug doesn't seem so hardware-specific (or even hardware-related in
> any way) now.
>
> And letting this bug slip through into the release version of Karmic
> will create even *more* stray duplicate bugs. :(
>
> --
> [MASTER] Karmic alpha: Checkbox cannot switch display modes in display test
> https://bugs.launchpad.net/bugs/427932
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Checkbox System Testing: New
> Status in “checkbox” package in Ubuntu: Confirmed
> Status in “x11-xserver-utils” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: x11-xserver-utils
>
> Steps to reproduce:
> 1)Perform the display test of checkbox
>
> What happens:
> 1)Switch display modes test does not pass
>
> Tested using Toshiba A200 laptop.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Sep 11 15:15:10 2009
> DistroRelease: Ubuntu 9.10
> LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20090902.1)
> Lsusb:
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> MachineType: TOSHIBA Satellite A200
> Package: x11-xserver-utils 7.4+2ubuntu1
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed
> boot=casper initrd=/casper/initrd.lz quiet splash --
> debian-installer/language=el console-setup/layoutcode?=gr
> ProcEnviron:
> PATH=(custom, no user)
> LANG=el_GR.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
> RelatedPackageVersions:
> xserver-xorg 1:7.4+3ubuntu5
> libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
> libdrm2 2.4.12+git20090801.45078630-0ubuntu1
> xserver-xorg-video-intel 2:2.8.1-1ubuntu1
> xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
> SourcePackage: x11-xserver-utils
> Uname: Linux 2.6.31-9-generic i686
> XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
> dmi.bios.date: 04/26/2007
> dmi.bios.vendor: TOSHIBA
> dmi.bios.version: V1.40
> dmi.board.name: ISKAE
> dmi.board.vendor: TOSHIBA
> dmi.board.version: 1.00
> dmi.chassis.asset.tag: *
> dmi.chassis.type: 10
> dmi.chassis.vendor: TOSHIBA
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnTOSHIBA:bvrV1.40:bd04/26/2007:svnTOSHIBA:pnSatelliteA200:pvrPSAE0E-04E029GE:rvnTOSHIBA:rnISKAE:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
> dmi.product.name: Satellite A200
> dmi.product.version: PSAE0E-04E029GE
> dmi.sys.vendor: TOSHIBA
> fglrx: Not loaded
> system:
> distro: Ubuntu
> architecture: i686kernel: 2.6.31-9-generic
>
> [lspci]
> 00:02.0 VGA compatible controller [0300]: Intel Corpor...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.8.5

---------------
checkbox (0.8.5) karmic; urgency=low

  * Fixed translation of suites and tests files (LP: #456115)
  * Fixed checking the status of command registries (LP: #457502)
  * Fixed selecting suites in the command line (LP: #457559)
  * Fixed reporting of bugs to contain test description (LP: #427932)
  * Fixed execute permissions on scripts (LP: #459606)
  * Renamed processors_info plugin to singular because processor
    information is reported as a single structure with a count attribute
  * Updated translation files.

 -- Marc Tardif <email address hidden> Mon, 26 Oct 2009 12:17:30 -0400

Changed in checkbox (Ubuntu):
status: Fix Committed → Fix Released
Kenyon Karl (kenyon-karl) wrote :

I tested this bug again for Ubuntu 9.10 Final Release that I reported as Bug #447624 on my Asus A2H (A2500H). When run Live mode, the test performed by Systems Test worked very nicely.

But after installation on my Windows XP SP3 partition using Wubi.exe, System Test mode tested the primary video mode, but failed to cycle through all the others as it did in Live mode. Is this an artifact of the Wubi created environment or the Windows partition? Is it just a problem with Systems testing (checkbox) program?

Note that my usage of the primary video mode in subsequent testing was not affected!

Marc Tardif (cr3) on 2009-10-30
Changed in checkbox:
status: Fix Committed → Fix Released
To post a comment you must log in.