WxWidgets apps don't have menus

Bug #662077 reported by yurik81
396
This bug affects 131 people
Affects Status Importance Assigned to Milestone
DBus Menu
Invalid
High
Unassigned
myrulib
Undecided
Unassigned
wxWidgets
New
Unknown
Baltix
Undecided
Unassigned
wxwidgets2.6 (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Quantal
Undecided
Unassigned
wxwidgets2.8 (Ubuntu)
High
Md Nuhin Nabi
Maverick
Undecided
Unassigned
Natty
High
Unassigned
Quantal
Undecided
Benjamin Drung

Bug Description

List of affected applications:
Audacity
codeblocks
FileZilla
pcsx2
poEdit
wxformbuilder
boinc-manager
truecrypt
drpython
opendict
wammu

[Test Case]
How to reproduce: Install but don't activate global menu applet (app menu). Then run any WxWidgets app. Note that app doesn't has menu.

[Regression Potential]
The fix will reintroduce bug #996407, which only affects Audacity and is less important than this bug.

Ubuntu 10.10

Workaround:
export UBUNTU_MENUPROXY=0

yurik81 (yurik81)
description: updated
Revision history for this message
Omer Akram (om26er) wrote :

are you sure Multiget is a wxwidget app and still shows its menus in appmenu.

Revision history for this message
yurik81 (yurik81) wrote :

Such behaviour was for sure on wxformbuilder, codeblocks, pcsx2. Other wxwidget apps not had been tested.

description: updated
Changed in appmenu-gtk (Ubuntu):
importance: Undecided → High
Revision history for this message
jervin (jervin) wrote :

Just wanted to mention that a temporary workaround for applications exhibiting this problem is documented in duplicate bug #660314. I know it works around the problem for Audacity and WxCam

Changed in appmenu-gtk (Ubuntu):
status: New → Triaged
Revision history for this message
Vadim Zeitlin (vadim-wxwidgets) wrote :

Does anybody know if this is really an appmenu-gtk problem or a bug in wxWidgets itself? As a wx developer I'd be interested in looking at this if it's the latter but I can't find much information about the whole menu proxy stuff which seems to be completely Ubuntu-specific. What exactly is needed, at GTK+ level, for menu proxying to work? We don't seem to do anything obviously wrong in our menu code which just uses the usual GTK menu functions. Thanks in advance for any ideas (or even pointers to better places for discussing this).

Revision history for this message
cablop (cablop) wrote :

It seems that this is an issue with the new Unity interface.

description: updated
Martin Pitt (pitti)
Changed in appmenu-gtk (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Benjamin Drung (bdrung)
description: updated
Ted Gould (ted)
affects: appmenu-gtk (Ubuntu Natty) → libdbusmenu (Ubuntu Natty)
Changed in libdbusmenu (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
Changed in dbusmenu:
status: New → Triaged
importance: Undecided → High
tags: added: parser
Revision history for this message
Andrius Kulikauskas (ms-ms) wrote :

This workaround worked for me, typing in a terminal:

export UBUNTU_MENUPROXY=0
audacity

Thank you to: http://forum.audacityteam.org/viewtopic.php?f=18&t=48779&start=10

I have an Asus U52F on which I installed Ubuntu 10.10 as a dualboot with the original Windows 7.

Revision history for this message
Tim Kosse (tim-kosse) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

is that still an issue in natty? I've just tried poedit there and the menus are exported as they should

Changed in libdbusmenu (Ubuntu Natty):
status: Triaged → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

ok, I misread the description, still an issue

Changed in libdbusmenu (Ubuntu Natty):
status: Incomplete → Triaged
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

What is the problem in putting those TWO lines into the frame.cpp file
     if (!m_menuBarHeight)
570 {
571 UpdateMenuBarSize();
572 }

the problem is really easy to solve, just look the svn link provided by Tim
http://svn.wxwidgets.org/viewvc/wx/wxWidgets/branches/WX_2_8_BRANCH/src/gtk/frame.cpp?r1=66344&r2=66343&pathrev=66344

The importance is "High" the problem can be fixed in half a minute and nobody in 4 months took care of it...
Can I help in fixing it?

Benjamin Drung (bdrung)
affects: libdbusmenu (Ubuntu Natty) → wxwidgets2.8 (Ubuntu Natty)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.11.0-0ubuntu7

---------------
wxwidgets2.8 (2.8.11.0-0ubuntu7) natty; urgency=low

  * Apply appmenu.patch to get menus back (LP: #662077).
 -- Benjamin Drung <email address hidden> Sat, 19 Feb 2011 20:17:05 +0100

Changed in wxwidgets2.8 (Ubuntu Natty):
status: Triaged → Fix Released
Revision history for this message
Benjamin Drung (bdrung) wrote :

Here's the debdiff for wxwidgets2.8 2.8.11.0-0ubuntu4.1, which I uploaded to maverick-proposed.

Revision history for this message
Giorgi Maghlakelidze (dracid) wrote :

Wonderful! How can we use the patch on maverick? :)
Or should we wait till it's included in the updates?

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted wxwidgets2.8 into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in wxwidgets2.8 (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Sebastien Bacher (seb128) wrote :

closing the libdbusmenu bug since that got fixed in wxwidgets

Changed in dbusmenu:
status: Triaged → Invalid
Revision history for this message
Nick Callaghan (niknak) wrote :

seems to be fixed in Audacity

Revision history for this message
jervin (jervin) wrote :

Yep, I tested WxCam and Audacity and they both now have their menu line...

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Changed in wxwidgets2.8 (Ubuntu Maverick):
assignee: nobody → ginagravanio (ginagravanio)
Colin Watson (cjwatson)
Changed in wxwidgets2.8 (Ubuntu Maverick):
assignee: ginagravanio (ginagravanio) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.11.0-0ubuntu4.1

---------------
wxwidgets2.8 (2.8.11.0-0ubuntu4.1) maverick-proposed; urgency=low

  * Apply appmenu.patch to get menus back (LP: #662077).
 -- Benjamin Drung <email address hidden> Sat, 19 Feb 2011 21:05:43 +0100

Changed in wxwidgets2.8 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Revision history for this message
turbolad (turbolad995) wrote :

TrueCrypt is still missing its menus.

Can this fix be obtained from the Update Manager?

Revision history for this message
mr.goose (editor-garfnet) wrote :

2011-04-28 Natty was officially released today. However, Truecrypt is STILL missing its menus in Natty.

Revision history for this message
mr.goose (editor-garfnet) wrote :

Further to my last post, I have been trying workarounds to this problem. Truecrypt is very important for us and not being able to access the menus makes it virtually useless to us. My observations:-

export UBUNTU_MENUPROXY=0 - does NOT work for Truecrypt.

However, un-installing appmenu-gtk - does work.

I hope this helps folks in a similar situation to us, until a proper fix is published.

Best wishes, G.

Revision history for this message
Clint Byrum (clint-fewbar) wrote : Re: [Bug 662077] Re: WxWidgets apps don't have menus

Excerpts from mr.goose's message of Fri Apr 29 00:18:07 UTC 2011:
> Further to my last post, I have been trying workarounds to this problem

Revision history for this message
piovisqui (piovisqui) wrote :

Include aegisub on the affected apps. This bug still exists in Kubuntu 11.04! What a shame!

Removing appmenu-gtk workarounds the problem.

Revision history for this message
Scott Kitterman (kitterman) wrote :

This particular bug is fixed. That doesn't mean all menu related issues are resolved. No one is going to fix anything more based on this bug. If you are still having problems, file a new bug.

Revision history for this message
Jochen Fahrner (jofa) wrote :

Same problem here. Since upgrade to Natty Truecrypt is missing the menubar under classic Gnome. In Unity the menubar is present in the panel. Uninstalling appmenu-gtk made the menubar appear in Gnome.

Revision history for this message
VladV (vlad-volkov) wrote :

Another workaround: use GTK Theme Сhanger (gtk-chtheme) to change the theme (for instance, set it to Raleigh).
This fixed the problem for me.

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

opendict in Ubuntu 11.04 (Natty) still doesn't show menu bar, it seems Ubuntu developers forgot to apply the fix against wxwidgets2.6
Bug #669789 is about opendict and wammu, so, we need unmark bug #669789 as a duplicate or mark this bug (#662077) as affecting wxwidgets2.6

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wxwidgets2.6 (Ubuntu Maverick):
status: New → Confirmed
Changed in wxwidgets2.6 (Ubuntu Natty):
status: New → Confirmed
Changed in wxwidgets2.6 (Ubuntu):
status: New → Confirmed
Revision history for this message
Clopper Almon (almon) wrote :

I was having this problem with a new intallation of Ubuntu 11.10 Oneiric Ocelot, so any notion that the bug is fixed is a jump ahead of reality. Apparently, it is known exactly what needs to be done to fix it, but nobody actually gets it done so that the ordinary Ubuntu user with an up-to-date system is not afflicted by the problem.

What worked for me was to remove appmenu-gtk. For greenhorns like me, I may add that I did this in the Gnome3 desktop for Ubuntu 11.10 by clicking Applications in the main menubar, then clicking Ubuntu Software Center, and then entering
appmenu-gtk
in the search field in the upper right corner. That brings up a line with the words "Export GTK menus over DBus" on the left side. Click those words and a wide orange bar comes up with with a button labeled "Remove" on the right. Click that button.

This bug was not in Ubuntu 10.04 and seems to have been a by product of Ubuntu work on Unity. I do hope that you will get it really fixed soon.

Revision history for this message
Alistair Buxton (a-j-buxton) wrote :

This bug lives on in 12.04

Revision history for this message
Benjamin Drung (bdrung) wrote :

Alistair, which version of wxwidgets do you have installed and which desktop environment are you using?

Revision history for this message
Frank Mersmann (fmersmann) wrote :

This bug was reintroduced a week or so ago. Affected are Audacity and all wxpython apps. Interestingly not TrueCrypt. My Desktop is KDE 4.8.3 and wxpython is 2.8.12.1

Revision history for this message
Olivier FAURAX (olivier-faurax) wrote :

I just saw this bug in Audacity today, and the bug was not there the 6/6.
2.8.12.1 here too.

Revision history for this message
Daniel Dietrich (shaddowy2) wrote :

Same problem here. I've installed Ubuntu 12.04, wxwidgets version 2.8.12.1-6ubuntu2.2, KDE 4.8.4-0ubuntu0.1 and got no menu in Audacity.

Revision history for this message
PhoneixS (phoneixsegovia) wrote :

The same happen to me with BOINC Manager, using wxwidgets 2.8.12.1-6ubuntu2.2 and Ubuntu 12.04 (1.267) and Gnome Classic without effects.

Revision history for this message
PhoneixS (phoneixsegovia) wrote :

As a workaround for BOINC Manager, you can use Shift+Ctrl+A to change to advanced view and then Shift+Ctrl+V to change again to simply view. Changing windows mode make menu bar appear.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

this should be fixed in http://boinc.berkeley.edu/trac/changeset/25812/boinc

boinc 7.0.30+

Revision history for this message
PhoneixS (phoneixsegovia) wrote :

I will try when it is released for linux.

In any case, the bug also appear in FileZilla.

Revision history for this message
eugenez (eugene-zvyagintsev) wrote :

The same problem in Kubuntu 12.04 & wxwidgets libraries of version 2.8.12.1-6ubuntu2.2.

Affected apps are myrulib, audacity, filezilla.

Changed in myrulib:
status: New → Invalid
status: Invalid → New
Revision history for this message
Benjamin Drung (bdrung) wrote :

I'll reopen this bug, because my drop-appmenu-workaround.patch that fixes 100% CPU usage under Unity reintroduces this bug under non-Unity systems.

Changed in wxwidgets2.8 (Ubuntu):
status: Fix Released → Triaged
Changed in wxwidgets:
status: Unknown → New
Revision history for this message
Simon Andric (simonandric5) wrote :

hello!

have the same problem

audacity --- no main menu --- im using kubuntu 12.10 quantal, project neon, all repos on, the newest cutting edge stuff...

nice day!

simon

Revision history for this message
Simon Andric (simonandric5) wrote :

ps. i use wx version

2.8.12.1-11ubuntu2

lps

Revision history for this message
itsjustarumour (itsjustarumour-gmail-deactivatedaccount-deactivatedaccount) wrote :

Having this issue on two Ubuntu machines, with 12.04 (32-bit) and 12.10 (32-bit). In my case, on both these machines the menu bar is missing for:

Banshee
GIMP

I have tried uninstalling appmenu-gtk but no joy.

In the case of Banshee, Alt+M brings up the menus and I can then using the cursor keys to select what I need. This doesn't work for GIMP though.

Revision history for this message
Dirk Heinrichs (dirk-heinrichs) wrote :

Same here: Ubuntu 12.10beta1, KDE 4.9.1, wxMaxima 12.04.0. No menu in KDE. If I start wxMaxima in a remote ssh session coming from a machine running XFCE, I get the menu.

Revision history for this message
Janet (bugzilla-kerridis) wrote :

Affects me too, Kubuntu 12.04 + LXDE: Gimp has a menubar, but not audacity. The menubar in audacity appears when I start it from a terminal with "export UBUNTU_MENUPROXY=0" before.

Revision history for this message
Janet (bugzilla-kerridis) wrote :

Everything's fine after purging appmenu-gtk.

Revision history for this message
RussianNeuroMancer (russianneuromancer) wrote :

Same issue in Aegisub and mkvtoolnix after upgrade from Precise to Quantal.

Revision history for this message
Uqbar (uqbar) wrote :

This bug is stil here in 12.10.
Is there any chance to get if fixed instead of worked around?

Revision history for this message
Uqbar (uqbar) wrote :

audacity is (badly) affected!

Revision history for this message
L_d_v_c@ (l-d-v-c) wrote :

xavier4811 write me the solution :

    sudo apt-get purge appmenu-gtk appmenu-gtk3 appmenu-qt

Solved !
Thanks

Revision history for this message
Dirk Heinrichs (dirk-heinrichs) wrote :

Yep, works here, too.

Revision history for this message
eugenez (eugene-zvyagintsev) wrote :

It works!

xavier4811 & l-d-v-c, thank you for your solution!

Revision history for this message
L_d_v_c@ (l-d-v-c) wrote :

;)

Revision history for this message
Benjamin Drung (bdrung) wrote :

Here's the patch to fix this bug by disabling the fix for bug #996407. Bug #996407 needs to be reopened and fixed without introducing regressions.

Benjamin Drung (bdrung)
description: updated
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Can somebody speak to the status of this in raring? The workaround (disabling the patches) should be uploaded to raring if there's not a bigger fix planned. I'm going to leave it in the quantal-proposed queue for now until a fix is uploaded to raring.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wxwidgets2.6 (Ubuntu Quantal):
status: New → Confirmed
Changed in wxwidgets2.8 (Ubuntu Quantal):
status: New → Confirmed
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Hi Ben, I'm assigning the Quantal task to you. Can you please speak to the status of this bug in Raring. It needs to be fixed there first.

Changed in wxwidgets2.8 (Ubuntu Quantal):
assignee: nobody → Benjamin Drung (bdrung)
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Ben, please see comments above, thanks.

Revision history for this message
Uqbar (uqbar) wrote :

The bug is still here in Quantal and Precise.
At least under KDE Audacity doesn't have menus.
Please fix it!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-11ubuntu4

---------------
wxwidgets2.8 (2.8.12.1-11ubuntu4) raring; urgency=low

  * Disable bp-menubar-fix.patch and drop-appmenu-workaround.patch for now.
    These patches fixed the grey stripe covering the Audacity menu with gnome
    classic bug #996407, but brought a bigger regression for all wxwidgets
    applications. (LP: #662077)
 -- Benjamin Drung <email address hidden> Fri, 16 Nov 2012 16:33:05 +0100

Changed in wxwidgets2.8 (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote : Please test proposed package

Hello yurik81, or anyone else affected,

Accepted into quantal-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in wxwidgets2.6 (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in wxwidgets2.8 (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Revision history for this message
mindbeat (mindbeat) wrote :

After updating with the packages in -proposed i got my menubar back in codelite.
Thanx!

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Setting to verification-done based on the last comment.

thanks

tags: added: verification-done
removed: verification-needed
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.8 - 2.8.12.1-11ubuntu3.1

---------------
wxwidgets2.8 (2.8.12.1-11ubuntu3.1) quantal-proposed; urgency=low

  * Disable bp-menubar-fix.patch and drop-appmenu-workaround.patch for now.
    These patches fixed the grey stripe covering the Audacity menu with gnome
    classic bug #996407, but brought a bigger regression for all wxwidgets
    applications. (LP: #662077)
 -- Benjamin Drung <email address hidden> Fri, 26 Oct 2012 17:50:50 +0200

Changed in wxwidgets2.8 (Ubuntu Quantal):
status: Fix Committed → Fix Released
tags: added: patch
Revision history for this message
tuxmartin (tuxmartin) wrote :

# echo "export UBUNTU_MENUPROXY=0" | sudo tee /etc/X11/Xsession.d/81ubuntumenuproxy > /dev/null
# reboot

Now it works :-)

Adolfo Jayme (fitojb)
Changed in wxwidgets2.6 (Ubuntu Maverick):
status: Confirmed → Won't Fix
Changed in wxwidgets2.6 (Ubuntu Natty):
status: Confirmed → Won't Fix
Revision history for this message
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in wxwidgets2.6 (Ubuntu Quantal):
status: Fix Committed → Won't Fix
Md Nuhin Nabi (nuhin-2)
Changed in wxwidgets2.8 (Ubuntu):
assignee: nobody → Md Nuhin Nabi (nuhin-2)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.