python-wxgtk2.6 fails to install to the python search path

Bug #274619 reported by Steve Langasek on 2008-09-26
66
Affects Status Importance Assigned to Milestone
wxwidgets2.6 (Ubuntu)
High
Emilio Pozuelo Monfort
Hardy
Undecided
Unassigned

Bug Description

python-wxwidgets2.6 apparently lacks any support to integrate with the python search path. Files are installed to /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/, with no symlinks installed anywhere to make this module importable:

>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named wx
>>>

This makes it impossible to rebuild gnuradio from source, blocking completion of a cppunit library transition.

Steve Langasek (vorlon) on 2008-09-26
Changed in wxwidgets2.6:
importance: Undecided → High
status: New → Confirmed
Emilio Pozuelo Monfort (pochu) wrote :

I'm working on this

Changed in wxwidgets2.6:
assignee: nobody → pochu
status: Confirmed → Triaged
status: Triaged → In Progress
Emilio Pozuelo Monfort (pochu) wrote :

There were 2 problems here: one was that the update-alternatives install was plain wrong, and the other was that python-wxgtk2.8 was installing /usr/lib/python2.X/site-packages/wx.pth as a regular file, so the alternatives in python-wxgtk2.6 wasn't working.

I'm fixing the first issue here and re-fixing the second one in python-wxgtk2.8 (see bug #211553)

Changed in wxwidgets2.6:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wxwidgets2.6 - 2.6.3.2.2-2ubuntu5

---------------
wxwidgets2.6 (2.6.3.2.2-2ubuntu5) intrepid; urgency=low

  * debian/python-wxgtk.postinst,
    debian/python-wxgtk.prerm,
    debian/rules:
    - Fix update-alternatives call to install links in
      /usr/lib/python2.X/wx.pth for each supported python version,
      so that importing wx actually works (lp: #274619).

 -- Emilio Pozuelo Monfort <email address hidden> Mon, 13 Oct 2008 14:33:05 +0200

Changed in wxwidgets2.6:
status: Fix Committed → Fix Released
Cesare Tirabassi (norsetto) wrote :

IMHO, this should be fixed in our stable release too since it makes many applications currently unusable (see duplicates list).
Subscribing motu-sru to request an ack to proceed.

tags: added: iso-testing
Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in wxwidgets2.6 (Ubuntu Hardy):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers