wxmaxima crashes when typing parentheses () or [] in the Plot 2D Dialog-Window

Bug #1311770 reported by Christian Prim on 2014-04-23
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
wxmaxima (Ubuntu)
Undecided
Unassigned

Bug Description

What must be done to reproduce:

Start wxmaxima. In Plot-Menu select 'Plot 2D'. Type in the first line where the %-sign is an opening bracket (.

What happens:

wxmaxima crashes

What is expected:

the plot of a given function eg. sin(x).

In preferences matching parentheses/brackets is selected. If not, () works in 2D-Dialog box.

Related:

[] never works in main window. The preferences don't change the behaviour.

maxima itself works without problems (tested in terminal).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: wxmaxima 13.04.2-2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Apr 23 17:51:08 2014
InstallationDate: Installed on 2011-10-27 (909 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: wxmaxima
UpgradeStatus: Upgraded to trusty on 2014-04-16 (7 days ago)

Christian Prim (christian-prim) wrote :
Francois Thirioux (fthx) wrote :

Maybe a duplicate or so ? :
https://bugs.launchpad.net/ubuntu/+source/wxmaxima/+bug/1308154

Clearly related, nethertheless.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wxmaxima (Ubuntu):
status: New → Confirmed
Rob Frohne (frohro) wrote :
Download full text (5.6 KiB)

I notice that it occurs when I use the handy windows that pop up when you use the menus to help the novice get what they want. If you type the command in the regular work window, parenthesis work fine. I'm using wxMaxima 13.04.2 on Ubuntu 15.04 with wxWidgets 3.0.2-1. The plot2D function is not necessary. It seems any of the windows from the menu if you type the first (, it crashes. When I run gdb and type the (, I get the following:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff499fc3e in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0

So I installed libglib2.0-0-dbg and did it again. I get:

Starting program: /usr/bin/wxmaxima
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe9066700 (LWP 8672)]
[New Thread 0x7fffea068700 (LWP 8670)]
[New Thread 0x7fffeb49d700 (LWP 8653)]
[New Thread 0x7fffebc9e700 (LWP 8652)]

Program received signal SIGSEGV, Segmentation fault.
g_type_iface_meta_marshal (closure=0x90c320, return_value=0x0, n_param_values=3, param_values=0x7fffff7ff210, invocation_hint=0x7fffff7ff1b0,
    marshal_data=0x18) at /build/buildd/glib2.0-2.44.1/./gobject/gclosure.c:1009
1009 /build/buildd/glib2.0-2.44.1/./gobject/gclosure.c: No such file or directory.

and the back trace looks like this:

(gdb) bt
#0 0x00007ffff499fc3e in g_type_iface_meta_marshal (closure=0x90c320, return_value=0x0, n_param_values=3, param_values=0x7fffff7ff210, invocation_hint=0x7fffff7ff1b0, marshal_data=0x18) at /build/buildd/glib2.0-2.44.1/./gobject/gclosure.c:1009
#4 0x00007ffff49bbe4a in <emit signal 0x90c0c0 "\001" on instance 0x913300 [GtkEntry]> (instance=0x7fffff7ff210, detailed_signal=0x90c0c0 "\001")
    at /build/buildd/glib2.0-2.44.1/./gobject/gsignal.c:3401
    #1 0x00007ffff49a12d5 in g_closure_invoke (closure=0x90c320, return_value=0x0, n_param_values=3, param_values=0x7fffff7ff210, invocation_hint=0x7fffff7ff1b0) at /build/buildd/glib2.0-2.44.1/./gobject/gclosure.c:768
    #2 0x00007ffff49b2f32 in signal_emit_unlocked_R (node=node@entry=0x90c130, detail=detail@entry=0, instance=instance@entry=0x913300, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffff7ff210) at /build/buildd/glib2.0-2.44.1/./gobject/gsignal.c:3587
    #3 0x00007ffff49bb698 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at /build/buildd/glib2.0-2.44.1/./gobject/gsignal.c:3305
#5 0x00007ffff53c42e7 in () at /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#6 0x00007ffff6c9d9f9 in wxTextCtrl::Remove(long, long) () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#7 0x00007ffff6ca51f8 in wxTextEntry::DoSetValue(wxString const&, int) () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#8 0x00007ffff6ca1ffc in wxTextCtrl::DoSetValue(wxString const&, int) () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#9 0x00007ffff6de9157 in wxTextEntryBase::ChangeValue(wxString const&) () at /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0
#10 0x00000000004a815a in ()
#11 0x00000000004a8914 in ()
#12 0x000000000...

Read more...

Rob Frohne (frohro) wrote :
Download full text (24.2 KiB)

I ran wxmaxima at the terminal and got the following backtrace that might be helpful.

frohro@frohro-e6420:~$ wxmaxima
*** buffer overflow detected ***: /usr/lib/maxima/5.35.1/binary-gcl/maxima terminated
Segmentation fault (core dumped)
======= Backtrace: =========
frohro@frohro-e6420:~$ /lib/x86_64-linux-gnu/libc.so.6(+0x78c4e)[0x2aaaab850c4e]
/lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x5c)[0x2aaaab8f0e8c]
/lib/x86_64-linux-gnu/libc.so.6(+0x116e80)[0x2aaaab8eee80]
/lib/x86_64-linux-gnu/libc.so.6(+0x118dd7)[0x2aaaab8f0dd7]
/usr/lib/maxima/5.35.1/binary-gcl/maxima[0x3c65a3]
/usr/lib/maxima/5.35.1/binary-gcl/maxima[0x396d8d]
/usr/lib/maxima/5.35.1/binary-gcl/maxima[0x397018]
/usr/lib/maxima/5.35.1/binary-gcl/maxima[0x36c025]
/usr/lib/maxima/5.35.1/binary-gcl/maxima[0x22f386a]
======= Memory map: ========
00200000-0075f000 r-xp 00000000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0095e000-0095f000 r--p 0055e000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0095f000-00ec0000 rw-p 0055f000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00ec0000-00efb000 r-xp 00ac0000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00efb000-00efc000 rwxp 00afb000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00efc000-00efd000 r-xp 00afc000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00efd000-00efe000 rwxp 00afd000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00efe000-00eff000 r-xp 00afe000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00eff000-00f00000 rwxp 00aff000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
00f00000-0103d000 r-xp 00b00000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0103d000-0103e000 rwxp 00c3d000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0103e000-01062000 r-xp 00c3e000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01062000-01063000 rwxp 00c62000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01063000-01064000 r-xp 00c63000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01064000-01065000 rwxp 00c64000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01065000-0106c000 r-xp 00c65000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0106c000-0106e000 rwxp 00c6c000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
0106e000-01071000 r-xp 00c6e000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01071000-01072000 rwxp 00c71000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01072000-01073000 r-xp 00c72000 08:05 753752 /usr/lib/maxima/5.35.1/binary-gcl/maxima
01073000-01074000 rwxp 00c73000 08:05 753752 /usr/lib/maxima/5.35.1/bina...

Rob Frohne (frohro) wrote :

I find the message as to where the segfault occurred changes when I swap to different menus. For example when I choose the solve instead of integrate as I was using, I get:

(gdb) run
Starting program: /usr/bin/wxmaxima
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe9066700 (LWP 11116)]
[New Thread 0x7fffea068700 (LWP 11114)]
[New Thread 0x7fffeb49d700 (LWP 11097)]
[New Thread 0x7fffebc9e700 (LWP 11096)]

Program received signal SIGSEGV, Segmentation fault.
__mbsrtowcs_l (dst=0x0, src=0x7fffff7ff128, len=140737479962920, ps=0x7fffff7ff130, l=0x7ffff5d19500 <_nl_global_locale>) at mbsrtowcs_l.c:46
46 mbsrtowcs_l.c: No such file or directory.
(gdb)

I guess this means I don't know what I'm doing, and there are probably a number of threads, and I don't know how to get the one that is segfaulting or something.

Rob Frohne (frohro) wrote :

I don't think this a a duplicate of https://bugs.launchpad.net/bugs/1308154 as is claimed here. I can enter brackets just fine at the regular command line and I get a nice pretty printed a_0 for a[0].

Rob Frohne (frohro) wrote :

It seems to be fixed in Peter Pall's nightly builds here: https://launchpad.net/~peterpall/+archive/ubuntu/wxmaxima-nightlies

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers