wxmaxima 13.04.2-2 fails to get some keyboard inputs

Bug #1308154 reported by Francois Thirioux on 2014-04-15
60
This bug affects 13 people
Affects Status Importance Assigned to Milestone
wxmaxima (Debian)
Fix Released
Unknown
wxmaxima (Ubuntu)
High
Unassigned

Bug Description

With 13.04.2-2 (at the moment in proposed repos), wxmaxima does not do something with some special inputs like Ctrl-C Ctrl-V [ ] and maybe some other ones I did not try... Maybe the upgrading to libwx 3.0.0 by this version of wxmaxima causes that ?

[impact]

It is a critical bug against wxmaxima's new proposed version since brackets (e.g.) are essential to maxima language.

Previous version does work fine. (FYI the new one allows to copy/paste with mouse middle button : this is definitely great, but...)

wxmaxima in Utopic (13.04.2-4) fixes the problem, and simply installing
http://ftp.debian.org/debian/pool/main/w/wxmaxima/wxmaxima_13.04.2-4_amd64.deb on top of current Trusty version fixes it too.

[test case]

Open wxmaxima on a computer with a keyboard without direct [ or ] keys, like Spanish keyboard.

Type : a[0]

Expected result: a[0]

Result: a0

--- brackets are not read by wxmaxima.

[Regression potential]

Very low.

1. It works in Utopic.
2. As it is, wxmaxima is completely useless unless you have a US keyboard.

Francois Thirioux (fthx) wrote :
Changed in wxmaxima (Ubuntu):
status: New → Confirmed
Changed in wxmaxima:
status: Unknown → New
Francois Thirioux (fthx) wrote :

Although this package is merged from Debian, it could /* be very nice to downgrade to previous 13.04.2-1build1 version */ since this version is unusable and is now in universe repository.

A text editor not taking all keys is quite annoying, isn't it ? :-)

Francois Thirioux (fthx) wrote :

sorry : 13.04.2-1ubuntu1 , not 13.04.2-1build1 .

Hi,

I decided to compile WxMaxima 13.04.2. I had to install libwxgtk3.0-dev, but the problem persisted.
Then I removed libwxgtk3.0-dev and installed libwxgtk2.8-dev, and recompiled Wxmaxima and now
it seems just fine (although it is now in English -- when installed from repo it was according to my
system language, that is Portuguese-BR).

I hope this can be helpful.

Bye.

nigra (nigra) wrote :

Yes, it is because of libwxgtk3.0.

If the official version remains problematic, use this ppa:

https://launchpad.net/~blahota/+archive/wxmaxima/

Francois Thirioux (fthx) wrote :

Revert to wx 2.8 done in Debian archive. Just have to wait a new merge...

no longer affects: wxmaxima
Francois Thirioux (fthx) wrote :

1) revert in proposed repository at the moment
2) issue with wx 3 solved in wxMaxima git repository for a later release

Changed in wxmaxima (Ubuntu):
status: Confirmed → Fix Released
Viktoria S. (viktoria-s) wrote :

I understand that this bug is fixed released. But unfortunatelly the problem occurs with unbuntu 14.04 64bit. In that repository wxmaxima depends on libwxgtk 3.0. The libwxgtk 2.8 package is installed too, but since the wxmaxima package depends on the 3.0 version I guess it is impossible to make wxmaxima to use the 2.8 version. (For me this is a big issue because not just ctrl+c ctrl+v not working but I'm not able to type ^ ; characters because of my keyboard layout requires to press the AltGr+3 AltGr+, for those keys and AltGr doesn't work either.) Thanks for any help in advance.

Francois Thirioux (fthx) wrote :

Ok, the port from Debian was not done in Trusty, so I do open this bug again.

You can get a working version here :
https://launchpad.net/ubuntu/+source/wxmaxima/13.04.2-4/+build/5959297/+files/wxmaxima_13.04.2-4_amd64.deb

or here (that's what I did, before Utopic's packages were online) :
https://packages.debian.org/sid/wxmaxima

You can download last version of Maxima here :
https://packages.debian.org/sid/maxima
(be careful to download maxima-share and maxima-doc too)

Sorry, I believed the Ubuntu version to be automatically synced with Debian's one.
Maintainers, please consider an update wxmaxima to 13.04.2-4 since the -2 version is unusable so it is a critical bug against wxmaxima.

Changed in wxmaxima (Ubuntu):
status: Fix Released → Confirmed
Viktoria S. (viktoria-s) wrote :

https://launchpad.net/ubuntu/+source/wxmaxima/13.04.2-4/+build/5959297/+files/wxmaxima_13.04.2-4_amd64.deb worked like charm. Thank you for the link :)
It would be great if the maintainers would update wxmaxima to 13.04.2-4, I totally agree.

Kochin (kochinc) wrote :

I am also experiencing this problem with wxmaxima 13.04.2-2. That version is really unusable. It often fails to respond to characters entered.

The wxmaxima 13.04.2-4 at https://launchpad.net/ubuntu/+source/wxmaxima/13.04.2-4/+build/5959297/+files/wxmaxima_13.04.2-4_amd64.deb fares a little bit better, but still stops responding to one character entered for about every 10 characters.

Michael Kreuzer (penulci) wrote :

The problem enetering [ and ] appears to me too, using a german keyboard.
As it seems same behaviour is/was reported ind Debian under https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=742988 too and already solved with a patch, at least the bug report tells after a short test there so not seem to be any more problems.

Greetings, Michael

Francois Thirioux (fthx) wrote :

The bug does no more exist in Utopic, since the 13.04.2-4 is the Utopic's version :

http://packages.ubuntu.com/utopic/wxmaxima

This version does just have to be backported...

tags: added: trusty

I edited the description following https://wiki.ubuntu.com/StableReleaseUpdates --- could someone with a bit more time than myself nominate it with the StableReleaseUpdate team? Instructions in the wiki link above.

description: updated
Michael Kreuzer (penulci) wrote :

@Francois Thiroux

Did you already request a backport, according to " https://wiki.ubuntu.com/UbuntuBackports "? As it seems you already have tested the new version.
The wiki says everyone could request a backport. Since Trusty is a LTS version it would be more than suitable.

Greetings, Michael

Francois Thirioux (fthx) wrote :

IMHO it's not a backport (in Ubuntu's policy, I mean) since I filled a bug against a critical failure of wxMaxima. There are no new features in the 13.04.2-4 version.

Michael Kreuzer (penulci) wrote :

Well the new feature would be usage of lists for non-english keyboard layout users ;-)
Of course I agree with your arguments and we can hope to one day receive the minor-release update to wxmaxima-13.04.2-4
meanwhile we could use the following

workaround: install wxmaxima-13.04.2-4 from Utopic repositories manually

it works fine and installs without any problems on Trusty.

Greetings, Michael

Changed in wxmaxima (Debian):
status: Unknown → Fix Released
Ian Smith (m4r35n357) wrote :

So, is this going to be updated, or will I have to fix it myself? It's not really clear from the discussion.

Vicente Luiz Scalon (vscalon) wrote :

Installing wxmaxima-13.04.2-4 on Ubuntu 14.04 solve problems partially. Home and end keys go to the home/end of file, not the line as previously versions.

Quang (quang) wrote :

The bug persists in wxmaxima-13.04.2-4 on Ubuntu 14.10 Utopic. Opening any input window (for example on the menu choose Calculus, then Intergrate), as soon as I type a parenthesis key "(", the whole wxmaxima crashes.

Francois Thirioux (fthx) wrote :

I can't reproduce this bug (which is maybe not related to the bug of this report). I tried with ({#|^\[$ and no crash at all.

But your bug is already filled :
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752528
Feed it !

IMHO it's absolutely useless to use Ubuntu's bug interface to *solve* issues on Maxima/WxMaxima since it's just a Debian merge.

My system : french KB, utopic 64 bits Gnome, wxM 13.04.2-4, Maxima 5.34.1-1 from https://packages.debian.org/sid/maxima

FYI a new version of wxM is available :
http://sourceforge.net/projects/wxmaxima/files/wxMaxima/14.09.0/
but still not in Debian Sid's repository. When you compile it by default, it does use wxWidgets 2.8. Maybe someone know how to use wxW 3.0, to test if the bug is still occurring ?

Francois Thirioux (fthx) wrote :

And the 14.09 version from :
https://launchpad.net/~blahota/+archive/ubuntu/wxmaxima
uses wxWidgets 2.8 too.

Changed in wxmaxima (Ubuntu):
importance: Undecided → High
PeterPall (peterpall) wrote :

Did set up a nightly build ppa (https://launchpad.net/~peterpall/+archive/ubuntu/wxmaxima-nightlies). Today the handling for umlaute is still broken there - but tomorrow the problem should be fixed there.

Martin Saturka (kvutza) wrote :

Using current Xubuntu 16.04LTS, wxmaxima 15.08.2 (and tested git-based wxmaxima 16.04.2 too).

It ignores some keyboard shortcuts, like "Ctrl+1" for text-cell insertion (contrary to "Ctrl+2" that works correctly); and "Alt" key seems to be ignored totally. Not being sure whether it is on wxwidgets, wxmaxima, or xfce.

Martin Saturka (kvutza) wrote :

Just found that the Ctrl+1 issue can be solved by removing the .xinputrc file (with ibus-gtk(3) installed, see wxMaxima issues at GitHub), though still do not know how to solve the Alt-* issue; notice that Alt-* keys work for me at another wxWidgets-based application.

Martin Saturka (kvutza) wrote :

Current GitHub wxMaxima githead has the Alt+menukeys stuff fixed.

Changed in wxmaxima (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.