[SRU] Please backport 2.3.2-0ubuntu2 to supported releases

Bug #1849679 reported by Balint Reczey on 2019-10-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wslu (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]

 * The wslu package is a set of settings and utilities to integrate Ubuntu running in WSL to the host Windows 10 system. The wslu package is shipped in the Ubuntu Microsoft Store apps and in the downloadable WSL tarballs for supported Ubuntu releases with the intent of providing uniformly complete integration across all supported Ubuntu releases and the way of ensuring consistent behavior is back-porting full upstream releases with minimal changes.

* Compared to the previous full backport this release contains the following features/fixes that warrant the backport:
  - Stop changing fonts when running wsl* commands
  - Fix wsl* commands when the Windows user name contains space

[Test Case]

 * Follow the testing process outlined in https://wiki.ubuntu.com/wslu-Updates
 * Run the autopktest in a WSL environment where the user name contains space.
 * Verify the other individual bugs fixed by the SRU.

[Regression Potential]

 * Since upstream version 2.0.0 a code refactoring took place thus any of the scripts could break. The tests to be run inside a WSL environment excercises the scripts thus the likelyhood of regressions occuring is low.

Balint Reczey (rbalint) on 2019-10-24
summary: - [SRU] Please backport 2.3.2-0ubuntu1 to supported releases
+ [SRU] Please backport 2.3.2-0ubuntu2 to supported releases
description: updated
Balint Reczey (rbalint) on 2019-10-24
description: updated

Hello Balint, or anyone else affected,

Accepted wslu into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wslu/2.3.2-0ubuntu2~19.10.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wslu (Ubuntu Eoan):
status: New → Fix Committed
tags: added: verification-needed verification-needed-eoan
Łukasz Zemczak (sil2100) wrote :

Hello Balint, or anyone else affected,

Accepted wslu into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wslu/2.3.2-0ubuntu2~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wslu (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Hello Balint, or anyone else affected,

Accepted wslu into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wslu/2.3.2-0ubuntu2~18.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wslu (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Balint, or anyone else affected,

Accepted wslu into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/wslu/2.3.2-0ubuntu2~16.04.0 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in wslu (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Balint Reczey (rbalint) wrote :

Verified on Eoan, Disco, Bionic and Xenial.

In Bionic and Xenial I had to modifiy the debian/tests/control file dropping the skippable restriction because it is not supported there. OTOH Ubuntu CI infra needs the restriction to not run the tests which are failing on non-WSL systems.

tags: added: verification-done verification-done-bionic verification-done-disco verification-done-eoan verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial
Robie Basak (racb) on 2019-11-06
Changed in wslu (Ubuntu):
status: New → Fix Released
Robie Basak (racb) wrote :

Hi Balint,

> [Test Case]
> [...]
> * Run the autopktest in a WSL environment where the user name contains space.

Did this get missed?

Robie Basak (racb) wrote :

17:01 <rbalint> rbasak, the Windows user name had space

The verification of the Stable Release Update for wslu has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 2.3.2-0ubuntu2~19.04

---------------
wslu (2.3.2-0ubuntu2~19.04) disco; urgency=medium

  * Backport to Disco (LP: #1849679)

wslu (2.3.2-0ubuntu2) focal; urgency=medium

  * Suppress pulseaudio error on starting shell when pulseaudio-utils is installed
    (LP: #1844671)

wslu (2.3.2-0ubuntu1) eoan; urgency=medium

  [ Sebastien Bacher ]
  * debian/postinst, debian/prerm:
    - register also the www-browser alternative, the non-x-variant is
      used by xdg-open when DISPLAY is unset

  [ Balint Reczey ]
  * New upstream release
    - Fix support for Windows user names with space
  * Add autopkgtest
  * Fix saving configuration when the Windows user name contains space
  * Refresh patches

wslu (2.3.0-1ubuntu1) eoan; urgency=medium

  * debian/control: Set Vcs-* fields
  * New upstream release
    - Stop changing terminal font when running wsl* commands (LP: #1836208)
  * Refresh patches
  * debian/rules: Run tests in WSL only

wslu (2.0.0-0ubuntu3) eoan; urgency=medium

  * Set DISPLAY=:0 when an X11 server is running (LP: #1836552)
  * Use PulseAudio if it is running on Windows (LP: #1836552)
  * Set up sound, too, when starting GUI programs via Windows desktop shortcuts
    (LP: #1836552)

 -- Balint Reczey <email address hidden> Thu, 24 Oct 2019 16:15:20 +0200

Changed in wslu (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 2.3.2-0ubuntu2~18.04.0

---------------
wslu (2.3.2-0ubuntu2~18.04.0) bionic; urgency=medium

  * Backport to Bionic (LP: #1849679)

wslu (2.3.2-0ubuntu2) focal; urgency=medium

  * Suppress pulseaudio error on starting shell when pulseaudio-utils is installed
    (LP: #1844671)

wslu (2.3.2-0ubuntu1) eoan; urgency=medium

  [ Sebastien Bacher ]
  * debian/postinst, debian/prerm:
    - register also the www-browser alternative, the non-x-variant is
      used by xdg-open when DISPLAY is unset

  [ Balint Reczey ]
  * New upstream release
    - Fix support for Windows user names with space
  * Add autopkgtest
  * Fix saving configuration when the Windows user name contains space
  * Refresh patches

wslu (2.3.0-1ubuntu1) eoan; urgency=medium

  * debian/control: Set Vcs-* fields
  * New upstream release
    - Stop changing terminal font when running wsl* commands (LP: #1836208)
  * Refresh patches
  * debian/rules: Run tests in WSL only

wslu (2.0.0-0ubuntu3) eoan; urgency=medium

  * Set DISPLAY=:0 when an X11 server is running (LP: #1836552)
  * Use PulseAudio if it is running on Windows (LP: #1836552)
  * Set up sound, too, when starting GUI programs via Windows desktop shortcuts
    (LP: #1836552)

 -- Balint Reczey <email address hidden> Thu, 24 Oct 2019 16:15:20 +0200

Changed in wslu (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 2.3.2-0ubuntu2~16.04.0

---------------
wslu (2.3.2-0ubuntu2~16.04.0) xenial; urgency=medium

  * Backport to Xenial (LP: #1849679)

wslu (2.3.2-0ubuntu2) focal; urgency=medium

  * Suppress pulseaudio error on starting shell when pulseaudio-utils is installed
    (LP: #1844671)

wslu (2.3.2-0ubuntu1) eoan; urgency=medium

  [ Sebastien Bacher ]
  * debian/postinst, debian/prerm:
    - register also the www-browser alternative, the non-x-variant is
      used by xdg-open when DISPLAY is unset

  [ Balint Reczey ]
  * New upstream release
    - Fix support for Windows user names with space
  * Add autopkgtest
  * Fix saving configuration when the Windows user name contains space
  * Refresh patches

wslu (2.3.0-1ubuntu1) eoan; urgency=medium

  * debian/control: Set Vcs-* fields
  * New upstream release
    - Stop changing terminal font when running wsl* commands (LP: #1836208)
  * Refresh patches
  * debian/rules: Run tests in WSL only

wslu (2.0.0-0ubuntu3) eoan; urgency=medium

  * Set DISPLAY=:0 when an X11 server is running (LP: #1836552)
  * Use PulseAudio if it is running on Windows (LP: #1836552)
  * Set up sound, too, when starting GUI programs via Windows desktop shortcuts
    (LP: #1836552)

 -- Balint Reczey <email address hidden> Thu, 24 Oct 2019 16:15:20 +0200

Changed in wslu (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 2.3.2-0ubuntu2~19.10.0

---------------
wslu (2.3.2-0ubuntu2~19.10.0) eoan; urgency=medium

  * Backport to Eoan (LP: #1849679)

wslu (2.3.2-0ubuntu2) focal; urgency=medium

  * Suppress pulseaudio error on starting shell when pulseaudio-utils is installed
    (LP: #1844671)

 -- Balint Reczey <email address hidden> Thu, 24 Oct 2019 16:15:20 +0200

Changed in wslu (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers