writer2latex packages fails to install

Bug #244098 reported by Linda octa on 2008-06-30
76
This bug affects 5 people
Affects Status Importance Assigned to Milestone
writer2latex (Debian)
Fix Released
Unknown
writer2latex (Ubuntu)
High
Martin Pitt
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: writer2latex

I am using Ubunty Hardy. When I try to install writer2latex package using aptitude this is the error that I get.
1. Description: Ubuntu 8.04 Release: 8.04
2. writer2latex:
  Installed: 0.5-6
  Candidate: 0.5-6
  Version table:
 *** 0.5-6 0
        500 http://archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status
3. Expect it to be installed so open office can use this package. Or at least if it can't be installed, remove from the apt list as whenever I install other package, I will get the same error for writer2latex (even I am not installing writer2latex)
4. What happen instead:
Setting up writer2latex (0.5-6) ...
/var/lib/dpkg/info/writer2latex.postinst: 57: update-updmap: not found
dpkg: error processing writer2latex (--configure):
 subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
 writer2latex
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up writer2latex (0.5-6) ...
/var/lib/dpkg/info/writer2latex.postinst: 57: update-updmap: not found
dpkg: error processing writer2latex (--configure):
 subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
 writer2latex

ProblemType: Package
Architecture: i386
Date: Mon Jun 30 11:10:31 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: subprocess post-installation script returned error exit status 127
NonfreeKernelModules: nvidia
Package: writer2latex 0.5-6
PackageArchitecture: all
SourcePackage: writer2latex
Title: package writer2latex 0.5-6 failed to install/upgrade: subprocess post-installation script returned error exit status 127
Uname: Linux 2.6.24-16-generic i686

Linda octa (zzdaring) wrote :
Ralph Janke (txwikinger) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in writer2latex:
importance: Undecided → Medium
status: New → Triaged
b (ben-ekran) wrote :

I can confirm this issue, but on powerpc, and with exit status "1" not "127":

bbogart@ubuntu:~$ sudo apt-get install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gnuplot libwvstreams4.3-extras libfaad2-0 libmtp6 libneon26 python-at-spi
  libsnmp10 libicu36 linux-headers-2.6.22-14-powerpc64-smp
  linux-headers-2.6.22-14-powerpc libgfortran1 libmagick++9c2a g++-4.1
  libglew1.4 libmp4v2-0 libcamel1.2-10 libcln4 libgpod2 libstdc++6-4.1-dev
  libsvg1 libpcrecpp0 libx264-54 gutsy-wallpapers libqalculate3
  libgtkhtml2.0-cil libdirectfb-0.9-25 openoffice.org-hyphenation libgsl0
  libwvstreams4.3-base libiso9660-4 liboobs-1-3 libdb4.5
  linux-headers-2.6.22-14 libtotem-plparser7 libuniconf4.3 feisty-gdm-themes
  libntfs-3g12 librsvg2.0-cil libungif4g
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up openoffice.org-writer2latex (0.5-6) ...
Adding extension /usr/lib/openoffice/share/extension/install/writer2latex.uno.pkg...
unopkg failed.
dpkg: error processing openoffice.org-writer2latex (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openoffice.org:
 openoffice.org depends on openoffice.org-writer2latex; however:
  Package openoffice.org-writer2latex is not configured yet.
dpkg: error processing openoffice.org (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openoffice.org-writer2latex
 openoffice.org
E: Sub-process /usr/bin/dpkg returned an error code (1)

This happened during my gutsy -> hardy upgrade.

Changed in writer2latex:
importance: Medium → High
Changed in writer2latex:
status: Unknown → Fix Released
Luca Falavigna (dktrkranz) wrote :

This merge will fix this issue for Intrepid.

Luca Falavigna (dktrkranz) wrote :

This is for hardy-proposed. ubuntu-sru: is it OK for you.

Martin Pitt (pitti) wrote :

Thanks! Sponsoring.

Changed in writer2latex:
assignee: nobody → pitti
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package writer2latex - 0.5-8ubuntu1

---------------
writer2latex (0.5-8ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable (LP: #244098), remaining Ubuntu changes:
    - (Build-)depend on default-jre/-jdk.

writer2latex (0.5-8) unstable; urgency=high

  * add missing Depends: on ${misc:Depends} for writer2latex
    (closes: #490138)

writer2latex (0.5-7) unstable; urgency=high

  * fix debian/copyright; ooomath.sty is LPPL, actually mention that

 -- Luca Falavigna <email address hidden> Mon, 04 Aug 2008 02:19:03 +0200

Changed in writer2latex:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in writer2latex:
status: New → Fix Committed
Steve Beattie (sbeattie) wrote :

I have reproduced the installation failure with the writer2latex 0.5-6 package in hardy 8.04, and can confirm that the writer2latex 0.5-6ubuntu0.1 package in hardy-proposed, with the fixed dependencies pulling in tex-common (which provides update-udpmap), successfully completes installation.

However, once writer2latex is installed, I am unable to convert even the most basic of openoffice documents. Running w2l from the command line gives me:

$ w2l -latex test_document.odt

This is Writer2LaTeX, Version 0.5 (2007-10-15)

Starting conversion...
Converting test_document.odt

String index out of range: 0
java.lang.StringIndexOutOfBoundsException: String index out of range: 0
   at java.lang.String.charAt(libgcj.so.81)
   at java.io.File.getParent(libgcj.so.81)
   at java.io.File.mkdirs(libgcj.so.81)
   at java.io.File.mkdirs(libgcj.so.81)
   at writer2latex.Application.convertFile(Application.java:249)
   at writer2latex.Application.doConversion(Application.java:216)
   at writer2latex.Application.main(Application.java:112)

Attempting to use it as an export filter from openoffice.org also doesn't work; oowriter claims that it's missing a jre and needs openoffice.org-java-common installed. After that gets installed, export to latex still doesn't work and the following is dumped to the terminal:

$ Error:java.util.zip.ZipException: /usr/lib/openoffice/program/classes/writer2latex.jar (No such file or directory)
Error:java.lang.NullPointerException

Making a symlink from /usr/share/writer2latex/writer2latex.jar to /usr/lib/openoffice/program/classes/writer2latex.jar still causes export to fail with the following output to the terminal:

$ Error:java.io.FileNotFoundException: No entry for META-INF/converter.xml exists.
Error:java.lang.NullPointerException

I'm thus not convinced that releasing this updated package will produce something usable for the user.

Luca Falavigna (dktrkranz) wrote :

This should be fixed in Intrepid with OpenJDK, but Hardy is still affected. I tried switching to java-gcj-compat (instead of gij) with no significant improvements. Hardy has no other JVM in main, so this needs to be fixed in a different way.

Luca Falavigna (dktrkranz) wrote :

Looking at http://bugs.debian.org/470397, it seems w2l works using full paths only:

# gunzip /usr/share/doc/writer2latex/examples/latex/sample-article.odt.gz
# w2l -latex /usr/share/doc/writer2latex/examples/latex/sample-article.odt

This is Writer2LaTeX, Version 0.5 (2007-10-15)

Starting conversion...
Converting sample-article.odt
Done!
#

Steve Beattie (sbeattie) wrote :

Ah, yes, giving w2l a full path causes it to convert an odt file to latex correctly. Thanks.

Marking as verification-done; however, I'm still somewhat dubious of this update as it won't function properly from within OpenOffice.org's export function, which I suspect is the common use case for this package. If nothing else, writer2linux should probably depend on openoffice.org-java-common.

Steve Beattie (sbeattie) wrote :

Nevermind, I retract my hesitation towards the update; for some reason I had overlooked the openoffice.org-writer2latex package, which adds the necessary glue to make writer2linux work from within openoffice.org as an export extension. I no longer have an objection to this package going into hardy-updates.

Thanks, and sorry for the noise!

I can confirm the fix in -proposed.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in writer2latex:
status: Fix Committed → Fix Released
Aereal (aereal) wrote :

Same thing here I think http://bit.ly/1dlhrW

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.