Comment 28 for bug 1501588

I can further confirm that downgrading wpa_supplicant to 2.3.3 allowed me to immediately connect to eduroam.