workrave icon does not appear in unity panel menu

Bug #796824 reported by Kevin Squire on 2011-06-13
This bug affects 52 people
Affects Status Importance Assigned to Milestone
workrave (Ubuntu)

Bug Description

Binary package hint: workrave

After upgrading to Ubuntu 11.04 and running unity, workrave runs, but the icon no longer appears in the panel. In xsession-errors, the following is reported:

** (<unknown>:3494): DEBUG: TrayChild Rejected: Workrave Tray Icon workrave Workrave
** (<unknown>:3494): DEBUG: TrayChild Rejected: workrave workrave Workrave



ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: workrave 1.9.3-2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 0cf7ed1ce330ade7ba392f47d5557ded
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Mon Jun 13 12:42:54 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
 PATH=(custom, user)
SourcePackage: workrave
UpgradeStatus: No upgrade log present (probably fresh install)

Kevin Squire (kevin-squire) wrote :
Aurelijus (aurelijuss) wrote :

Adding workrave into notification area configuration solved the problem:

Changed in workrave (Ubuntu):
status: New → Confirmed
razor7 (ghiamar) wrote :

Hi, aftrer installing workrave (1.9.901-1ppa1~oneiric1 ), still no panel applet at all. How may I activate it?

razor7 (ghiamar) wrote :

Well, spoke too soon, whitelisted workrave panel applet and now shouws up, but has a major glitch. See attachemnt

Alexandr (olexandr-dmitriev) wrote :

I can confirm - the workrave applet is messed up.

Changed in workrave (Ubuntu):
importance: Undecided → Medium
chris erway (cce) wrote :

I, too, have this problem where the workrave applet appears, but is cut in half for some reason (as in razor7's picture). I'm running Ubuntu 11.10 and the latest package from this PPA.

Pander (pander) on 2012-05-21
tags: added: precise productivity
removed: amd64
Andrei Shevchuk (shevchuk) wrote :

Is anyone working on this? Still exists in 12.10.

tags: added: quantal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package workrave - 1.10-0ubuntu1

workrave (1.10-0ubuntu1) raring; urgency=low

  * New upstream release
  * debian/control, debian/rules, debian/workrave.install:
    - Enable support for an indicator in Unity (LP: #796824)
  * debian/patches/fix-format-security.patch:
    - Fix FTBFS due to -Werror=format-security
 -- Michael Terry <email address hidden> Thu, 24 Jan 2013 11:04:41 -0500

Changed in workrave (Ubuntu):
status: Confirmed → Fix Released
razor7 (ghiamar) wrote :

Hi, installed workrave 1.10-0ubuntu2 and there is no tray icon at all!

Gioele Barabucci (gioele) wrote :

@ghiamar, I opened a separate bug for the lack of indicators in workrave 1.10, bug #1176620. Could you comment on that bug report and maybe attach an image as well?

Jesse Johnson (holocronweaver) wrote :

Yet another launchpad bug that was marked as fixed without users testing the fix.

In this case, the fix never worked, and even on Ubuntu 14.04 the bug remains.

Reinhard Tartler (siretart) wrote :

whatever support for libindicator3 was introduced in 1.10-0ubuntu1, it doesn't seem to work on Ubuntu utopic

Changed in workrave (Ubuntu):
status: Fix Released → Triaged
Ivan Garavito (ivangaravito) wrote :

It remains at 16.04.

Igor Plyatov (plyatov) wrote :

Bug remains in Ubuntu 16.10.

Workrave works, but no applet is invisible on the panel.

Andreas Mueller (t3kcit) wrote :

Has anyone tried filing an upstream bug? I couldn't successfully register to bugzilla :-/
[Also failing under 16.10]

james (mrquintopolous) wrote :

Still an issue on 16.04 and 16.10 for me. I wish I knew more about how these panel applets work. Anyone have any thoughts on how this could happen?

PabloAB (pabloab777) wrote :

Even on last version using PPA (as suggested [here]( and [here]( on 16.04 I got errors and still no icon:

    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers