wireless-crda breaks capability to connect hidden wlan

Bug #336915 reported by syscon-hh on 2009-03-02
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
NetworkManager
Invalid
Undecided
Unassigned
wireless-crda (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: wireless-crda

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu jaunty (development branch)"

Kernel 2.6.28-8-generic i686

wireless-crda_1.6

hardware: RaLink RT2500, as well as RaLink RT61

Today updating the package >wireless-crda_1.5< to _1.6 breaks the capability connecting to hidden wireless accesspoints managed by network-manager as it still functioning with former package wireless-crda_1.5

Downgrading the package solves the problem and vice versa respectivily lets the network-manager rotate the nm-applet indication endless.

Additionally: The direct connection by >wpa_supplicant< installation inside /etc/network/interfaces is no longer successfull, too.

Attached some infos of terminal outputs

Related branches

syscon-hh (syscon-kono) wrote :

I can confirm this problem.

syscon-hh (syscon-kono) wrote :

Further investigations show:

In the changelog of >wireless-crda_1.6< you can read:

Changes:
 wireless-crda (1.6) jaunty; urgency=low

   * wireless-regdb: Update to Jan 30, 2009 regdb.
   * crda: Add /usr/local/lib/crda/regulatory.bin as first in path

In reality the pathes are (wirelesss-crda_1.5 as well as wireles-crda_1.6)

/usr/lib/crda/regulatory.bin
/lib/udev/rules.d/85-regulatory.rules

syscon-hh (syscon-kono) wrote :

In the package wireless-crda_1.6

the file >/lib/udev/rules.d/85-regulatory.rules<

is incomplete, now:

# Runs CRDA for kernel wireless regulatory events.
# For more information see:
# http://wireless.kernel.org/en/developers/Regulatory/CRDA

KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/sbin/"

last line should be:

KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/sbin/crda"

Changing these as work-around, the hidden network is functioning as required.

MarcinL (nicram-el) wrote :

I also can confirm the bug. Workaround provided by syscon-hh works for me.
Hardware: RaLink RT2561/RT61 802.11g PCI.

marcinq (marcinq) wrote :

RTL8187B ... Without the workaround posted by syscon-hh I cannot connect to any network ... My network is not hidden

Simon Kitching (skitching) wrote :

Also confirmed: editing /lib/udev/rules.d/85-regulatory.rules as shown by syscon-hh fixed this issue for me too.
Problem was caused during a jaunty update I performed on March 4 (prev update was a few days before).
Hardware was iwl3945, network was hidden.

Uwe Helm (1forthedoctor) wrote :

workaround fixed it for me as well. i couldn't connect to both, hidden and broadcatsing essids. hardware is ath9k.

As this package is now automatically installed with jaunty, it's a really annoying bug that should impacts all wireless users...

workaround works for me also, ath5k.

Rocko (rockorequin) on 2009-03-10
Changed in wireless-crda:
status: New → Confirmed
Changed in network-manager:
status: New → Invalid
syscon-hh (syscon-kono) wrote :

The update to >wireless-crda_1.7_***.deb< is still wrong !!!!

Now the incorrect line has changed to:

KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="sbin//crda"

There is one slash to much between sbin // crda !!!

Hernando Torque (htorque) wrote :

Added a patch to correct the udev file.

Hernando Torque (htorque) wrote :
Rocko (rockorequin) wrote :

Version 1.7 is installed and working for me now (although I could have sworn I'd told Synaptic to lock it at version 1.5), so this bug is fixed now for me. It must have upgraded directly from 1.5 to 1.7, though.

Sense Egbert Hofstede (sense) wrote :

It has been a while since this bug was reported. The last commenter says 1.7 works again. Is this true for everyone or does it still not work properly?
I can confirm there is still a slash too much in /lib/udev/rules.d/85-regulatory.rules on Karmic, which uses wireless-crda 1.10.

Changed in wireless-crda (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
description: updated
Loïc Minier (lool) wrote :

The superfluous slash is harmless though.

description: updated
Sense Egbert Hofstede (sense) wrote :

Adding /usr/local/lib/crda/regulatory.bin as first in the search path was done to allow users to use a local alternative. It also looks in the /usr/lib/crda/regulatory.bin file, but the entries in the (optional) first file have a higher priority. This is done because sometimes the contents of /usr/lib are similar for lot of systems, so differences can only be placed in /usr/local.

If you don't get errors like "failed to open db file" that change ought to have no influence.

I've attached a diff of wireless-crda 1.6 compared to wireless-crda 1.5 so we can see if there is a change that caused this bug. The only changes that were made, were the addition of two regularity.bin paths -- and a check to see if there was actually one to read -- and adaptions to the Makefile, which include using the $(SBINDIR) variable instead of sbin and replacing the text $(SBINDIR) with the value of the variable $(SBINDIR) in the rules file.

Since Loïc Minier said the extra slash doesn't do any harm I'd like to ask you all if you're really sure the change fixed your setup or if it was something else. Did the change also fix it when you were using 1.6?
The only reason I can come up with is that the first slash misses, but that should be fixed as well in (at least) 1.10. Can anyone tell me if the first slash is missing in earlier versions?

Sense Egbert Hofstede (sense) wrote :

I've unmarked bug #340995 as a duplicate of this bug to use that report to keep track of the small problem with the extra slash.

I suspect this bug has already been fixed when the contents of the RUN field in the rules file were changed from "/sbin/" to "/sbin//crda", which means this bug has been fixed already by a previous release of wireless-crda. Can anyone here confirm that theory?

Simon Kitching (skitching) wrote :

I can confirm that it originally failed for me ("/sbin"), and by updating manually to "/sbin/crda" resolved the issue.

I have tried manually changing it to "/sbin//crda" and this also works fine for me. So the first fix probably did resolve the issue, despite the odd-looking extra slash.

If you can tell me how to force v1.7 to be installed on top of my local change, I am happy to test that. Sorry, "apt-get upgrade" is about the limit of my apt/dpkg knowledge.

Sense Egbert Hofstede (sense) wrote :

Marking it as Fix Released. Thanks to everyone for their input.
Editing the rules file solves the problem, so that should be enough for now. There is no need to update to a newer version of wireless-crda if you adapted the rule.

If the bug does still occur, or comes back, please reopen the bug.

Changed in wireless-crda (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers