WINE windows do not display their title bar consistently when maximized

Bug #778595 reported by Jeff H on 2011-05-06
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Wine
New
Undecided
Unassigned
wine (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

The normal behavior for Windows is to merge their title bar with Unity's title bar when maximized. Here is a reproducible test case, but this bug seems to apply to all WINE apps, not just this one:

Download the Windows version of Filezilla from here: http://sourceforge.net/projects/filezilla/files/FileZilla_Client/3.4.0/FileZilla_3.4.0_win32.zip/download , and run it in WINE.
Maximize the window, notice it does not merge it's title bar with Unity's, there are 2 title bars when maximized
Close the application
Open it again, now it will start up maximized, and properly merge it's title bar with Unity's.
Un-maximize and maximize the window repeatedly. Occasionally, it will maximize correctly, but most of the time, it won't.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64: AP///////wAw5AHYAAAAAAASAQOAIhN4Ct4Fo1pRkiYaUFQAAAABAQEBAQEBAQEBAQEBAQEBPhxWoFAAFjAwIDUAWMIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/gBMUDE1NldIMS1UTEMxAE8=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Fri May 6 11:49:50 2011
DistUpgraded: Log time: 2011-04-21 12:16:09.104517
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712] (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:ff1f]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110416)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110416)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110416)
MachineType: TOSHIBA Satellite L505D
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=UUID=fc97a616-e755-45b1-aaa3-8c268c257740 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-21 (14 days ago)
dmi.bios.date: 09/07/2009
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 1.00
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: AMD
dmi.chassis.version: None
dmi.modalias: dmi:bvnInsydeCorp.:bvr1.00:bd09/07/2009:svnTOSHIBA:pnSatelliteL505D:pvrPSLV6U-00J001:rvnTOSHIBA:rnPortablePC:rvrBaseBoardVersion:cvnAMD:ct10:cvrNone:
dmi.product.name: Satellite L505D
dmi.product.version: PSLV6U-00J001
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Jeff H (jahtech-android-apps) wrote :
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Hernando Torque (htorque) wrote :

Seems to work fine when using the Grid plugin from Compiz (drag window to top edge), while a double-click on the title bar re-produces the bug.

Hernando Torque (htorque) wrote :

The top-edge way stops working after the application has been minimized.

Jeff H (jahtech-android-apps) wrote :

Here was my experience with dragging it to the top:

If the application started up maximized, it seems to work, but after enough times (maybe 20 or so), it would eventually stop maximizing correctly. If the application wasn't maximized at startup, if would stop maximizing correctly after only 5 or 10 times. It also seemed to work a better percentage of the time if I maximized/un-maximized by repeatedly dragging the title bar to/from the top without letting go of the left mouse button.

It would stop maximizing correctly sooner if you minimized the window OR if you un-maximized the window by double-clicking the title bar or clicking the un-maximize button.

James McLaughlin (udp) wrote :

Is this really a duplicate of the other bug? I don't have any mouse offset issues, but I do have two titlebars visible when I maximize a WINE application.

Luis Alvarado (luisalvarado) wrote :

I can also confirm this problem. Maximizing the Window does not merge the Wine title bar with the Unity Panel. Instead I get the following for example: http://imgur.com/oHg4e

At first I thought it was the different resolutions between the Wine configuration (Emulate virtual desktop) and the Unity Desktop but if I set the resolution to the same one as the Unity desktop or if I remove the option in Wine about emulating the desktop, in both cases I will get the same problem, which is, the Unity Launcher does not hide or go to the background. Instead, it forces itself to be not only on top, but also it moves the whole wine game to the right while using the space it needs for the launcher as see here:

http://imgur.com/xNlCf

So there is the problem that both, the Unity top Panel and the Unity Launcher stay on top, do not merge, do not hide and push the Wine window to take up the space they need to be on top.

Eddie (system-w) wrote :

This change was made since 1.5.17 version and I have to use alt+mouse drag to merge the application's titlebar with the unity panel and it costs a little playing with the mouse.
I found that 1.5.16 was the last version which allows to drag windows application's tittlebar and then maximize it merged with the unity panel.

Dac Chartrand (conner-bw) wrote :

I have this issue too. See attached screenshot.

If I maximize then resize more than a couple of times, the menu bar becomes unresponsive. I can no longer close the app by clicking the orange X or drag/resize the application using the menu bar. The app itself still works but the menu bar functionality does not (and I'm forced to ALT+F4 when quitting).

Are you still experiencing this bug in any current supported Ubuntu release? (https://wiki.ubuntu.com/Releases)

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
importance: Undecided → Low

This is still very much an issue in saucy/13.10. It is clearly evident with any maximized application running under Wine.

tags: added: oneiric precise quantal raring saucy
affects: unity (Ubuntu) → wine (Ubuntu)
affects: unity → wine
Changed in wine:
status: Incomplete → New
status: New → Confirmed
Changed in wine (Ubuntu):
status: Incomplete → Confirmed

This bug needs to:

1. Be notified to http://bugs.winehq.org/
2. The notification link to be pasted into the "Wine" project in this report.

Once this has been done, this bug will be ready to be worked on by a developer.

Changed in wine:
status: Confirmed → New

This seems to have been fixed in trusty/14.04 (unity 7.1.2+14.04.20140305-0ubuntu1). Maximized Wine windows now integrate nicely with the global Unity title bar, even when toggling between maximized/unmaxized states, switching between different Wine apps running simultaneously, etc. Everything looks good and feels snappy.

This makes Wine a much better experience under Unity. Maybe one day we'll even get proper launcher and switcher icons for Wine apps (https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1103833).

If you're still experiencing this bug, please change its status back to "confirmed".

Changed in wine (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers