Ubuntu

Can't start wicd daemon

Reported by Atlantic777 on 2013-02-24
116
This bug affects 25 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Ubuntu)
Medium
Unassigned

Bug Description

I installed ubuntu 13.04 from minimal.iso and tried to get wireless network working. I installed wicd, wicd-daemon and wicd-curses but I can't get wicd daemon started. I use awesome wm and there is no other network managers like gnome-network-manager except if ubuntu has some special network manager for minimal installs/servers. Network over ethernet works well. Interesting thing is that /var/log/wicd folder is empty and I don't get any traceback.

nikola@ubuntu:~$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

nikola@ubuntu:~$ apt-cache policy wicd
wicd:
  Installed: 1.7.2.4-4
  Candidate: 1.7.2.4-4
  Version table:
 *** 1.7.2.4-4 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status

I expected wicd starts on boot, or at least to be able to start it manually with: sudo service wicd start

Instead of that, a get just this:
 * Starting Network connection manager wicd [fail]

Related branches

lp:~chilicuil/ubuntu/trusty/wicd/fix-1132529
Robie Basak (community): Needs Information on 2013-12-06
Ubuntu branches: Pending requested 2013-12-06
Atlantic777 (nikola.hardi) wrote :

The problem is that /etc/resolv.conf is a link to ../run/resolvconf/resolv.conf and when wicd makes the backup, relative path ../run/... doesn't exist.

The fix is to change /etc/resolv.conf to point to /run/resolvconf/resolv.conf (this is absolute path).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in wicd (Ubuntu):
status: New → Confirmed
Noah Clark (a-noah) wrote :

Atlantic, would just update the sym link? I am also experiencing this issue.

Atlantic777 (nikola.hardi) wrote :

Yes, just updating link fixed it for me. Long story short, just run this 2 commands:

sudo mv /etc/resolv.conf /etc/resolv.conf.backup
sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

Here are some more details about this issue.

When I started wicd as root (not with init script) I got IO exception. The excpetion happens in /usr/share/wicd/daemon/wicd-daemon.py file, line 1708 when it tries to make a backup but the link is broken and it crashes. I find it interesting that there is the same link (relative link in /etc/resolv.conf) in ubuntu 12.04, too. I think that this should be a link with absolute path but I'm not sure who should I contact about that.

Evan Peck (colors) wrote :

How about this patch? I remved the symlink/backup thing althogether.

Atlantic777 (nikola.hardi) wrote :

Evan, that probalby works but I think it's not the right solution. I started this bug as related to wicd but now it seems to me that it's related to ubuntu or resolvconf.

The attachment "rmbackup.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Evan Peck (colors) wrote :

Ok- well, at least that is a temporary solution until the upstream developers and/or Ubuntu developers can come up with a permanent solution as I don't want to mess with the program's working too much (I'm not a developer by trade). :P

Noah Clark (a-noah) wrote :

I am unable to get the above solution to work:

noahc@trex:~$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
noahc@trex:~$ apt-cache policy wicd
wicd:
  Installed: 1.7.2.4-4
  Candidate: 1.7.2.4-4
  Version table:
 *** 1.7.2.4-4 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages
        100 /var/lib/dpkg/status
noahc@trex:~$ sudo service wicd
Usage: /etc/init.d/wicd {start|stop|restart|force-reload|status}
noahc@trex:~$ sudo service wicd restart
 * Restarting Network connection manager wicd [fail]

And then:

noahc@trex:~$ sudo mv /etc/resolv.conf /etc/resolv.conf.backup
noahc@trex:~$ sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
noahc@trex:~$ sudo service wicd restart
 * Restarting Network connection manager wicd [fail]

My /var/log/wicd is empty as well.

Atlantic777 (nikola.hardi) wrote :

What happens when you run "sudo wicd"? You should get some traceback that way.
Does /run/resolvconf/resolv.conf exist on your system? Try this:

ls -lah /etc/resolv.conf
cat /etc/resolv.conf

And check what was resolv.conf before with:

ls -lah /etc/resolv.conf.backup

Noah Clark (a-noah) wrote :

noahc@trex:~$ sudo wicd
[sudo] password for noahc:
Traceback (most recent call last):
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1859, in <module>
    main(sys.argv)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1708, in main
    os.symlink(dest, backup_location)
OSError: [Errno 17] File exists

noahc@trex:~$ ls -lah /etc/resolv.conf
lrwxrwxrwx 1 root root 27 Feb 24 21:22 /etc/resolv.conf -> /run/resolvconf/resolv.conf
noahc@trex:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.1

noahc@trex:~$ ls -lah /etc/resolv.conf.backup
lrwxrwxrwx 1 root root 27 Feb 24 21:21 /etc/resolv.conf.backup -> /run/resolvconf/resolv.conf

Does anything look out of place?

Noah Clark (a-noah) wrote :

Is there an easy way to apply this patch to my machine?

Having the exact same Problem as Noah, on fresh installed raring (dev branch), same arch

replacing symlinks did not fix it

Noah Clark (a-noah) wrote :

Robert,

I applied the patch and still have those issues. 12.10 works fine though.

Got the wicd daemon running, but having other problems now, so far here is a patch to get the daemon started, its a one liner

ERROR:dbus.proxies:Introspect error on :1.12:/org/wicd/daemon: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

seems the client also hangs when started, at least it is infinitely searching for connections

ok, getting really weird again ... kernel panic and everything hanging ... it did that before my patch as well. not responsive at all, I give up for now, after all raring is still in development.

bmarsh (bmarsh-bmarsh) wrote :

Having same wicd problem (dbus error - - logfile is empty) on 13.04-i386 with all updates applied. The symlink change didn't help at all. And 13.04 has now been released.

bmarsh (bmarsh-bmarsh) wrote :

Getting closer maybe.

1) I made the symlink change mentioned above but that didn't fix anything.

2) In checking with the daemon file, I went to /var/lib/wicd and found a similar symlink:

    resolv.conf.orig --> ../run/resolvconf/resolv.conf

3) I changed that symlink to be absolute and the daemon now runs. Works fine with a wired line.

However, for a wireless which needs a WPA passphrase entered into the properties window fails. You can enter the passphrase but nothing happens when you click 'OK'. The window just sits there. I think it must have something to do with the wpa_supplicant connection and that connection just isn't happening.....

Dev (deviskec) wrote :

Getting same error:

Traceback (most recent call last):
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1859, in <module>
    main(sys.argv)
  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1708, in main
    os.symlink(dest, backup_location)
OSError: [Errno 17] File exists

Raring release 64-bit version, symlink patch did not help.

Atlantic777 (nikola.hardi) wrote :

Guys, but look what error you get. Have you tried to delete that file (/var/lib/wicd/resolv.conf.orig)? The problem is that when you start wicd, it tryis to copy file from a broken symlink and wicd-daemon crashes leaving some traces in /var/lib/wicd/. Try to remove that backup file, make sure links are fixed and run wicd daemon again. Good luck. ;)

Liam Zdenek (liamzdenek) wrote :

bmarsh, your patch provided in comment #19 fixed it for me. I did this:

    rm /etc/resolv.conf
    ln -s /run/resolvconf/resolv.conf
    rm /var/lib/wicd/resolv.conf.orig
    ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig

then, launching wicd with "sudo service wicd start" worked, and wicd-gtk appears to be functioning normally. I'm not experiencing anything with wpa2 malfunctioning.

Carlo Martini (marzian-it) wrote :

@ Liam: thanks, that worked for me, but I don't see the tray icon (I already checked and it is enabled on the startup programs)

Maris Radu (marisradu) wrote :

@Liam worked for me to, @bmarsh I am only using WPA and don't have any problem, I hoped you found a fix for your problem.

Dev (deviskec) wrote :

@Liam thanks, your steps worked for me too. Looks like the tray icon is gone for good now since 13.04 release ditched the systray completely out and a new appindicator would be needed.

superboot (greasecar) wrote :

@Liam Worked like a charm. Nice find on the broken link. Darn relative paths!

Joseph Boiteau (josephboiteau) wrote :

Robert patch "check for existing backup of symlink to resolv.conf" listed above worked like a charm for me!

Xubuntu raring 13.04 - freshly switched from network-manager to wicd

Rémi Lapeyre (courrier-3) wrote :

Hi, i'm on Linux Mint 15 and this worked for me :
    rm /etc/resolv.conf
    ln -s /run/resolvconf/resolv.conf
    rm /var/lib/wicd/resolv.conf.orig
    ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig

TechSolX (uohn) wrote :

Same problem, same solution as @Liam, Gracias. Ubuntu 13.04 Linux 3.8.0-30-generic x86_64 GNU/Linux.
Awesome wm, not that it matters...

Leo (bzdk) wrote :

Same problem, same solution as #Liam, thanks guys.

Linux Mint 15 Olivia

Piotr Darzyn (darzynp) on 2013-10-08
Changed in wicd (Ubuntu):
status: Confirmed → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Malte Wetz (mjw-de) wrote :

I ran into the same bug on Xubuntu 13.10.

However I did not post because of that (apparently it'll probably be fixed in the next release). I post because I believe you should also make wicd give more information if and when it runs into critical problems (for example with this backup). Critical problems as in preventing the program from starting. There was no message on the screen, no entry in the syslog, no files in wicd's own log directory and even the above error on the terminal would not have been of any use to an average user who has no knowledge of Python.

IMHO, the correct way would be to provide at least a clear and understandable error message, preferably with instructions to fix it. Like: "Failed to backup /etc/resolv.conf. Make your own backup and then re-run wicd with parameter --no-backup" or something like that. Sooner or later, someone will have similar problems again and then they should be able to help themselves.

Because having to google for problems with your network manager provides a fine example of a chicken-egg-problem.

Just my 0.02$

Martin (lodp) wrote :

I'm on Kubuntu 13.10, and ran into the same problem, with wicd installed from the Saucy repositories. The fix in comment #19 worked.

The bug status was changed to "Fix committed" -- how does the process work on this one? Will this be fixed in the next Ubuntu release, or backported to the current one, too?

My package version is 1.7.2.4-4.1

Sebastian W. (yodamin) wrote :

Hey guys I have the same versions as Martin does (with Xubuntu).

Is it possible to release the patch provided in this duplicate?
https://bugs.launchpad.net/wicd/+bug/1193856

It makes no sense if everybody has to fix it himself ...

Thomas Ward (teward) wrote :

Bug status reset to Confirmed. Importance set to Medium per a request in #ubuntu-bugs on IRC.

Changed in wicd (Ubuntu):
importance: Undecided → Medium
status: Fix Released → Confirmed
C de-Avillez (hggdh2) wrote :

@Piotr Darzyn: please do not change bug status without a CLEAR explanation of why you did so.

Javier P.L. (chilicuil) wrote :

I've taken the fix provide by tommy in bug #1193856 and prepared a merge request for the ubuntu package and the upstream code:

https://code.launchpad.net/~chilicuil/ubuntu/trusty/wicd/fix-1132529/+merge/197998
https://code.launchpad.net/~chilicuil/wicd/wicd/+merge/198057

Hopefully one will get accepted, in the meantime I've prepared a package:

https://launchpad.net/~chilicuil/+archive/proposed-fixes

In order to use it, you can follow the next instructions:

$ sudo add-apt-repository ppa:chilicuil/proposed-fixes
$ sudo apt-get update
$ sudo apt-get install wicd-daemon
$ sudo rm -rf /etc/apt/sources.list.d/chilicuil-proposed-fixes*
$ sudo apt-get update

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wicd - 1.7.2.4-4.1ubuntu1

---------------
wicd (1.7.2.4-4.1ubuntu1) trusty; urgency=low

  * debian/patches/34-fix-resolv.conf_backup-restore-broken-link.patch:
    allow wicd-daemon to start when /etc/resolv.conf is a broken link
    (LP: #1132529)
 -- <email address hidden> (Javier P.L.) Fri, 06 Dec 2013 01:02:49 -0600

Changed in wicd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers