whoopsie's network-manager state querying is broken

Bug #1697375 reported by Jean-Baptiste Lallement on 2017-06-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
whoopsie (Ubuntu)
High
Brian Murray
Xenial
High
Unassigned
Zesty
High
Unassigned
Artful
High
Brian Murray

Bug Description

[Impact]
whoopsie's querying of network-manager's state is broken and this results in whoopsie only being able to detect if the system is on-line when network manager's state changes. Subsequently, if one manually restarts whoopsie then whoopsie will stay off-line until an n-m state change. This can result in crashes not being uploaded. Additionally, whoopsie's systemd service file does not start after networking which is incorrect since it initially needs to query network-manager's state. (However, this ended up allowing crash reports to still be submitted because whoopsie would start first then the n-m's state would change and whoopsie would detect that.)

[Test Case] (state detection failure)
1) Manually restart the whoopsie service
2) Observe the following two messages:
"Jul 14 14:48:09 speedy whoopsie[14137]: [14:48:09] Could not get the Network Manager state:
Jul 14 14:48:09 speedy whoopsie[14137]: [14:48:09] GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: No such property 'state'"

with the version of network-manager from -proposed you will not see these messages when restarting whoopsie.

[Test Case] (starting after network-manager0
1) Boot your system
2) Observe the following in syslog:
"Jul 17 06:46:47 speedy whoopsie[1156]: [06:46:47] Could not get the Network Manager state:
Jul 17 06:46:47 speedy whoopsie[1156]: [06:46:47] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files
"

with the version of network-manager in -proposed you will not see the "NetworkManager was not provided" messages.

[Regression Potential]
Its possible that systems that were not submitting crash reports suddenly will and that will use some network bandwidth and Error Tracker resources.

- Original Description -
------------------------
On artful crash reports are not uploaded automatically (several .crash files in /var/crash and no corresponding upload or .uploaded files)

ProblemType: BugDistroRelease: Ubuntu 17.10
Package: whoopsie 0.2.56
ProcVersionSignature: Ubuntu 4.10.0-22.24-generic 4.10.15
Uname: Linux 4.10.0-22-generic x86_64
ApportVersion: 2.20.5-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Jun 12 09:39:29 2017
InstallationDate: Installed on 2013-09-03 (1377 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: apport-noui N/ASourcePackage: whoopsie
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

$ grep whoopsie /var/log/syslog
Jun 11 23:17:41 herm whoopsie[1027]: [00:17:41] offline
Jun 11 23:17:42 herm whoopsie[1027]: [00:17:42] Cannot reach: https://daisy.ubuntu.com
Jun 11 23:17:42 herm whoopsie[1027]: [00:17:42] Cannot reach: https://daisy.ubuntu.com
Jun 11 23:17:42 herm whoopsie[1027]: [00:17:42] Cannot reach: https://daisy.ubuntu.com
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] online
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] offline
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/12
Jun 12 08:00:14 herm whoopsie[1027]: [09:00:14] online
Jun 12 08:37:47 herm whoopsie[25826]: [09:37:47] Using lock path: /var/lock/whoopsie/lock
Jun 12 08:37:47 herm whoopsie[25826]: [09:37:47] Could not get the Network Manager state:
Jun 12 08:37:47 herm whoopsie[25826]: [09:37:47] GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: La propriété « state » n'existe pas

Changed in whoopsie (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
milestone: none → ubuntu-17.06
Changed in whoopsie (Ubuntu):
milestone: ubuntu-17.06 → ubuntu-17.07
Brian Murray (brian-murray) wrote :

On boot in artful whoopsie works for me, I think because whoopsie is started before networking and then network-manager's state changes and then whoopsie is able to connect. Here I started whoopsie, took an interface offline and then brought it online.

ul 14 14:25:25 speedy whoopsie[13673]: [14:25:25] Could not get the Network Manager state:
Jul 14 14:25:25 speedy whoopsie[13673]: [14:25:25] GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: No such property 'state'
Jul 14 14:25:35 speedy whoopsie[13673]: [14:25:35] offline
Jul 14 14:25:35 speedy whoopsie[13673]: [14:25:35] Cannot reach: https://daisy.ubuntu.com
Jul 14 14:25:35 speedy whoopsie[13673]: [14:25:35] Cannot reach: https://daisy.ubuntu.com
Jul 14 14:25:43 speedy whoopsie[13673]: [14:25:43] Cannot reach: https://daisy.ubuntu.com
Jul 14 14:25:43 speedy whoopsie[13673]: [14:25:43] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/17
Jul 14 14:25:43 speedy whoopsie[13673]: [14:25:43] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/17
Jul 14 14:25:43 speedy whoopsie[13673]: [14:25:43] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/17
Jul 14 14:25:44 speedy whoopsie[13673]: [14:25:44] online

Additionally, if I try to start whoopsie manually when I am already online it fails.

Jul 14 14:48:09 speedy systemd[1]: Started crash report submission daemon.
Jul 14 14:48:09 speedy whoopsie[14137]: [14:48:09] Using lock path: /var/lock/whoopsie/lock
Jul 14 14:48:09 speedy whoopsie[14137]: [14:48:09] Could not get the Network Manager state:
Jul 14 14:48:09 speedy whoopsie[14137]: [14:48:09] GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: No such property 'state'

I also noticed the same behavior on Ubuntu 17.04.

Changed in whoopsie (Ubuntu Artful):
status: New → In Progress
importance: Undecided → High
Brian Murray (brian-murray) wrote :

Testing this on Ubuntu 16.04 and Ubuntu 17.04 I've discovered that the 'state' property is also not available, so this will need to be SRU'ed to both releases.

description: updated
summary: - crash reports are not uploaded automatically
+ whoopsie's network-manager state querying is broken
Changed in whoopsie (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → High
Changed in whoopsie (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.57

---------------
whoopsie (0.2.57) artful; urgency=medium

  * src/connectivity.c: query the correct property when trying to
    network-manager's state. (LP: #1697375)
  * Modify the whoopsie service file to start after networking is on-line.

 -- Brian Murray <email address hidden> Mon, 17 Jul 2017 13:08:38 -0700

Changed in whoopsie (Ubuntu Artful):
status: In Progress → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted whoopsie into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.55.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in whoopsie (Ubuntu Zesty):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-zesty
Changed in whoopsie (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Jean-Baptiste, or anyone else affected,

Accepted whoopsie into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/whoopsie/0.2.52.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Part 1 verified on Ubuntu 17.04

bdmurray@clean-zesty-amd64:~$ sudo service whoopsie status
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-21 11:05:00 PDT; 6s ago
 Main PID: 1787 (whoopsie)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/whoopsie.service
           └─1787 /usr/bin/whoopsie -f

Jul 21 11:05:00 clean-zesty-amd64 systemd[1]: Stopped crash report submission daemon.
Jul 21 11:05:00 clean-zesty-amd64 systemd[1]: Started crash report submission daemon.
Jul 21 11:05:00 clean-zesty-amd64 whoopsie[1787]: [11:05:00] Using lock path: /var/lock/whoopsie/lock
Jul 21 11:05:00 clean-zesty-amd64 whoopsie[1787]: [11:05:00] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:05:00 clean-zesty-amd64 whoopsie[1787]: [11:05:00] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:05:00 clean-zesty-amd64 whoopsie[1787]: [11:05:00] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
bdmurray@clean-zesty-amd64:~$ apt-cache policy whoopsie
whoopsie:
  Installed: 0.2.55.1
  Candidate: 0.2.55.1
  Version table:
 *** 0.2.55.1 500
        500 http://192.168.10.7/ubuntu zesty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.2.55 500
        500 http://192.168.10.7/ubuntu zesty/main amd64 Packages

Brian Murray (brian-murray) wrote :

Part 1 verified on Ubuntu 16.04:

bdmurray@clean-xenial-amd64:~$ systemctl status whoopsie
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-21 11:33:57 PDT; 2min 32s ago
 Main PID: 1696 (whoopsie)
   CGroup: /system.slice/whoopsie.service
           └─1696 /usr/bin/whoopsie -f

Jul 21 11:33:57 clean-xenial-amd64 systemd[1]: Started crash report submission daemon.
Jul 21 11:33:57 clean-xenial-amd64 whoopsie[1696]: [11:33:57] Using lock path: /var/lock/whoopsie/lock
Jul 21 11:33:57 clean-xenial-amd64 whoopsie[1696]: [11:33:57] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:33:57 clean-xenial-amd64 whoopsie[1696]: [11:33:57] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:33:57 clean-xenial-amd64 whoopsie[1696]: [11:33:57] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
bdmurray@clean-xenial-amd64:~$ apt-cache policy whoopsie
whoopsie:
  Installed: 0.2.52.4
  Candidate: 0.2.52.4
  Version table:
 *** 0.2.52.4 500
        500 http://192.168.10.7/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     0.2.52.3 500
        500 http://192.168.10.7/ubuntu xenial-updates/main amd64 Packages
     0.2.52 500
        500 http://192.168.10.7/ubuntu xenial/main amd64 Packages

Brian Murray (brian-murray) wrote :
Download full text (3.1 KiB)

Hmm apparently After=network-online.target may not be enough as I'm still running into a race.

bdmurray@clean-xenial-amd64:~$ systemctl status whoopsie
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-21 11:51:09 PDT; 8s ago
 Main PID: 587 (whoopsie)
   CGroup: /system.slice/whoopsie.service
           └─587 /usr/bin/whoopsie -f

Jul 21 11:51:09 clean-xenial-amd64 systemd[1]: Started crash report submission daemon.
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] Using lock path: /var/lock/whoopsie/lock
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] offline
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] Cannot reach: https://daisy.ubuntu.com
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:51:10 clean-xenial-amd64 whoopsie[587]: [11:51:10] online
bdmurray@clean-xenial-amd64:~$ sudo shutdown -r now
[sudo] password for bdmurray:
Connection to clean-xenial-amd64.local closed by remote host.
Connection to clean-xenial-amd64.local closed.

Last login: Fri Jul 21 11:51:11 2017 from 192.168.122.1
bdmurray@clean-xenial-amd64:~$ systemctl status whoopsie
● whoopsie.service - crash report submission daemon
   Loaded: loaded (/lib/systemd/system/whoopsie.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-07-21 11:52:46 PDT; 4min 6s ago
 Main PID: 596 (whoopsie)
   CGroup: /system.slice/whoopsie.service
           └─596 /usr/bin/whoopsie -f

Jul 21 11:52:46 clean-xenial-amd64 systemd[1]: Started crash report submission daemon.
Jul 21 11:52:46 clean-xenial-amd64 whoopsie[596]: [11:52:46] Using lock path: /var/lock/whoopsie/lock
Jul 21 11:52:46 clean-xenial-amd64 whoopsie[596]: [11:52:46] Could not get the Network Manager state:
Jul 21 11:52:46 clean-xenial-amd64 whoopsie[596]: [11:52:46] GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was
Jul 21 11:52:46 clean-xenial-amd64 whoopsie[596]: [11:52:46] offline
Jul 21 11:52:46 clean-xenial-amd64 whoopsie[596]: [11:52:46] Cannot reach: https://daisy.ubuntu.com
Jul 21 11:52:47 clean-xenial-amd64 whoopsie[596]: [11:52:47] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:52:47 clean-xenial-amd64 whoopsie[596]: [11:52:47] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:52:47 clean-xenial-amd64 whoopsie[596]: [11:52:47] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/0
Jul 21 11:52:47 clean-xenial-amd64 whoopsie[596]: [11:52:47] online

Regardless, this isn't making the situation worse and fixes it some of the time so I think it is still worth letting into -updates while we further sort out the mat...

Read more...

tags: added: verification-done-xenial verification-done-zesty
removed: verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.52.4

---------------
whoopsie (0.2.52.4) xenial-proposed; urgency=medium

  [Brian Murray]
  * src/connectivity.c: query the correct property when trying to
    network-manager's state. (LP: #1697375)
  * Modify the whoopsie service file to start after networking is on-line.
  * src/whoopsie.c: Add HotspotError from the openjdk-8 package hook which can
    be larger than 1KB to the list of accepted fields. (LP: #1696814)

 -- Tiago Stürmer Daitx <email address hidden> Wed, 19 Jul 2017 11:39:47 -0700

Changed in whoopsie (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for whoopsie has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package whoopsie - 0.2.55.1

---------------
whoopsie (0.2.55.1) zesty-proposed; urgency=medium

  [ Brian Murray ]
  * src/connectivity.c: query the correct property when trying to
    network-manager's state. (LP: #1697375)
  * Modify the whoopsie service file to start after networking is on-line.
  * src/whoopsie.c: Add HotspotError from the openjdk-8 package hook which can
    be larger than 1KB to the list of accepted fields. (LP: #1696814)

 -- Tiago Stürmer Daitx <email address hidden> Wed, 19 Jul 2017 11:34:31 -0700

Changed in whoopsie (Ubuntu Zesty):
status: Fix Committed → Fix Released
tags: added: id-59695177efc355a29a203a96
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers