Comment 7 for bug 1899288

Sergio Callegari (callegar) wrote :

Still true of the deb packages provided by upstream for Virtualbox 6.1.18.

The problem is really with the packaging on their side which does not target ubuntu 20.10. In fact, they say so by indicating that they have a deb up to 19.10 and 20.04.

I guess there is little that ubuntu can do if Virtualbox does not want to package a deb for ubuntu 20.10 that is not an LTS. Most likely, they'll stick to 20.04 and start supporting newer ubuntu at 21.10 in preparation for the 22.04 LTS release.

On the other hand, I believe that ubuntu could help a lot here by making the current virtualbox always available in testing version on a PPA.