mouse button clicks not detected in windowed mode

Bug #528957 reported by Jarmo Torvinen
328
This bug affects 61 people
Affects Status Importance Assigned to Milestone
libsdl
Fix Released
Medium
libsdl1.2 (Debian)
Fix Released
Unknown
libsdl1.2 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Andrew Mitchell
wesnoth (Debian)
Fix Released
Unknown
wesnoth (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

The main menu in the game wesnoth is not usable when running in windowed mode (which is the default). So new users might not be able to use the game without finding the workaround in this bug report.

This bug has been fixed by reverting another, but less severe, bug (http://bugzilla.libsdl.org/show_bug.cgi?id=716).

TEST CASE: Make sure compiz is enabled. Start the game wesnoth (if it start in full screen then press ctrl-f). Nothing happens when you click the buttons (except the letter in the bottom right).

Regarding regression see http://bugzilla.libsdl.org/show_bug.cgi?id=716

------------------Original --------------
Binary package hint: wesnoth

The game starts normally to the main screen, and I can move between menu items with a mouse (the correct items are highlighted on mouse over). The problem is that the mouse clicks are totally ignored. I cannot select any items so the playing of the game seems rather difficult.

lsb_release -rdDescription: Ubuntu lucid (development branch)
Release: 10.04

apt-cache policy wesnoth
wesnoth:
  Installed: 1:1.6.5-1build1
  Candidate: 1:1.6.5-1build1
  Version table:
 *** 1:1.6.5-1build1 0
        500 http://fi.archive.ubuntu.com lucid/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
Date: Sat Feb 27 13:58:52 2010DistroRelease: Ubuntu 10.04InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
NonfreeKernelModules: wl
Package: wesnoth 1:1.6.5-1build1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-genericSourcePackage: wesnoth
Uname: Linux 2.6.32-14-generic i686

Revision history for this message
Jarmo Torvinen (jarmo-torvinen) wrote :
Revision history for this message
Jarmo Torvinen (jarmo-torvinen) wrote :

It seems that if I manage to enable the full screen mode with keyboard, the mouse is usable again.

summary: - mouse button clicks not detected in the game
+ mouse button clicks not detected in windowed mode
Revision history for this message
Rhonda D'Vine (rhonda) wrote :

This is an issue with libsdl1.2 version 1.2.14 that the wesnoth team found out a while ago and discussed with libsdl upstream developers already. The fix for it unfortunately isn't easy so somehow I fear it will take a while to get fixed.

Given that the libsdl1.2 version 1.2.13 was causing other troubles in Ubuntu the sync still happened. It's hard to decide which issue is "more" relevant.

Revision history for this message
gare-calhoun (gare-calhoun) wrote :

workaround is to play wesnoth in full screen mode:

open terminal window

> wesnoth --fullscreen

Changed in wesnoth (Ubuntu):
status: New → Confirmed
Rhonda D'Vine (rhonda)
affects: wesnoth → libsdlgame
Revision history for this message
Robomaster (thebenjaminz) wrote :

This affects me to - I'm using Lucid. Several others reported (http://ubuntuforums.org/showthread.php?t=1437702) that they had this same problem, but only on lucid.

Revision history for this message
iORlas (iorlas) wrote :

Oh g-d... I wanted to play while my code compiles. But this bug makes me sad =/
Also, left button works if i press right button.

Revision history for this message
Lieven (lieven-debels) wrote :

Same problem here, if I hold down the right button and then press the left button, it works. Actually, it should work without holding down the right button. I'm using an updated Lubuntu Lucid beta.

Changed in libsdlgame:
status: Unknown → Confirmed
Changed in wesnoth (Debian):
status: Unknown → New
Revision history for this message
William Grant (wgrant) wrote :

There is an SDL patch on the Debian bug. The upstream Wesnoth bug is https://gna.org/bugs/index.php?14770.

affects: libsdlgame → libsdl
Changed in libsdl:
status: Confirmed → Unknown
Changed in libsdl1.2 (Debian):
status: Unknown → Confirmed
Revision history for this message
Julien Lavergne (gilir) wrote :

Attached is the debdiff with the debian patch.

Testing packages are available in my PPA : https://launchpad.net/~gilir/+archive/updates

I confirm that it fixes the problem for me.

Changed in libsdl1.2 (Debian):
status: Confirmed → Fix Released
Revision history for this message
Mark Dickie (blaeberries) wrote :

This is only a bug for me in Gnome, in enlightenment e17 the bug does not appear. Anyway, if it's fixed, it's fixed.

Changed in wesnoth (Debian):
status: New → Fix Released
Revision history for this message
Przemysław Kochański (kochas315) wrote :

another workaround is to disable compiz (alt+F2 > metacity --replace)

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

The fix for libsdl1.2 will be uploaded into lucid-proposed, for testing after lucid release.

Revision history for this message
Przemysław Kochański (kochas315) wrote :

libsdl1.2 fix fixes Westnoh bug but provides another one in OpenTTD: http://bugs.openttd.org/task/3758?project=1&order=tasktype&sort=asc&order2=reportedin&sort2=desc

Revision history for this message
Rhonda D'Vine (rhonda) wrote :

There though is also another proposed fix mentioned in the Debian bug that fixes both the wesnoth and the OpenTTD issue. If there is (hopefully) a version for lucid-proposed prepared, both parts should be added:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578389#12

Revision history for this message
Przemysław Kochański (kochas315) wrote :

the package from Gerfried Fuchs link (libsdl1.2debian_1.2.14-5.1) indeed fix both wesnoth and openttd bugs, but have dependences problem (requaiers libsvga1_1.4.3-29 and libdirectfb-1.2-9_1.2.10.0-3, but replacing the last one brokes a lot of dependences in lucid. I force-installed it through dpkg, but now every time synaptic showes mi broken package report between libdirectfb versions).

Revision history for this message
Rhonda D'Vine (rhonda) wrote :

 The package in the link is built for Debian so to some degree it's expected to have differences in the dependencies. The patch itself though should work without troubles on lucid. If I get around to find the time for it I am willing to prepare a debdiff.

 Thanks for quick test,
Rhonda

Revision history for this message
alaaji (alaaji) wrote :

You can use <tab> to choose options as well and then enable fullscreen that way if you'd like. I'm not using compiz but I do have Lucid and have the same problem as the others.

Changed in wesnoth (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Revision history for this message
hihihi100 (hihihi100) wrote :

Hi there:

I have this same problem, and the ctrl f2 workaround works for me...

However, I havent seen any change after having downloaded

deb http://ppa.launchpad.net/gilir/updates/ubuntu lucid main
deb-src http://ppa.launchpad.net/gilir/updates/ubuntu lucid main

to my sources... Am I forgetting something?

Revision history for this message
hihihi100 (hihihi100) wrote :

K, dont start to call me stupid yet... what I have to add is
Patch:

libsdl1.2_1.2.14-4ubuntu2.debdiff

Now, will any nice member tell me where do I have to add all the enclosed text? Im a total noob

Plus, should I disable the

deb http://ppa.launchpad.net/gilir/updates/ubuntu lucid main
deb-src http://ppa.launchpad.net/gilir/updates/ubuntu lucid main

lines?

Thanks

Morgan Collett (morgan)
Changed in libsdl1.2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Andrew Mitchell (ajmitch) wrote :

I've uploaded a libsdl1.2 package to test to:

deb http://ppa.launchpad.net/ajmitch/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/ajmitch/ppa/ubuntu lucid main

It'd be appreciated if people could test this & check that it fixes the problem and doesn't introduce any new issues.

Changed in libsdl1.2 (Ubuntu):
status: Confirmed → Fix Released
Changed in libsdl1.2 (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Andrew Mitchell (ajmitch)
Revision history for this message
Przemysław Kochański (kochas315) wrote :

I've added "ppa:ajmitch/ppa" to software sources list, updates were found, and problem is fixed! Wesnoth and OpenTTD works prefectly. Thanks!

Revision history for this message
Tomislav Parčina (tomo-sok) wrote :

I can confirm that adding those two lines
deb http://ppa.launchpad.net/ajmitch/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/ajmitch/ppa/ubuntu lucid main
in /etc/apt/sources.list and executing sudo apt-get update; sudo apt-get upgrade solves the problem.

Andrew Mitchell, thumbs up!

Revision history for this message
Peter (pingrainbowtrading) wrote :

Thanks! Andrew and Tomislav! I got the problem solved!

Revision history for this message
Phillip Susi (psusi) wrote :

The PPA fixes this issue for me as well.

Revision history for this message
Rune Philosof (olberd) wrote :
Rune Philosof (olberd)
description: updated
Revision history for this message
Rune Philosof (olberd) wrote :

Andrew. I took the liberty of doing steps 1-3 f the sru procedure.
I am not sure about step 4, besides you are assigned to this bug.
Will you do the rest of the sru procedure?

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

At the moment, the package is in the queue to be approved for lucid-proposed & needs an ACK from the SRU team & an archive admin.

Changed in libsdl1.2 (Ubuntu Lucid):
status: In Progress → Triaged
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted libsdl1.2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in wesnoth (Ubuntu):
status: Confirmed → Invalid
Changed in wesnoth (Ubuntu Lucid):
status: New → Invalid
Changed in libsdl1.2 (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Rune Philosof (olberd) wrote :

Wouldn't it have made more sense to go with the upstream version 1.2.14-6 instead of 1.2.14-4ubuntu1.1?

Anyway. It seems to work when tested in wesnoth1.8.

Martin Pitt (pitti)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsdl1.2 - 1.2.14-4ubuntu1.1

---------------
libsdl1.2 (1.2.14-4ubuntu1.1) lucid-proposed; urgency=low

  * Add 320_disappearingcursor.diff & 310_fixmouseclicks from Debian
    revisions 1.2.14-5 & 1.2.14-6 to fix problems with the mouse button
    clicks not being detected in windowed mode (LP: #528957)
 -- Andrew Mitchell <email address hidden> Mon, 03 May 2010 22:57:25 +1200

Changed in libsdl1.2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in libsdl:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.