Using compiz breaks Wesnoth application

Bug #566001 reported by Michał J. Gajda
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
wesnoth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: wesnoth

Using Ubuntu Lucid beta with all upgrades (as of today), I see that both wesnoth and wesnoth1.8 have the same problem: no clicks are accepted inside application window, so no buttons work. This occurs only when using compiz.

No other games seems to have this problem, but it may also be a bug in SDL.

Information:
1) lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
2) wesnoth package versions:
1:1.6.5-1build1
1:1.8-1
3) Buttons like "Tutorial" are supposed to respond to clicks with actions.
4) Buttons don't respond to clicks (even though they get highlighted when mouse is over.)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: wesnoth 1:1.6.5-1build1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic-pae 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Apr 18 16:28:31 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: wesnoth

Revision history for this message
Michał J. Gajda (mgajda) wrote :
Revision history for this message
Gabe Gorelick (gabegorelick) wrote :

Thanks for reporting this. Can you check to see if this is a duplicate of bug 528957? Thanks in advance.

Changed in wesnoth (Ubuntu):
status: New → Incomplete
Revision history for this message
Rhonda D'Vine (rhonda) wrote : Re: [Bug 566001] Re: Using compiz breaks Wesnoth application

* Gabe Gorelick <email address hidden> [2010-04-18 20:37:36 CEST]:
> Thanks for reporting this. Can you check to see if this is a duplicate
> of bug 528957? Thanks in advance.
>
> ** Changed in: wesnoth (Ubuntu)
> Status: New => Incomplete

 Out of curiosity, why marking it as invalid when it's actually a
duplicate? Please mark it as such and not as invalid, thanks.

 So long,
Rhonda

Revision history for this message
Rhonda D'Vine (rhonda) wrote :

Sorry, misread Incomplete as Invalid - my bad. Hope you don't get that comment wrongly.

Actually, a fix for SDL should be in the works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers