libjavascriptcoregtk-1.0-0 need to be multiarched

Bug #933913 reported by Anders Kaseorg
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
icu (Ubuntu)
Low
Unassigned
libproxy (Ubuntu)
Undecided
Martin Pitt
webkit (Ubuntu)
Low
Unassigned

Bug Description

Since glib-networking in precise was rebuilt against libproxy1 instead of libproxy0, we now have

ia32-libs-multiarch depends gstreamer0.10-plugins-good depends libsoup2.4-1 depends glib-networking depends libproxy1 depends libjavascriptcoregtk-1.0-0 depends libicu48,

so for ia32-libs to remain installable, libjavascriptcoregtk-1.0-0 and libicu48 need to be converted to multiarch.

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in icu (Ubuntu):
status: New → Confirmed
Changed in webkit (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Actually, libproxy1 is not even supposed to pull in libjavascriptcoregtk-1.0-0, it's quite a large library and libproxy can't use it right now anyway (we had to drop the mozjs and webkit plugins due to mozjs being in universe).

Changed in libproxy (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

But independently of this, it'd still be nice to multi-arch the libraries, it's just not that pressing any more.

Changed in icu (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in webkit (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libproxy - 0.4.7-0ubuntu3

---------------
libproxy (0.4.7-0ubuntu3) precise; urgency=low

  * Drop libwebkitgtk-dev build dependency. We just got rid of the old
    webkit-gtk2 stack, we don't want to pull that back in. We already had to
    disable the webkit plugin as this needs mozjs. (LP: #933913)
 -- Martin Pitt <email address hidden> Fri, 17 Feb 2012 07:54:22 +0100

Changed in libproxy (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

the library package is multiarched in quantal. The -dev package is still not multiarched.

Changed in icu (Ubuntu):
status: Triaged → Fix Released
summary: - libjavascriptcoregtk-1.0-0, libicu48 need to be multiarched
+ libjavascriptcoregtk-1.0-0 need to be multiarched
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers