Applications fail to start on the second use

Bug #1656252 reported by Jean-Baptiste Lallement on 2017-01-13
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Ted Gould
address-book-app (Ubuntu)
Critical
Unassigned
camera-app (Ubuntu)
Critical
Unassigned
gallery-app (Ubuntu)
Critical
Unassigned
ubuntu-app-launch (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu)
Critical
Unassigned

Bug Description

zesty desktop
unity8 session snap 349

Test Case:
1. Launch the webbrowser from the app scope
2. close it (or the app crashes)
3. Launch the webbrowser from the app scope

Expected result:
It starts twice

Actual result
It does not always starts and it hangs on the launch window (blank window, with the webbrowser icon and a spinning loading icon)
When it occurs it is very reproducible and a reboot of the machine is required to make it work again.

Related branches

Jean-Baptiste Lallement (jibel) wrote :
affects: unity8 (Ubuntu) → webbrowser-app (Ubuntu)
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
description: updated
summary: - sometimes webbrowser fails to start
+ frequently webbrowser fails to start

We were seeing this on the second launch of any app that has single instance specified in the desktop file. The theory is systemd is confused about it successfully exiting.

Assigning to unity8 because it happened with other apps too like system settings or the gallery.

summary: - frequently webbrowser fails to start
+ frequently applications fails to start
description: updated
affects: webbrowser-app (Ubuntu) → unity8 (Ubuntu)
Changed in canonical-devices-system-image:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Critical
milestone: none → p2
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

I can confirm that removing single instance from the desktop file works around it.

summary: - frequently applications fails to start
+ some applications fail to start twice
description: updated

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-app-launch (Ubuntu):
status: New → Confirmed
tags: added: unity8-desktop
summary: - some applications fail to start twice
+ Applications fail to start on the second attempt
summary: - Applications fail to start on the second attempt
+ Applications fail to start on the second use
Changed in ubuntu-app-launch (Ubuntu):
status: Confirmed → Invalid
Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in address-book-app (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Critical
status: New → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in camera-app (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Critical
status: New → In Progress
Changed in gallery-app (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Ken VanDine (ken-vandine)
description: updated
Changed in webbrowser-app (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) on 2017-01-27
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Committed
kevin gunn (kgunn72) on 2017-03-06
tags: removed: unity8-desktop
Olivier Tilloy (osomon) wrote :

The workaround was causing a regression in webbrowser-app: in unity8, opening a link from another app would work if the browser was not running, but it wouldn't do anything if the browser was already running.

Changed in webbrowser-app (Ubuntu):
status: Fix Committed → New
Olivier Tilloy (osomon) on 2017-03-29
tags: added: next-candidates
Bill Filler (bfiller) on 2017-03-31
Changed in canonical-devices-system-image:
milestone: p2 → u8c-2
tags: added: current-milestone
tags: added: unity8-desktop
Ted Gould (ted) on 2017-04-12
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in camera-app (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in address-book-app (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in gallery-app (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Olivier Tilloy (osomon) on 2018-11-19
Changed in webbrowser-app (Ubuntu):
assignee: Olivier Tilloy (osomon) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers