New Microsoft Azure Linux Agent

Bug #1799498 reported by Roiy Zysman on 2018-10-23
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
walinuxagent (Ubuntu)
High
Łukasz Zemczak
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]
This release contains both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these improvements.

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/walinuxagentUpdates

The Microsoft Azure Linux Agent team will execute their testsuite, which
includes extension testing , against the walinuxagent that is in
-proposed. A successful run will be required before the proposed walinuxagent
can be let into -updates.

The CPC team will be in charge of attaching a summary of testing to the bug. CPC team members will not
mark ‘verification-done’ until this has happened.

[Upstream Changelog]

* v2.2.32

[#1325] Enable cgroups by default on all distros
[#1327, #1347] Allow enforcing of cgroups limits
[#1337] Allow configuration for cgroups
[#1333] Add support for NSBSD
[#1319] Stream extension downloads to disk (do not buffer the download in memory)
[#1303] Fix to support custom DNS servers
[#1306] Log extension stdout and stderr
[#1302] Better of cloud-init configuration during deprovisioning
[#1295] Fix to report the correct extension error code
[#1289] Allow disabling the agent or extensions
[#1290] Use the "ip route" command instead of the "route" comand during network configuration
[#1281] Delete JIT accounts
[#1234] Fix for reading KVP values from host
[#1287] Add UDEV rule in azure disk encryption

This release also includes improvements in telemetry and bug fixes.

* v2.2.31

[#1196] Health store integration
[#1199] CGroups support
[#1194] Use host for status reporting
[#1188] Fix for sentinel and signal handlers
[#1182] Telemetry updates
[#1171] Add support for JIT
[#1164] Fix for name resolution in Ubuntu 18.04
[#1154] Set connection close header
[#1143] Remove extension packages after extraction

There are also several other bug fixes and improvements.

* v2.2.26

Update Debian specific configuration and setup.

* v2.2.25

Revert extension manifest caching to prevent downgrade issues.

[Original Description]

This is a request to integrate the new version of the Azure Linux Guest Agent version 2.2.32 into the Ubuntu Azure Images .
Available here
https://github.com/Azure/WALinuxAgent/releases/tag/v2.2.32

tags: added: upgrade-software-version
Changed in walinuxagent (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
description: updated
Changed in walinuxagent (Ubuntu):
importance: Undecided → High
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

So currently, without any modifications, the new walinuxagent packages (based on 2.2.32) fail to build due to failing unit-tests. Apparently for all the previous walinuxagent versions in Ubuntu, no unit-tests have been running during build because of a bug in setup.py (fixed recently in PR #1244 [1]). Only now we actually see the tests running. I did a similar change to the current cosmic package and also saw many similar failures.

Were all the walinuxagent unit-tests expected to pass on Ubuntu? Some tests will obviously fail (like the cgroup ones) because of the builder environment, but there's also a lot of others that I wouldn't normally expect to fail - but they're failing on the new and old walinuxagent.

Possibly what we'll do is ignore the failures for this release (it's a possibility), unless the expectation was that those should have been passing already. For the next release we would really need to have those passing though. Maybe move out some of them (like the cgroup ones) as autopkgtests, since only then they could actually work.

What's the case here?

[1] https://github.com/Azure/WALinuxAgent/pull/1244

Łukasz Zemczak (sil2100) wrote :

Filled in a bug to explicitly track the unit-test failures:
https://bugs.launchpad.net/ubuntu/+source/walinuxagent/+bug/1800499

But for now, until we get some clarity, this is a blocker for getting the new wala out.

Changed in walinuxagent (Ubuntu):
status: In Progress → Incomplete
tags: added: id-5bd6c6f3f9786c60d0af5a69

I looked at the test failures and they are caused by environmental differences from our automation. Apart from the cgroup tests that you already mentioned, a few test are issuing requests to an internal endpoint, and some mocks need improving. Also, it looks like for some reason some of the mock data is not being picked up correctly.

We run those tests on Ubuntu routinely so, if this is OK for you, we could go ahead as is for this release.

How can I replicate your builder environment? I can work on fixing the failing tests.

Thank you.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package walinuxagent - 2.2.32-0ubuntu1

---------------
walinuxagent (2.2.32-0ubuntu1) disco; urgency=medium

  * New upstream release (LP: #1799498).
  * debian/patches/disable_import_test.patch: refreshed patch.
  * debian/control:
    - Add the python3-mock build-dependency.
  * debian/rules:
    - Run unit tests but don't fail the build if they fail. Previously, due to
      a bug in setup.py, those were never being run during build so the
      failures are not regressions.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Mon, 29 Oct 2018 09:13:23 +0100

Changed in walinuxagent (Ubuntu):
status: Incomplete → Fix Released
Changed in walinuxagent (Ubuntu Trusty):
status: New → In Progress
Changed in walinuxagent (Ubuntu Xenial):
status: New → In Progress
Changed in walinuxagent (Ubuntu Bionic):
status: New → In Progress
Changed in walinuxagent (Ubuntu Cosmic):
status: New → In Progress
Steve Langasek (vorlon) wrote :

The SRU exception states that:
  the CPC team will write new automated tests to cover new testable functionality (if any) in the new package

Has this been done?

Changed in walinuxagent (Ubuntu Cosmic):
status: In Progress → Incomplete
Francis Ginther (fginther) wrote :

> The SRU exception states that:
> the CPC team will write new automated tests to cover new testable functionality (if any) in the > new package
>
> Has this been done?

@Steve,

There is no new functionality or features in this release of walinuxagent that require new automated tests. CPC is happy to sign-off on this requirement as complete.

Hello Roiy, or anyone else affected,

Accepted walinuxagent into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in walinuxagent (Ubuntu Cosmic):
status: Incomplete → Fix Committed
Changed in walinuxagent (Ubuntu Bionic):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Roiy, or anyone else affected,

Accepted walinuxagent into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Steve Langasek (vorlon) wrote :

Hello Roiy, or anyone else affected,

Accepted walinuxagent into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in walinuxagent (Ubuntu Xenial):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Roiy, or anyone else affected,

Accepted walinuxagent into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in walinuxagent (Ubuntu Trusty):
status: In Progress → Fix Committed
David Coronel (davecore) wrote :

I upgraded walinuxagent to version 2.2.32-0ubuntu1 (from -proposed) on 4 instances (trusty, xenial, bionic and cosmic). I rebooted the 4 instances and verified the serial console still works for each one. I didn't run additional tests. Maybe the Azure team has more in-depth automated tests they can run for each Ubuntu release?

David Coronel (davecore) wrote :

I also noticed walinuxagent in Ubuntu 18.10 (cosmic) installed the python3-distro dependency when upgrading the walinuxagent package (which was expected).

tags: added: verification-needed-bionic verification-needed-cosmic verification-needed-trusty verification-needed-xenial
tags: added: id-5bf281d2ceb8ea76acb07c33

Microsoft's testing has turned up https://bugs.launchpad.net/ubuntu/+source/walinuxagent/+bug/1806972 as an issue in the latest version of walinuxagent, which will need addressing before we can SRU it.

tags: added: verification-failed-bionic verification-failed-cosmic verification-failed-trusty verification-failed-xenial
removed: verification-needed-bionic verification-needed-cosmic verification-needed-trusty verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers