Please update wacom to 0.8.4-2 version

Bug #405800 reported by Kiwinote
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
wacom-tools (Debian)
Invalid
Undecided
Unassigned
wacom-tools (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Martin Schmitz

Bug Description

Binary package hint: wacom-tools

2009-09-16 Ping Cheng <email address hidden>
 * Fixed a mapping issue introduced by non-TwinView support
 * Label 0.8.4-2

2009-08-28 Ping Cheng <email address hidden>
 * Updated wacomcpl for Nvidia non-TwinView setting
 * Fixed ring event jump accrossing 0 and 71 points
 * Label 0.8.4-1

2009-07-30 Ping Cheng <email address hidden>
 * Support Nvidia non-TwinView setting
 * Updated webpages and man page
 * Fixed bug 2789354 for Graphire
 * Label 0.8.4

2009-06-28 Ping Cheng <email address hidden>
 * Added support for DFT720a
 * Fixed DFT720 and DTF521 product ID swapped issue in wacom_wac.c
 * Added ABS_Z out-prox event for the newer kernels
 * Support kernel 2.6.31
 * Label 0.8.3-6

2009-05-22 Ping Cheng <email address hidden>
 * Fixed a menu strip out-prox issue in wacom_wac.c (Sylvain Giasson)
 * Fixed a relative mode button issue for ExpressKeys
 * Updated --enable-quirk-tablet-rescale support
 * Split TOOLSEIAL from SERIAL for xsetwacom
 * Support boundary cases of "usbParse: Exceeded channel" (Stefan Schimanski)
 * Label 0.8.3-5

2009-05-01 Ping Cheng <email address hidden>
 * Updated web pages and docs
 * Fixed a tool index bug in wacom_wac.c (Sylvain Giasson)
 * Updated configure.in for Xorg earlier than 7.0
 * Label 0.8.3-4

2009-04-23 Ping Cheng <email address hidden>
 * Updated README
 * Updated GPL to version 2
 * Updated wacom_wac.c
 * Brought configure.in and inlcude files in-sync with Fedora 10/11
 * Fixed a few button and in-prox/out-prox issues
 * Label 0.8.3-3

http://linuxwacom.sourceforge.net/

Related branches

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

and now there's 0.8.4

Changed in wacom-tools (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Artur Rona (ari-tczew)
description: updated
tags: removed: karmic tx2-1150
summary: - [karmic] new upstream version available
+ Please update wacom to 0.8.4 version
Kiwinote (kiwinote)
summary: - Please update wacom to 0.8.4 version
+ Please update wacom to 0.8.4-1 version
description: updated
Revision history for this message
Loïc Martin (loic-martin3) wrote : Re: Please update wacom to 0.8.4-1 version

Timo's 0.8.4.1 packages work great for me on Karmic i386, with an Intuos3 6x8.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Subscribed ubuntu-release, since the new version adds support for newer hardware and some minor features.

Changed in wacom-tools (Debian):
status: New → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Timo, did you test the packages yourself on tablet hardware? I also subscribed Alberto, I think he also knows about tablets.

The changelog looks appropriate, I just can't decipher what "Updated wacom_wac.c" is supposed to mean?

On how much hardware was this tested?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Martin: I don't have suitable hw to test, other than the WALTOP tablet which supports only a minor subset of the features. The upstream changelog is cryptic as always..

I've uploaded it to my ppa: https://edge.launchpad.net/~tjaalton/+archive/ppa

Hopefully more people could test it, especially the Intuos4 owners.

Revision history for this message
Ronan Jouchet (ronj) wrote : Re: [Bug 405800] Re: Please update wacom to 0.8.4-1 version

Hello,
I'll test it on an Intuos3

On Thu, Sep 17, 2009 at 2:57 PM, Timo Aaltonen <email address hidden> wrote:
> Martin: I don't have suitable hw to test, other than the WALTOP tablet
> which supports only a minor subset of the features. The upstream
> changelog is cryptic as always..
>
> I've uploaded it to my ppa:
> https://edge.launchpad.net/~tjaalton/+archive/ppa
>
> Hopefully more people could test it, especially the Intuos4 owners.
>
> --
> Please update wacom to 0.8.4-1 version
> https://bugs.launchpad.net/bugs/405800
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Timo Aaltonen (tjaalton) wrote : Re: Please update wacom to 0.8.4-1 version

I've tried it with the WALTOP (Aiptek 10000U), but it crashed the server just like the current version in jaunty/karmic; the driver bails out if the device is something else than a Wacom. Patching the driver to continue instead cured the crashing, but the tablet didn't do anything. It used to work in 8.10, but only because the device was recognized as a serial one, and that part of the driver doesn't seem to check the vendor ID. Some other part of the system made this happen, so it's not the driver to blame :)

Evdev works for the most part, but I didn't test if pressure sensitivity worked.

Revision history for this message
Ronan Jouchet (ronj) wrote :

Timo, your 0.8.4.1 packages works exactly like Jaunty {wacom-tools 0.7.9.3-2 + xserver-xorg-input-wacom 0.7.8} on my Intuos3 A5wide on a freshly installed Karmic alpha6, which means:

  1. tablet properly detected when hotplugged and working (I only tested gimp)
  2. wacomcpl doesn't allow setup of the tablet because it's not recognized by the hal rules
  3. applying the same fix I used in Jaunty to the .fdi file (http://ubuntuforums.org/showthread.php?p=7234134#post7234134) solves 2. , which means after this fix wacomcpl recognizes my Intuos3 and lets me set up parameters

Available for more testing if needed.

Revision history for this message
Martin Pitt (pitti) wrote :

Seems ok, please go ahead.

Revision history for this message
Ronan Jouchet (ronj) wrote :

Is there a fix planned for the bug I mentioned above? (wacom.fdi file still failing to identify some tablets as such). Not a big deal if you're comfortable with doing some search and editing config files, but could be a deal breaker for new users.

Revision history for this message
Loïc Martin (loic-martin3) wrote :

Ronan, the problem you're talking about in post #8 isn't that the .fdi file fails to identify the tablet - it does identify them, it's just that it now uses longer (=more precise) identifiers, which wacomcpl hasn't yet been patch to accept. The old identifiers (stylus/eraser/etc...) were the same whatever the model of tablet you had, which means all tablets plugged on a system would get the same parameters (which is wrong, you obviously don't want your Bamboo tablet to have the same setup as your Cintiq).

So the bug is in wacomcpl, not elsewhere. As an alternative, you can use wacom-utility (http://www.gtk-apps.org/content/show.php?action=content&content=104309) which recognises the new strings (but doesn't yet have all the features wacomcpl had), or change your fdi file with the one provided http://ubuntuforums.org/showpost.php?p=7234134&postcount=176

Kiwinote (kiwinote)
summary: - Please update wacom to 0.8.4-1 version
+ Please update wacom to 0.8.4-2 version
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

ack for -2

Revision history for this message
Martin Schmitz (martin-schmitz-digital) wrote :

As Ronan Mentions, I still had to modify the .fdi in order to use wacomcpl but apart from that everything works for me. Using a Cintig 12 WX at 1280x800 and a flat screen at 1280x1024 and a Geforce 8800GT running the proprietary drivers with TwinView horizontal. I can switch screens and the mapping is done correctly (it is streched on the flat screen but I don't really mind since I'm only drawing on the cintiq anyways) which is more than I can tell than for my 9.04 setup where the mapping is of (so that the tablet area doesn't align to the tablets screen) and I can't switch screens, but I guess I just screwed up on some settings there.

I'm also available for further tests.

Revision history for this message
Martin Schmitz (martin-schmitz-digital) wrote :

Alas, scratch that. The mapping is still weird just this time around it's the flat screen where I can't reach the bottom section of the screen since the 16:10 tablet is mapped to the 4:3 monitor without it being stretched.
It's the same for the 8.3-2 Version though so not worse either and, as mentioned, I practically only need it to map correctly on the cintiq screen and as I can't even do the on 9.04 it's an improvement to me.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Sorry for the delay.. I've uploaded 0.8.4.2-0.1 to my ppa: https://edge.launchpad.net/~tjaalton/+archive/ppa

pitti: still ok to upload, after beta perhaps?

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 405800] Re: Please update wacom to 0.8.4-2 version

Timo Aaltonen [2009-09-30 10:20 -0000]:
> pitti: still ok to upload, after beta perhaps?

Yes; you can upload, but it'll stay in the unapproved queue until
after beta.

Revision history for this message
Martin Schmitz (martin-schmitz-digital) wrote :

0.8.4.2-0.1 breaks my Twinview again. My cintiq is now stretched across both its own screen and the monitor.
I tried all variations of 'xsetwacom set stylus TwinView "[0-5]" ' and none of them had any effect. Well Mode 5 sort of had the effect that 'wacomcpl' would crash whenever I clicked the 'Screen Mapping' button.

the reported issue:

child killed: segmentation violation
child killed: segmentation violation
    while executing
"exec xsetwacom get $dev $Option($j) "
    (procedure "getDeviceOptionProc" line 7)
    invoked from within
"getDeviceOptionProc $device 3"
    (procedure "initialSet" line 11)
    invoked from within
"$initial"
    (procedure "displaySubWindow" line 32)
    invoked from within
"displaySubWindow updateSet defaultSet initialSet 4 0 0"
    invoked from within
".panel.advanced invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tk::ButtonUp" line 22)
    invoked from within
"tk::ButtonUp .panel.advanced"
    (command bound to event)

Once set to left of (5) 'xsetwacom get stylus TwinView' would only return a 'segmentation fault'. Maybe wacomcpl is mapping the modes wrong. i.e. from 1 to 6 instead of 0-5 so that 'left of' is 6 and what we get is an 'out of range' issue but I have no clue what's going on. It's really just frustrating right now.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

hrm, well 0.8.4.2-0ubuntu1 is now waiting in the queue, so maybe best to let upstream know about the regression between 0.8.4-1 and 0.8.4-2 so we'd be able to pull in the fix for 9.10rc.

Revision history for this message
Martin Pitt (pitti) wrote :

Timo Aaltonen [2009-10-01 6:11 -0000]:
> hrm, well 0.8.4.2-0ubuntu1 is now waiting in the queue, so maybe best to
> let upstream know about the regression between 0.8.4-1 and 0.8.4-2 so
> we'd be able to pull in the fix for 9.10rc.

I can also just reject it, to avoid this regression creeping in. Shall I?

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Why not, I can upload the previous version after that.

Revision history for this message
Martin Pitt (pitti) wrote :

OK, rejected. Just for the record, the next upload can use the same version number.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

0.8.4.1-0ubuntu1 uploaded and waiting in the queue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wacom-tools - 1:0.8.4.1-0ubuntu1

---------------
wacom-tools (1:0.8.4.1-0ubuntu1) karmic; urgency=low

  * New upstream version. (LP: #405800)
  * xsfbs: Remove deprecated --print-installation-architecture. (LP: #403316)
  * waltop-ntrig.diff: Drop support for WALTOP, it doesn't work and crashes
    the server.

 -- Timo Aaltonen <email address hidden> Wed, 16 Sep 2009 16:31:32 +0300

Changed in wacom-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers