rebuild python-vte for python2.7

Bug #674175 reported by Jean-Baptiste Lallement on 2010-11-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vte (Ubuntu)
High
Barry Warsaw

Bug Description

python-vte is not available for python2.7 in natty and breaks apps that depends on it amongst which update-manager.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-vte 1:0.26.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-2.10-generic 2.6.37-rc1
Uname: Linux 2.6.37-2-generic i686
Architecture: i386
Date: Thu Nov 11 19:55:25 2010
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: vte

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

setting importance to 'high' because of the dependency of update-manager which is a critical component.

Changed in vte (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
importance: Undecided → High
status: New → Triaged
tags: added: python27
tags: added: mago
Barry Warsaw (barry) wrote :

ftbfs for Natty with Python 2.6 and 2.7. It appears as though it's still referencing Python 2.6 when it tries to build the package for Python 2.7. Cause is currently unknown.

Changed in vte (Ubuntu):
status: Triaged → In Progress
milestone: none → natty-alpha-1
Barry Warsaw (barry) wrote :

I think the problem is that when it wants to build in debian/build/main/python, it only builds for Python 2.6 and this somehow leaves artifacts around that break the Python 2.7 build.

Barry Warsaw (barry) wrote :
Barry Warsaw (barry) wrote :

Debian maintainer contacted.

Michael Terry (mterry) wrote :

Try the following diff. It specifies the version of python when running make, which is relevant when make decides to rerun ./configure (which it now does on install for some reason). Since PYTHON was only specified during the debuild configure step, it reverted to the default version during install. Always specifying it prevents that bug.

--- debian/rules 2010-08-31 03:04:57 +0000
+++ debian/rules 2010-11-23 19:59:50 +0000
@@ -73,13 +73,13 @@
 configure/python-vte:: $(addprefix configure-stamp-, $(PY_VERSIONS))

 build-stamp-%:
- make -C $(buildbasedir)/$*
+ make -C $(buildbasedir)/$* PYTHON=`which $*`
  touch $@

 build/python-vte:: $(addprefix build-stamp-, $(PY_VERSIONS))

 install-stamp-%:
- make -C $(buildbasedir)/$* install DESTDIR=$(DEB_DESTDIR)
+ make -C $(buildbasedir)/$* install DESTDIR=$(DEB_DESTDIR) PYTHON=`which $*`
  # stop shipping *.a and *.la files for the Python module;
  # python-support moves them anyway (#412477)
  find $(DEB_DESTDIR)/usr/lib/$* -name \*.a -exec rm -f '{}' \;

Barry Warsaw (barry) wrote :

Confirmed that this fixes the build. Thanks Michael. See attached branch, which is ready for review and upload.

Barry Warsaw (barry) wrote :

Debdiff as requested by Matthias.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte - 1:0.26.0-0ubuntu3

---------------
vte (1:0.26.0-0ubuntu3) natty; urgency=low

  [ Michael Terry ]
  * Explicitly specify the Python version when running make. Since
    $PYTHON was only specified during the debuild configure step, it
    reverted to the default version during install. (LP: #674175)
 -- Barry Warsaw <email address hidden> Mon, 29 Nov 2010 17:46:24 -0500

Changed in vte (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers