Typo in etc/init/vsftpd.conf

Bug #577165 reported by Jürgen Kreileder on 2010-05-07
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vsftpd (Ubuntu)
Low
Luke Faraone
Lucid
Low
Unassigned

Bug Description

Binary package hint: vsftpd

       [ -d /var/run/vsftpd/emply ] || install -m 755 -o root -g root -d /var/run/vsftpd/empty

Obviously "emply" is not the same as "empty".

IMPACT: very low. vsftpd needs an empty directory for chroot
environment, according to comments in vsftpd.conf:

# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd/empty

The upstart script in /etc/init/vsfptd.conf checks for this directory
and it created it with the proper permissions IF there is no such
directory. As the script in Lucid has a typo in the checking part,
the condition is never true and the directory gets created no matter
what.

This is fixed in Maverick. Patch is attached for Lucid.

TEST CASE:

There is no visible problem to reproduce. See IMPACT above.

Without the patch the directory creation happens every time, with the
patch it happens ONLY if the directory does not exist.

REGRESSION POTENTIAL: low/none.

NOTE: as this is not a serious bug, it should be SRU'd together with
#648202 which also corrects a bug in init/vsftpd.conf.

Related branches

Jürgen Kreileder (jk) wrote :
Angel Abad (angelabad) on 2010-05-13
Changed in vsftpd (Ubuntu):
status: New → Confirmed
Angel Abad (angelabad) wrote :

This debdiff fix typo error and closes this patch.

Thanks!

Angel Abad (angelabad) on 2010-05-13
tags: added: patch
Daniel Hahler (blueyed) on 2010-05-15
Changed in vsftpd (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
importance: Medium → Low
Luke Faraone (lfaraone) on 2010-05-17
Changed in vsftpd (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vsftpd - 2.2.2-3ubuntu7

---------------
vsftpd (2.2.2-3ubuntu7) maverick; urgency=low

  * debian/vsftpd.upstart: Fix typo. Thanks Jürgen Kreileder.
    (LP: #577165)
 -- Angel Abad <email address hidden> Thu, 13 May 2010 20:48:52 +0200

Changed in vsftpd (Ubuntu):
status: In Progress → Fix Released
Angel Abad (angelabad) wrote :

Debdiff for lucid-proposed.

Thanks!

Changed in vsftpd (Ubuntu):
status: Fix Released → New
tags: added: lucid-proposed
C de-Avillez (hggdh2) wrote :

Hi Angel, thank you for the debdiff. Just one detail, the vsftpd task for Ubuntu is still fix released.

Changed in vsftpd (Ubuntu):
status: New → Fix Released
Thierry Carrez (ttx) wrote :

If you want to propose this fix for a Lucid SRU, please follow the steps described at:
https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

In particular, please update the description as described at Procedure step 2.

Thierry Carrez (ttx) wrote :

Unsubscribing sponsors, please resubscribe when a SRU report is ready (see previous comment for links)

Imre Gergely (cemc) on 2010-12-13
description: updated
Imre Gergely (cemc) on 2010-12-13
description: updated
Changed in vsftpd (Ubuntu Lucid):
status: New → Confirmed
Changed in vsftpd (Ubuntu Lucid):
assignee: nobody → Andres Rodriguez (andreserl)
status: Confirmed → In Progress
Angel Abad (angelabad) on 2011-02-26
Changed in vsftpd (Ubuntu Lucid):
importance: Undecided → Low
Changed in vsftpd (Ubuntu Lucid):
status: In Progress → Confirmed
assignee: Andres Rodriguez (andreserl) → nobody
importance: Low → Medium
importance: Medium → Low
Martin Pitt (pitti) wrote :

There are two conflicting vsftpd uploads in the lucid-proposed queue:

 vsftpd (2.2.2-3ubuntu6.1) lucid-proposed; urgency=low
 .
   * debian/vsftpd.postinst: (LP: #709194)
     - Update conditional to fix upgrade issue when user exists, but group does not

 vsftpd (2.2.2-3ubuntu6.1) lucid-proposed; urgency=low
 .
   [ Andres Rodriguez ]
   * debian/vsftpd.upstart:
     - Fix typo. Thanks to JÃŒrgen Kreileder (LP: #577165)
     - Fix start of vsftpd even if not in standalone mode. Thanks to
       Stephane Chazelas (LP: #648202)
 .
   [ Dustin Kirkland, Serge Hallyn ]
   * debian/vsftpd.postinst: Check that the group exists first, then the user,
     then try adding the user to the group. (LP: #629234, LP: #677764)

I rejected them both. Please reupload a merged version. Thanks!

Clint Byrum (clint-fewbar) wrote :

APPROVED: the package version 2.2.2-3ubuntu6.2 uploaded to lucid-proposed should be accepted.

Accepted vsftpd into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in vsftpd (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Imre Gergely (cemc) wrote :

Checked the package from -proposed and the typo is corrected in /etc/init/vsftpd.conf (emply -> empty). The packages upgrades ok, and /var/run/vsftpd/empty gets created at startup.

Looks like the fix is ok in Lucid.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vsftpd - 2.2.2-3ubuntu6.2

---------------
vsftpd (2.2.2-3ubuntu6.2) lucid-proposed; urgency=low

  * debian/vsftpd.upstart:
    - Fix typo. Thanks to Jürgen Kreileder (LP: #577165)
    - Fix start of vsftpd even if not in standalone mode. Thanks to
      Stephane Chazelas (LP: #648202)

  [ Dustin Kirkland, Serge Hallyn ]
  * debian/vsftpd.postinst: Check that the group exists first, then the user,
    then try adding the user to the group. (LP: #629234, LP: #677764)
 -- Andres Rodriguez <email address hidden> Wed, 13 Apr 2011 18:34:25 -0400

Changed in vsftpd (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase

>>> http://tusis.ru

- There is no reason to feel depressed if you, like so many other men today, have hit the rough spot of your sexual life when you cannot seem to be performing as well as you used to do. Your agitation and frustration are easily understood, and still you should know that with the modern development of worldwide pharmacological industries it is but natural that there is bound to be a solution for your own needs when it comes down to solving your erectile dysfunction problems.

- We suggest you getting erectile dysfunction drugs from our online drugstore cheaply, easily and without much to-do. You will always be taken care of and attended to with extreme care, and you will have the possibility of choosing from a wide range of erectile dysfunction products to find a solution that will best suit your particular needs.

- The whole world puts great trust in those famous diamond shaped pills, and if you are not an exception we would like to revise some basic points that speak in favor of putting your male health in the hands of those magical tablets.
Firstly, there is no need for regular therapy – those blue pills have to be taken directly before the planned sexual contact, and extra convenience shines through when you come to realize that the pills will not start working unless sufficient sexual stimulation is provided.

- Secondly, this erectile dysfunction solution is known for its extremely low adverse side effects profile, which makes it available for all age groups of patients. Besides, it really does not matter how old you are when it goes about taking erectile dysfunction pills – just make sure that you do not overdose, and they will work for you at their best!

- Finally, those fabulous pills do not only provide you with stable erection that can be maintained for as long as you need it – they also help you to achieve unheard sensitivity during the sexual act as well as make your genitals look much more sizey!

- Think of all those benefits of taking erectile dysfunction pills and the effect you can produce on your loved one – and do not hesitate to make your order and / or refills right away!

--- > http://tusis.ru < ---

 _V______C________L
 ___I_______I_______E
 _____A_______A_______V
 _______G_______L_______I
 _________R_______I_______T
 ___________A_______S_______R
 _____________________________A

   Like coffee can make your mind tuned for a day, Our male caplets can make your manhood ready for the real crazy night! We welcome you to our store and promises you to please you with lowered prices and valuable gifts regularly! Try this lovemaking madness!
-
 - - -
--------- http://tusis.ru
 - - -
-

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers