Ubuntu

vlc crashed with SIGSEGV in libebml::EbmlBinary::operator==()

Reported by RussianNeuroMancer on 2012-04-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Unknown
vlc (Ubuntu)
Medium
Unassigned

Bug Description

VLC crash when I try to playback video file. Second attempt was successful.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: vlc-nox 2.0.1-4
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Wed Apr 4 12:20:20 2012
ExecutablePath: /usr/bin/vlc
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcCmdline: /usr/bin/vlc video.mkv
ProcEnviron:
 LANGUAGE=ru_RU
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: vlc
Title: vlc crashed with SIGSEGV in libebml::EbmlBinary::operator==()
UpgradeStatus: Upgraded to precise on 2012-03-02 (33 days ago)
UserGroups: adm admin audio cdrom dialout libvirtd lpadmin plugdev sambashare

Changed in vlc (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Benjamin Drung (bdrung) on 2012-05-23
description: updated
visibility: private → public

Already fixed in upstream.

Changed in vlc (Ubuntu):
status: New → Fix Released
Benjamin Drung (bdrung) wrote :

Setting back to Fix Committed, because VLC 2.0.2 hasn't landed in Ubuntu yet.

Changed in vlc (Ubuntu):
status: Fix Released → Fix Committed
Changed in vlc:
milestone: none → 2.0.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.0.2-1

---------------
vlc (2.0.2-1) unstable; urgency=medium

  [ Edward Wang ]
  * New upstream release (Closes: #679625, #664279, LP: #689122, #936488,
    #942126, #971106, #972615, #973051, #987231, #995003, #998538).
    - Fix Ogg Heap buffer overflow. Thanks to Hugo Beauzée-Luyssen
  * Add the crystalhd plugin to the vlc distribution.
  * libcaca_plugin.so now depends on X11 in this release, so it must
    be installed under vlc (versus vlc-nox).

  [ Reinhard Tartler ]
  * Urgency set to medium because a security issue is fixed in this release

  [ Benjamin Drung ]
  * Add new plugins to vlc-nox:
    - crystalhd (Linux amd64 and i386 only)
    - directfb
    - fbosd (Linux only)
    - omxil (Linux only)
  * Add build dependencies for new plugins.
  * Add new symbols to libvlccore5.
  * Switch to debhelper 8.

 -- Benjamin Drung <email address hidden> Sat, 30 Jun 2012 18:39:41 +0200

Changed in vlc (Ubuntu):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in vlc:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.