Ubuntu

package vlc-nox 2.0.0-4 failed to install/upgrade: trying to overwrite '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2

Reported by mathieg2 on 2012-03-25
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
vlc (Debian)
Fix Released
Unknown
vlc (Ubuntu)
High
Benjamin Drung
Precise
High
Benjamin Drung

Bug Description

Seems to clash with another package vlc-data

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: vlc-nox 2.0.0-4
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Sun Mar 25 11:06:25 2012
ErrorMessage: trying to overwrite '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2
SourcePackage: vlc
Title: package vlc-nox 2.0.0-4 failed to install/upgrade: trying to overwrite '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2
UpgradeStatus: Upgraded to precise on 2012-02-26 (27 days ago)

mathieg2 (graeme-salsaholics) wrote :
tags: removed: need-duplicate-check
mathieg2 (graeme-salsaholics) wrote :

As a workaround, I have run the following commands:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/vlc-nox_2.0.1-2_i386.deb

sudo apt-get -f install

vlc seems to be working ok now - but I am not sure what state ubuntu is in as a result of this override.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vlc (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Just needs a Breaks/Replaces

Changed in vlc (Ubuntu Precise):
importance: Undecided → Medium
status: Confirmed → In Progress
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) wrote :

This actually seems like it's going to need more than breaks/replaces, giving to bdrung since he sync'd this.during the freeze

Changed in vlc (Ubuntu Precise):
assignee: Micah Gersten (micahg) → Benjamin Drung (bdrung)
importance: Medium → High
milestone: none → ubuntu-12.04-beta-2
status: In Progress → Triaged
Micah Gersten (micahg) wrote :

I don't think this technically affects the images, but will affect people trying to upgrade.

tags: added: rls-mgr-p-tracking
Changed in vlc (Debian):
status: Unknown → New
Benjamin Drung (bdrung) wrote :

The location of the files haven't change since 2.0.0-4. I still fail to see what triggers this issue. Can someone with this bug run "ls -al /usr/share/doc/vlc*" and post the output?

Unfortunately, I did a manual workaround - I forced the overwrite - so my ls-al would be useless to you I guess.

Graeme
Sent from my ASUS Eee Pad

Benjamin Drung <email address hidden> wrote:

>The location of the files haven't change since 2.0.0-4. I still fail to
>see what triggers this issue. Can someone with this bug run "ls -al
>/usr/share/doc/vlc*" and post the output?
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/964449
>
>Title:
> package vlc-nox 2.0.0-4 failed to install/upgrade: trying to overwrite
> '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2
>
>Status in “vlc” package in Ubuntu:
> Triaged
>Status in “vlc” source package in Precise:
> Triaged
>Status in “vlc” package in Debian:
> New
>
>Bug description:
> Seems to clash with another package vlc-data
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: vlc-nox 2.0.0-4
> ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
> Uname: Linux 3.2.0-20-generic-pae i686
> NonfreeKernelModules: nvidia
> ApportVersion: 1.95-0ubuntu1
> Architecture: i386
> Date: Sun Mar 25 11:06:25 2012
> ErrorMessage: trying to overwrite '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2
> SourcePackage: vlc
> Title: package vlc-nox 2.0.0-4 failed to install/upgrade: trying to overwrite '/usr/share/doc/vlc-nox', which is also in package vlc-data 2.0.1-2
> UpgradeStatus: Upgraded to precise on 2012-02-26 (27 days ago)
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/964449/+subscriptions

James Mitchell (jmit) wrote :

I also did a manual workround using dpkg to remove vlc, then reinstall. Is the file listing still going to be useful to you?

Benjamin Drung (bdrung) wrote :

No, I the file listing is only interesting on a system that is untouched after the install failure.

Micah Gersten (micahg) wrote :

ls -asl /usr/share/doc/vlc*
0 lrwxrwxrwx 1 root root 7 Mar 24 10:04 /usr/share/doc/vlc -> vlc-nox
0 lrwxrwxrwx 1 root root 3 Feb 2 2010 /usr/share/doc/vlc-nox -> vlc
0 lrwxrwxrwx 1 root root 7 Sep 6 2010 /usr/share/doc/vlc-plugin-notify -> vlc-nox
0 lrwxrwxrwx 1 root root 7 Jul 22 2010 /usr/share/doc/vlc-plugin-pulse -> vlc-nox

/usr/share/doc/vlc-data:
total 176
  4 drwxr-xr-x 2 root root 4096 Mar 26 15:01 .
136 drwxr-xr-x 2972 root root 135168 Mar 26 15:09 ..
  4 -rw-r--r-- 1 root root 1807 Mar 24 10:07 changelog.Debian.gz
 28 -rw-r--r-- 1 root root 25782 Mar 23 13:02 copyright
  4 -rw-r--r-- 1 root root 1870 Mar 23 10:45 NEWS.Debian.gz

Benjamin Drung (bdrung) wrote :

The problem is that /usr/share/doc/vlc-nox shouldn't be a symlink, but a directory.

Benjamin Drung (bdrung) on 2012-03-28
Changed in vlc (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in vlc (Debian):
status: New → Fix Released
Changed in vlc (Ubuntu Precise):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 2.0.1-3

---------------
vlc (2.0.1-3) unstable; urgency=high

  * Replace symlink by directory in /usr/share/doc/vlc-nox.
    (Closes: #665743, LP: #964449)

 -- Benjamin Drung <email address hidden> Wed, 28 Mar 2012 13:29:37 +0200

Changed in vlc (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.