vlc stops playing audio after pause/resume or seek

Bug #696841 reported by Alex Shulgin on 2011-01-03
168
This bug affects 36 people
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Undecided
Unassigned
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: vlc

Audio output blocks after pausing and then resuming playback. It also blocks after seeking (forward or backward) through the stream.

If I change the audio track, it starts playing audio again. This happens on every video/audio file I've tried. Starts to happen after dist-upgrade to maverick.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: vlc 1.1.4-1ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic x86_64
Architecture: amd64
CheckboxSubmission: 714519e8c9d4d43b21e4cc980d2fffe5
CheckboxSystem: c69722ecac764861be52925fa50b4dcc
Date: Mon Jan 3 17:25:51 2011
ProcEnviron:
 PATH=(custom, username)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: vlc

Alex Shulgin (alex-shulgin) wrote :
Rémi Denis-Courmont (rdenis) wrote :

Unfortunately, I am unable to reproduce your problem, and it is evident that we would have gotten a lot of bug reports if it affected many users. Please provide the VLC debug logs.

Changed in vlc (Ubuntu):
status: New → Incomplete
Alex Shulgin (alex-shulgin) wrote :
Download full text (18.5 KiB)

Here's a sample of running with `-vv' on the file from this URL: http://www.openbsd.org/songs/song44.ogg

The effects are the same for mp3 or video files: stops playing audio after a resume. <SpaceBar> denotes me pressing space bar to pause, then to resume playback.

$ vlc song44\ -\ Trial\ of\ the\ BSD\ Knights.ogg -vv
VLC media player 1.1.4 The Luggage (revision exported)
[0x11d3120] main libvlc debug: VLC media player - 1.1.4 The Luggage
[0x11d3120] main libvlc debug: Copyright © 1996-2010 the VideoLAN team
[0x11d3120] main libvlc debug: revision exported
[0x11d3120] main libvlc debug: configured with ./configure '--enable-static' '--build=x86_64-linux-gnu' '--config-cache' '--disable-maintainer-mode' '--disable-silent-rules' '--disable-update-check' '--enable-fast-install' '--prefix=/usr' '--sysconfdir=/etc' '--with-binary-version=1ubuntu1.1' '--enable-a52' '--enable-aa' '--enable-bonjour' '--enable-caca' '--enable-dca' '--enable-dirac' '--enable-dvb' '--enable-dvbpsi' '--enable-dvdnav' '--enable-faad' '--enable-flac' '--enable-fluidsynth' '--enable-freetype' '--enable-fribidi' '--enable-ggi' '--enable-gnutls' '--enable-jack' '--enable-kate' '--enable-libass' '--enable-libmpeg2' '--enable-libproxy' '--enable-libxml2' '--enable-lirc' '--enable-live555' '--enable-mad' '--enable-mkv' '--enable-mod' '--enable-mozilla' '--enable-mpc' '--enable-mtp' '--enable-mux_ogg' '--enable-ncurses' '--enable-notify' '--enable-ogg' '--enable-pulse' '--enable-qt4' '--enable-realrtsp' '--enable-schroedinger' '--enable-sdl' '--enable-shout' '--enable-skins2' '--enable-smb' '--enable-speex' '--enable-svg' '--enable-taglib' '--enable-theora' '--enable-twolame' '--enable-upnp' '--enable-vcd' '--enable-vcdx' '--enable-vorbis' '--enable-x264' '--enable-zvbi' '--with-kde-solid=/usr/share/kde4/apps/' '--with-mozilla-pkg=libxul' '--disable-dxva2' '--disable-gnomevfs' '--disable-goom' '--disable-osso_screensaver' '--disable-portaudio' '--disable-projectm' '--disable-sqlite' '--disable-telx' '--enable-alsa' '--enable-atmo' '--enable-dc1394' '--enable-dv' '--enable-libva' '--enable-pvr' '--enable-udev' '--enable-v4l' '--enable-v4l2' '--enable-svgalib' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[0x11d3120] main libvlc debug: translation test: code is "C"
[0x11d3120] main libvlc debug: checking plugin modules
[0x11d3120] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins-04081e-3e8.dat
[0x11d3120] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
[0x11d3120] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins-04081e-3e8.dat
[0x11d3120] main libvlc debug: module bank initialized (393 modules)
[0x11d3120] main libvlc debug: opening config file (/home/user/.config/vlc/vlcrc)
[0x11d3120] main libvlc debug: CPU has capabilities MMX MMXEXT SSE SSE2 SSE3 SSSE3 FPU
[0x11d3120] main libvlc debug: looking for memcpy module: 3 candidates
[0x11d3120] main libvlc debug: using memcpy module "memcpymmxext"
[0x12bee90] main input debug: Creating an input for 'Media Library'
[0x12bee90] main input debug: Input is a meta file: disabling unneeded options
[0x12bee90] main input...

luca_ing (luca-ingianni) wrote :

I see sort of similar behaviour. No sound after pause. Seeking is OK, though.

kreig jones (kreigjones) wrote :

I had the same problem. No sound after a pause, but seek worked.
 I soon realized that VLC somehow reverted to using ALSA for sound output after upgrade. After changing from ALSA to Pulseaudio resume worked fine.

Alex Shulgin (alex-shulgin) wrote :

I confirm problem gone after installing vlc-plugin-pulse.

Rémi Denis-Courmont (rdenis) wrote :

This "bug" is a conflict between VLC-ALSA and the PulseAudio daemon. More of a misconfigured VLC than a bug really.

That said, I don't know why the PulseAudio output plugin is not part of the base VLC package in Ubuntu.

Changed in vlc (Ubuntu):
status: Incomplete → Opinion
Micah Gersten (micahg) wrote :

vlc-plugin-pulse is recommended by vlc

nickanor (sostentado) wrote :

I also encountered this problem but i guess i solved this just by installing libvlccore-dev. Worked perfect again.

libvlccore-dev : Please install this...

Benjamin Drung (bdrung) wrote :

It makes no sense to me that installing libvlccore-dev is a working solution. This package contains only development files.

Helder (he7d3r) wrote :

Still happening on Ubuntu 12.10

Benjamin Drung (bdrung) wrote :

H2G, have you installed vlc-plugin-pulse and selected pulseaudio as output module? If it still fails, can you please attach the output of vlc run with -vvv?

BB (benkasminbullock) wrote :

This bug has been happening for me since I installed VLC media player. The workaround is to change the audio channel after resuming the video. I have attached the output of the following command:

vlc -vvv > vlc-bug-log 2>&1

BB (benkasminbullock) wrote :

P.S., I have installed vlc-plugin-pulse and selected pulseaudio for the audio output.

Rémi Denis-Courmont (rdenis) wrote :

@BB: The log shows you are using ALSA, not PulseAudio.

That being said, I really think Ubuntu should include the PulseAudio plugins in VLC by default and make the ALSA ones optional, not vice versa.

BB (benkasminbullock) wrote :

@Remi: on the audio menu, the default says "Playback/recording through the Pulse audio server". That might be ALSA for all I know but it says that. I'll post a screenshot if you like. Even if I change it to "PulseAudio Sound Server", the bug remains.

Benjamin Drung (bdrung) wrote :

Rémi, vlc recommends vlc-plugin-pulse and therefore vlc-plugin-pulse is installed by default.

Rémi Denis-Courmont (rdenis) wrote :

@BB: that's PulseAudio *through* ALSA, as opposed to native PulseAudio. You did select ALSA. That's the whole point.

@bdrung: Recommends can be disabled. Putting the ALSA input & output in the default package, and the PulseAudio input & output in a separate package is not much short of idiotic for a PulseAudio-based distribution. That is the main reason why this bug hit in the first place.

BB (benkasminbullock) wrote :

This is a log of the same bug happening with the selection of Audio/Audio device/PulseAudio Sound Server" from the menu.

This is on Ubuntu 12.04. I only upgraded from 10. Ubuntu because I hoped that this problem would be fixed! This is a very old bug.

BB (benkasminbullock) wrote :

@Remi:

> @BB: that's PulseAudio *through* ALSA, as opposed to native PulseAudio. You did select ALSA. That's the whole point.

I didn't select anything, that is the default I get. The only option I can see is to use "PulseAudio Sound System" under the "Audio"/"Audio Device" menu. The bug is the same under those circumstances, as you can see from the attachment to the comment immediately above this one.

Rémi Denis-Courmont (rdenis) wrote :

ONCE AGAIN: do NOT use the ALSA audio output plugin!!!!

Tools -> Preferences -> Audio -> Audio output -> "Default" or "PulseAudio audio output", NOT "ALSA audio output"

Or reset your preferences.

Rémi Denis-Courmont (rdenis) wrote :

User configuration error.

Changed in vlc (Ubuntu):
status: Opinion → Invalid
BB (benkasminbullock) wrote :

@Remi: I did as you suggest and confirm that this works. However closing the bug as "Invalid" and marking it as "user configuration error" is irresponsible. I certainly didn't configure it that way since I didn't even know about the configuration until now. The VLC media player came like this on Ubuntu and someone somewhere set it up like this.

Rémi Denis-Courmont (rdenis) wrote :

Yes, you did. The default is default, not ALSA.

You can try with a clean Ubuntu installation if you won't believe it.

BB (benkasminbullock) wrote :

> Yes, you did.

No, I didn't. I didn't even know this configuration existed until you wrote about it. I've never even looked under that tools menu. You are just trying to shift responsibility for the bug by making up lies, which is irresponsible behaviour.

Rémi Denis-Courmont (rdenis) wrote :

So your cat did it... That is not an excuse for calling a volunteer contributor a liar and an irresponsible.

You are welcome to my kill file. Plonk.

BB (benkasminbullock) wrote :

> That is not an excuse for calling a volunteer contributor a liar and an irresponsible.

You accused me of lying first, guy. What's your excuse for calling a volunteer bug reporter a liar?

I can't imagine how many people experienced this bug and just stopped using VLC Media player, or stopped using Linux, without reporting it. And what happens to the people who report it? You accuse them of lying and then tell lies yourself.

If you're ever wondering to yourself why people don't use Linux, look at the above conversation.

Scott Kitterman (kitterman) wrote :

Back to the original problem ... (honestly, such arguments are not productive):

Does anyone have this problem when vlc-plugin-pulse is installed? It seems from reading the bug history that they don't, but that's not entirely clear to me.

On 23 November 2012 08:18, Scott Kitterman <email address hidden> wrote:
> Back to the original problem ... (honestly, such arguments are not
> productive):

I have never configured this menu in the way I was accused of doing, I
did not know that menu existed until yesterday.

> Does anyone have this problem when vlc-plugin-pulse is installed? It
> seems from reading the bug history that they don't, but that's not
> entirely clear to me.

I have vlc-plugin-pulse installed and the bug was happening to me
until I got Rene's fix (on a menu I didn't even know existed until
yesterday). I installed vlc media player using the default method on
Ubuntu 10.something and then recently upgraded to 12.04. I think I
reinstalled VLC media player at that point. As I noted the main reason
to upgrade Ubuntu was to try to get rid of this annoying bug in VLC
media player. I burned a compact disc and sat waiting for upgrade for
hours and had to do all kinds of work, just trying to fix a bug which
was in a menu I had never seen before in my life until yesterday. I'd
also tried various reinstallations of VLC media player before that,
using the advice on the VLC media player website.

It looks like the configuration file was left over from the
10.something Ubuntu settings.

And, just in case I forgot to mention it, I had not seen that
configuration menu under Tools/Preferences/Audio, and did not know it
existed until yesterday. I hope that is clear.

pazuzuthewise (pazuzuthewise) wrote :

I've encountered this bug both in vlc 2.0.6 and 2.0.7 (the last one installed from a ppa), under kubuntu 13.04 x64. I didn't install initially vlc-plugin-pulse, and in the vlc settings menu audio output was set to default (not alsa). So this cannot be a case of wrong configuration made by the user, as was suggested above.

After installing vlc-plugin-pulse and selecting pulse as audio output in vlc, all seems to be ok.

These settings should be default. Maybe this is not really a bug, but a configuration error, though not from the part of the user, since the default settings are the cause of it, but from the packager.

pazuzuthewise (pazuzuthewise) wrote :

Forgot to mention that mine is a fresh install, without a separate /home partition, so it cannot be the case of leftover configuration files.

Amish Naidu (amhndu) wrote :

I installed the vlc-plugin-pulse on my Ubuntu 12.04 with the "Default" audio output settings and now pausing,seeking everything works just fine.

Philip.Rowney (philip-rowney) wrote :

I have a similar problem...

I have tried adding the modules as described via the standard repos, to be told all is up-to-date.

Seeking does not affect the audio at all. But, If I pause I have to select audio->none, then audio->track1 for audio to return.
I HAVE a 'vlc -vv' output.

NB ) de-selecting the video video->none ALSO re-enables the audio!

********************************* vlc -vv STDOUT *********************************************************
<EMPTY>
************************************ END ****************************************************************

********************************* vlc -vv STDERR *********************************************************
<ATTACHED>
************************************ END ****************************************************************

I used to be a Software Test Development Engineer ;0)

More data

'cat /etc/lsb-release'
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Ubuntu 12.10"

firesock (firesock-ml) wrote :

Hi!
Changing at:
Tools -> Preferences -> Audio -> Audio output -> PulseAudio

Solved the problem. I guess there is something to review in order to leave this option as a default to avoid this problem.

Thank you all!

John Crockett (john-phx) wrote :

I find it astonishing that this bug is marked "invalid."

Here I sit, using Ubuntu 14.04 and VLC 2.1.4 and I have the exact problem described above. For me, sound does not stop when resuming from pause. It only stops when I "click forward," mostly on mp4s but not always. I can get the sound back by disabling audio and re-enabling it.

I have tried all the "fixes" described above and still have the same problem. I am happy to provide any tech info you-all may need to diagnose, but you will need to tell me what you need and how I can find it.

Also, to the MANY others who have this issue (there are hundreds of thousands of returns on the serach "VLC Sound stops when skipping through a video"), you are neither alone nor crazy.

To Remi Denis-Courmont: Thank you for such an amazing product it is by far my favorite and the best media player available. I will continue to use it despite the minor annoyance this bug represents. I am a fellow programmer, so I understand the thousands (likely tens of thousands) of person-hours that has gone into this and am grateful to you and the other voluteers. My sole purpose here is to make you aware of a problem so you can make a great application even better.

BB (benkasminbullock) wrote :

On 19 July 2014 11:11, John Crockett <email address hidden> wrote:

> Also, to the MANY others who have this issue (there are hundreds of
> thousands of returns on the serach "VLC Sound stops when skipping
> through a video"), you are neither alone nor crazy.

Nor did you or your cat change the default configuration.

> To Remi Denis-Courmont: Thank you for such an amazing product it is by
> far my favorite and the best media player available.

Bill Gates also wishes to thank Remi. Also the people at Apple computers.

Mario Trams (mario-trams) wrote :

I just observed the same issue in Ubuntu 14.04.1 with VLC 2.1.4.

I don't know where the problem originates from (whether VLC or sound subsystem) but I was able to
work around it by setting the audio output of VLC (Tools->Preferences->Audio) from "Automatic"
to "ALSA audio output".

Setting it to "PulseAudio" as it apearently worked for "firesock" did not work for me.

@Mario Trams (mario-trams)
It seems that switiching to Alsa is the only workaround. This has been long affecting bug for me in Trusty. No update from either VLC or Pulse : (

firesock (firesock-ml) wrote :

Hi!!
I want to review that I selected ALSA audio output and then PulseAudio Sound Server.
It seems to solve the issue for now.

Regards!

geobijes (geobijes) wrote :

I can confirm this persists in Ubuntu 14.04 and vlc 2.1.4 - after seeking, vlc may or may not play sound afterwards. Sometimes I have to repeatedly seek again and again so that there's sound in the video.

Many thanks to firesock for the workaround. Selecting "ALSA audio output" and "PulseAudio Sound Server" seems to fix the issue. Just make sure to restart vlc after changing the setting, it doesn't seem to be applied until you do.

This is also a problem in Debian jessie, and vlc-plugin-pulse is now a transitional dummy package because the pulse plugin has been included by default.

Benjamin Xiao (ben-r-xiao) wrote :

This problem still exists on Vivid with VLC 2.2.0-rc2 and the Pulse output module. Switching to ALSA works as a workaround, but this bug should be marked as valid as the default install of VLC uses Pulse.

Fifoxtasy (philipp-foerster) wrote :

i can confirm this bug
still true for 14.10 and VLC 2.2.0-rc2
ALSA work around works for me as well
tried with fresh install as well

Changed in vlc (Ubuntu):
status: Invalid → Confirmed
Vahid Mardani (vahid-mardani) wrote :

I have the exact same problem. It seems we don't have any relaxation in the open-source world !

Vahid Mardani (vahid-mardani) wrote :

the Alsa and pulseaudio are the bad & ugly gays. all stuff relating to those libraries are not working properly.

hhfischer (hhfischer) wrote :

same problem with kubuntu 14.04.2
updated vlc to 2.2 rc2 hoping this would solve the problem: didn't

red this thread: switched from audio default to pulseaudio: nothing changed
switched from pulseaudio to alsa : nothing changed
swiched from alsa back to pulseaudio > seams to work at fist but then:

tested further:
this fix helps only when seekin _forward_
if i seek backwards the problem exists furher.
But: if audio is "muted" because of seeking backwards and then playing
it seems to help one time seeking forward and play: audio comes back

Jon (ubuntu-azrider) wrote :

Kubuntu 14.04
VLC 2.2.0

Same problem for me was fixed with:
Tools/Preferences/Audio...
Output Module: ALSA audio output
Device: PulseAudio Server

Hope this helps

Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Changed in vlc:
milestone: none → 2.2.2
status: New → Fix Released
Shlomi Fish (shlomif-gmail) wrote :

Can you please share some details about what was the fix to this problem and where we can find it? We ran into it in Mageia Linux as well:

https://bugs.mageia.org/show_bug.cgi?id=16376

Rémi Denis-Courmont (rdenis) wrote on 2012-11-22: #22
User configuration error.

Changed in vlc (Ubuntu):
status: Opinion → Invalid

Rémi Denis-Courmont (rdenis) wrote on 2012-11-22: #26
So your cat did it... That is not an excuse for calling a volunteer contributor a liar and an irresponsible.

You are welcome to my kill file. Plonk.

Rémi Denis-Courmont (rdenis) on 2015-04-26
Changed in vlc (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Changed in vlc:
milestone: none → 2.2.2
status: New → Fix Released

Apparently the cat's fix took 4 years.

Scaramanga (scaramanga) wrote :

I've had this issue since I upgraded to Xubuntu 14.04. I followed Jon's instructions and cannot reproduce this issue anymore.
My VLC version is 2.1.6.

s7ian (s7ian) wrote :

This is mine output when I use the search bar:

***************When sound disappear when using search bar:***************

[0xb4704a28] mp4 demux debug: elst (0) gives 809040ms (movie)-> 809107ms (track)
[0xb4704a28] mp4 demux debug: track[Id 0x1] using Sync Sample Box (stss)
[0xb4704a28] mp4 demux debug: stts gives 24273 --> 24167 (sample number)
[0xb4704a28] mp4 demux debug: elst (0) gives 809040ms (movie)-> 809040ms (track)
[0xb4704a28] mp4 demux debug: track[Id 0x2] does not provide Sync Sample Box (stss)
[0x98c97b8] pulse audio output debug: underflow
[0xaa227c50] main input debug: Buffering 0%
[0xa13a0340] main decoder debug: End of audio preroll
[0x98c97b8] pulse audio output debug: underflow
[0xaa227c50] main input debug: Buffering 0%
[0xaa227c50] main input debug: Buffering 33%
[0xaa227c50] main input debug: Buffering 66%
[0xaa227c50] main input debug: Buffering 99%
[0xaa227c50] main input debug: Stream buffering done (399 ms in 21 ms)
[0xa1394e98] main decoder debug: End of video preroll
[0xa1394e98] main decoder debug: Received first picture
[0xaa227c50] main input debug: Decoder buffering done in 1135 ms
[0x98c31f8] main video output warning: picture is too late to be displayed (missing 38 ms)
[0x98c31f8] main video output debug: picture might be displayed late (missing 5 ms)

***************When sound does not disappear when using search bar: ***************

[0xb4704a28] mp4 demux debug: elst (0) gives 1725953ms (movie)-> 1726020ms (track)
[0xb4704a28] mp4 demux debug: track[Id 0x1] using Sync Sample Box (stss)
[0xb4704a28] mp4 demux debug: stts gives 51780 --> 51732 (sample number)
[0xb4704a28] mp4 demux debug: elst (0) gives 1725953ms (movie)-> 1725953ms (track)
[0xb4704a28] mp4 demux debug: track[Id 0x2] does not provide Sync Sample Box (stss)
[0xaa227c50] main input debug: Buffering 0%
[0x98c97b8] pulse audio output debug: underflow
[0xaa227c50] main input debug: Buffering 0%
[0xaa227c50] main input debug: Buffering 33%
[0xaa227c50] main input debug: Buffering 66%
[0xa13a0340] main decoder debug: End of audio preroll
[0x98c97b8] pulse audio output debug: underflow
[0xaa227c50] main input debug: Buffering 99%
[0xaa227c50] main input debug: Stream buffering done (399 ms in 40 ms)
[0xaa2462c0] main vout display debug: auto hiding mouse cursor
[0xa1394e98] main decoder debug: End of video preroll
[0xa1394e98] main decoder debug: Received first picture
[0xaa227c50] main input debug: Decoder buffering done in 588 ms
[0x98c97b8] pulse audio output debug: underflow
[0x98c97b8] main audio output warning: playback way too early (-603602): playing silence
[0x98c97b8] main audio output debug: inserting 28972 zeroes

So every time VLC reports:

"[0x98c97b8] main audio output warning: playback way too early (-603602): playing silence"

... it is able to play sound again after use of the search bar.

***************/end of report. no conclution. ***************

s7ian (s7ian) wrote :

oh. yes. The system is
Ubuntu 14.04, 32 and 64
VLC 2.1.16

s7ian (s7ian) wrote :

um that should be VLC 2.1.6

g (garethic) wrote :

I had this problem on Kubuntu 14, VLC 2.2.1
Audio was lost after seeking forward or back through the video, especially large ones.
It fixed when I changed the Audio Preferences(Simple): Output Module from Automatic to ALSA audio output, & Device to 'Playback/recording through PulseAudio server'. then restarting VLC.
Strangely, changing to those options in Preferences (All) did not fix the problem.

Dave Allan (dave-b-allan) wrote :

I'm in Kubuntu 14.04, can confirm this bug in VLC with vlc-plugin-pulse installed and with pulse selected as the audio output module. Switching to ALSA corrected it for me.

Thanks everyone, keep up the your amazing contributions to the open source world :-)

s7ian (s7ian) wrote :

Ubuntu 14.04 here. Can confirm that the Switching to ALSA actually
seems to work. Thank You.

On 1/17/16, Dave Allan <email address hidden> wrote:
> I'm in Kubuntu 14.04, can confirm this bug in VLC with vlc-plugin-pulse
> installed and with pulse selected as the audio output module. Switching
> to ALSA corrected it for me.
>
> Thanks everyone, keep up the your amazing contributions to the open
> source world :-)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/696841
>
> Title:
> vlc stops playing audio after pause/resume or seek
>
> Status in VLC media player:
> Fix Released
> Status in vlc package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: vlc
>
> Audio output blocks after pausing and then resuming playback. It also
> blocks after seeking (forward or backward) through the stream.
>
> If I change the audio track, it starts playing audio again. This
> happens on every video/audio file I've tried. Starts to happen after
> dist-upgrade to maverick.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: vlc 1.1.4-1ubuntu1.1
> ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
> Uname: Linux 2.6.35-24-generic x86_64
> Architecture: amd64
> CheckboxSubmission: 714519e8c9d4d43b21e4cc980d2fffe5
> CheckboxSystem: c69722ecac764861be52925fa50b4dcc
> Date: Mon Jan 3 17:25:51 2011
> ProcEnviron:
> PATH=(custom, username)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: vlc
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/vlc/+bug/696841/+subscriptions
>

Filofel (filofel) wrote :

FWIW:

14.04.3 x32, vlc 2.2.1:
Using "Reset Preferences" in VLC recreates the problem. This would indicate that the default config exhibits it.
And indeed, I initially hit the problem for the very first time after upgrading my machine from Ubuntu 12.04.x LTS to 14.04.3 LTS.

The fix suggested above (output module -> ALSA, Device -> PulseAudio Sound Server) still works.

Changed in vlc (Ubuntu):
status: Confirmed → Fix Released
Adam Niedling (krychek) wrote :

Why did you set it to fix released??

Adam Niedling (krychek) wrote :

Can an admin please set this bug back to Confirmed? Amr had no reason to change it and now we can't change it back...

Andrew (sl4rtyb4rtf4st) wrote :

I have had this issue for years, strange enough is this the first time I took the time to see if there was a fix. I had the attitude that with free software you take the slight irritations with the good...

Most of the "fixes" in this thread did nothing for me, until I reached the fix which fixed the issue for me:
tools -> audio -> Output module -> ALSA audio output
        -> Device -> Playback/recoding through the PulseAudio sound server

Wow that was a relatively easy fix for years worth of shift arrow pressing and mild annoyance.
Thanks.

DaDummy (dadummy) wrote :

Kubuntu 17.10, VLC 2.2.6 here. I encountered a slightly different variant of this issue.

In my case audio files (mp3) would always start playing muted in vlc. When I clicked the mute control in the lower right corner of the VLC application it would correctly unmute and play this file. As soon as another file would start playing vlc would then revert to muted.

I tried the various solutions mentioned on this thread and found that switching the output module to ALSA, selecting any of the two PulseAudio devices available and then restarting VLC reproducibly fixes the issue.

Switching the output module back to PulseAudio and restarting VLC reproducibly makes the erratic behavior described above appear again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.